Issue 124848 - graphic/OLE read errors
Summary: graphic/OLE read errors
Status: CLOSED DUPLICATE of issue 124717
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.1.0
Hardware: All Windows 7
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2014-05-07 16:43 UTC by TAB
Modified: 2017-05-20 10:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
file that had errors before OO was reloaded (397.76 KB, application/vnd.oasis.opendocument.text)
2014-05-07 16:43 UTC, TAB
no flags Details
file where most graphics disappeared (360.89 KB, application/vnd.oasis.opendocument.text)
2014-05-07 16:45 UTC, TAB
no flags Details
file is OK (371.37 KB, application/vnd.oasis.opendocument.text)
2014-05-07 19:14 UTC, TAB
no flags Details
file where most graphics disappeared (322.38 KB, application/vnd.oasis.opendocument.text)
2014-05-07 19:15 UTC, TAB
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description TAB 2014-05-07 16:43:17 UTC
Created attachment 83351 [details]
file that had errors before OO was reloaded

OO 4.1 has new bug that did not exist in 4.0.1.
After changing graphic Fig.30 (p.2) in SurfM.odt, all other graphics suffered ReadErrors.
	So, I saved the documemt under a new name (SurfMa.odt) and re-read SurfM.odt. Now, one graphic (Fig·0) was read properly, as well as Fig·30, but all others had 'Graphic cannot be displayed' errors.
	After closing OO and reloading it, the SurfM.odt was re-read correctly (good!) but all graphics were blank in SurfMa.odt, without any error message.
	It's hard to reproduce, but you could check the attached files, and what was changed between v.4.0.1 and 4.1.0.
Comment 1 TAB 2014-05-07 16:45:08 UTC
Created attachment 83352 [details]
file where most graphics disappeared
Comment 2 Rainer Bielefeld 2014-05-07 17:51:28 UTC
I see the effect with "AOO 4.1.0 Release – German UI / German locale [AOO410m18(Build:9764)  -   Rev. 1589052 2014-04-22 11:43:54]" on German WIN7 Home Premium (64bit)", “historic” 4. User Profile used for all predecessor versions: in SurfMa.odt several objects (for example Fig. 20) are missing. But I do not see "Read error" boxes.

Vague suspect: related to "Issue 124717 Embedded GDI Metafiles replaced by "Read Error" box"?

@reporter:
We will need some more information concerning 1 missing object, for example Fig. 20. What kind of object from what source is it? How ha it been inserted?
Tooltip for frame at Fig. 20  shows a hyplerlink to samd folder file QDsq.igr. Is the document related to INTERGRAPH sketches?
Comment 3 TAB 2014-05-07 19:14:23 UTC
Created attachment 83353 [details]
file is OK
Comment 4 TAB 2014-05-07 19:15:08 UTC
Created attachment 83354 [details]
file where most graphics disappeared
Comment 5 Oliver-Rainer Wittmann 2014-05-08 10:51:44 UTC
(In reply to TAB from comment #0)
> Created attachment 83351 [details]
> file that had errors before OO was reloaded
> 
> OO 4.1 has new bug that did not exist in 4.0.1.
> After changing graphic Fig.30 (p.2) in SurfM.odt, all other graphics
> suffered ReadErrors.
> 	So, I saved the documemt under a new name (SurfMa.odt) and re-read
> SurfM.odt. Now, one graphic (Fig·0) was read properly, as well as Fig·30,
> but all others had 'Graphic cannot be displayed' errors.
> 	After closing OO and reloading it, the SurfM.odt was re-read correctly
> (good!) but all graphics were blank in SurfMa.odt, without any error message.
> 	It's hard to reproduce, but you could check the attached files, and what
> was changed between v.4.0.1 and 4.1.0.

@TAB:
What do you mean by "changing graphic Fig.30 (p.2)"?
Did you changed its size?
Did you replaced it?
A description of the steps you performed to 'change the graphic' would help me to reproduce and fix the defect. Thanks in advance.
Comment 6 TAB 2014-05-09 14:58:37 UTC
(In reply to Rainer Bielefeld from comment #2)
> I see the effect with "AOO 4.1.0 Release – German UI / German locale
> [AOO410m18(Build:9764)  -   Rev. 1589052 2014-04-22 11:43:54]" on German
> WIN7 Home Premium (64bit)", “historic” 4. User Profile used for all
> predecessor versions: in SurfMa.odt several objects (for example Fig. 20)
> are missing. But I do not see "Read error" boxes.
> 
> Vague suspect: related to "Issue 124717 Embedded GDI Metafiles replaced by
> "Read Error" box"?
> 
> @reporter:
> We will need some more information concerning 1 missing object, for example
> Fig. 20. What kind of object from what source is it? How ha it been inserted?
> Tooltip for frame at Fig. 20  shows a hyplerlink to samd folder file
> QDsq.igr. Is the document related to INTERGRAPH sketches?

Graphics are all from INTERGRAPH SmartSketch, inserted in the odt frame by copy (from SmartSketch) and paste.
Comment 7 TAB 2014-05-09 15:02:34 UTC
(In reply to Oliver-Rainer Wittmann from comment #5)
> (In reply to TAB from comment #0)
> > Created attachment 83351 [details]
> > file that had errors before OO was reloaded
> > 
> > OO 4.1 has new bug that did not exist in 4.0.1.
> > After changing graphic Fig.30 (p.2) in SurfM.odt, all other graphics
> > suffered ReadErrors.
> > 	So, I saved the documemt under a new name (SurfMa.odt) and re-read
> > SurfM.odt. Now, one graphic (Fig·0) was read properly, as well as Fig·30,
> > but all others had 'Graphic cannot be displayed' errors.
> > 	After closing OO and reloading it, the SurfM.odt was re-read correctly
> > (good!) but all graphics were blank in SurfMa.odt, without any error message.
> > 	It's hard to reproduce, but you could check the attached files, and what
> > was changed between v.4.0.1 and 4.1.0.
> 
> @TAB:
> What do you mean by "changing graphic Fig.30 (p.2)"?
> Did you changed its size?
> Did you replaced it?
> A description of the steps you performed to 'change the graphic' would help
> me to reproduce and fix the defect. Thanks in advance.

I forget. Likely, I changed the frame size and re-pasted the graphic into it. Or, I pasted a new version of the graphic.
Comment 8 Rainer Bielefeld 2014-05-09 15:17:13 UTC
(In reply to TAB from comment #7)
That might match with the other observations. I know that GDI Metafile is default for paste from  WIN Paintbrush . May be for Copy / Paste from INTERGRAPH SmartSketch either? So TAB would have got GDIs into his documents, what like to vanish under particular circumstances (what circumstances currently is completely unknown for me).
Comment 9 Rainer Bielefeld 2014-05-15 04:17:50 UTC
I now am sure that his problem is the same as Issue 124717. Unzipped document "SurfM"  in subfolder "Pictures" already contains lots of pictures.bmp, what in reality are .svm with wrong name extension.bmp (for example 200000D800004F7B00004DEFB0EBC5CA.bmp), what is characteristic for the problem. 

@ TAB: 
I do not know any other workaround than to switch back to 4.0.1
In meta.xml of "SurfM" I found "meta:generator>OpenOffice/4.1.0$Win32 OpenOffice.org_project/410m18$Build-9764", Please leave a comment in Issue 124717 if your OS is not WIN 7

*** This issue has been marked as a duplicate of issue 124717 ***
Comment 10 TAB 2014-05-17 23:55:14 UTC
	It happened again. I just edited text --not much; including changing some numbering, and did not change any graphic. Suddenly, ALL figures had ReadErrors! I saved the file as SurfMa.odt. Then, I closed and re-read it: ReadErrors were gone, but so were the figures. This occurred under v.4.0.1 and Windows Vista; so, it's not a 'new bug' under v.4.1.
	The original file SurfM.odt still had its figures; fortunately, I did not overwrite it!