Issue 124921 - Advanced Filter destroys Auto Filter Area
Summary: Advanced Filter destroys Auto Filter Area
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: 4.0.0
Hardware: All Windows 7
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: regression
Depends on:
Reported: 2014-05-17 09:27 UTC by Rainer Bielefeld
Modified: 2014-05-17 09:37 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Sample Document (102.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-17 09:37 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2014-05-17 09:27:26 UTC
Steps how to reproduce with "AOO 4.1.0 Release – German UI / German locale [AOO410m18(Build:9764)  -   Rev. 1589052 2014-04-22 11:43:54]" on German WIN7 Home Premium (64bit)", “historic” 4. User Profile used for all predecessor versions:

0. Download attached sample document
1. In Operating System file explorer create a copy of the document
2. From AOO Start Center open sample document in AOO 4 
3. Launch a server installation of OOo 3.3.0 (or similar) and from
   Start center open Copy of sample document
4. All following steps should be done for both Documents in both versions,
   results should be compared
5. Click Autofilter-Arrowdown for heading cell "Schritt"
   > Dropdown shows lots of filter items
6. Click heading cell "Schritt"
7. Menu 'Data -> Define Range -> "FilterArea"' should show Range 
8. <Esc>
9. Menu 'Data -> Filter -> Advanced Filter -> Creiteria select AdHoc -> [OK]
   Expected: Lots of rows selected and shown
   Bug: AOO 4.0 filters nothing, all rows keep visible
10. AOO4: Menu 'Data -> Define Range -> "FilterArea"' shows 
          "$ProjStat.$A$1:$I$1", what can't work

Additional Info:
(a) In other tests I remember the first Advanced Filter attempt was successful,
    damage came after first Advanced filter, I do not remember the difference
    (Might have been other Version)
(b) Already Reproducible with server installation of " AOO 4.0.0-Dev – 
    English UI / German locale [AOO400m1(Build:9700) - 
    Rev. 1457992 – Rev.1457606 ((2013-03-19))]" on 
    German WIN7 Home Premium (64bit)", own separate user profile
(c) Still worked fine with with server installation of "AOO 3.4.0 – German UI
    / German locale [AOO340m1(Build:9590) - Rev.1327774]" on German 
    WIN7 Home Premium (64bit)", own separate user profile
Comment 1 Rainer Bielefeld 2014-05-17 09:37:21 UTC
Created attachment 83410 [details]
Sample Document

(d) In some cases I fail to reproduce the problem, don't know why. 1 Time
    Advanced Filter suddenly worked fine after I had disabled Macros
    when I opened the document, but I was not able to reproduce that
    If you also fail, try again next day