Issue 124922 - Font Effects not applied correctly
Summary: Font Effects not applied correctly
Status: VERIFIED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 4.1.0
Hardware: Mac Mac OS X, all
: P3 Major (vote)
Target Milestone: 4.1.1
Assignee: hdu@apache.org
QA Contact:
URL:
Keywords: regression
: 124862 125382 (view as issue list)
Depends on:
Blocks: 124985
  Show dependency treegraph
 
Reported: 2014-05-17 10:38 UTC by papayes
Modified: 2014-08-07 06:49 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.1.1_release_blocker+


Attachments
Screenshot: 4.0.1 on the right, 4.1.0 on the left (130.77 KB, image/png)
2014-05-17 12:47 UTC, Ariel Constenla-Haile
no flags Details
sample test document (23.02 KB, application/vnd.oasis.opendocument.text)
2014-05-19 12:02 UTC, hdu@apache.org
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description papayes 2014-05-17 10:38:10 UTC
Hello,
only with OSX 10.9.3 and 4.1.0 AOO (and LibO 4.2.4...)
regression (OK with AOO 4.0.1)

Writer : type any word and select 
Format> Character > Font Effects >
Effects of characters do not work whatever the police.
- Outline does not work: increased case and no outline
- Shadow is black and not gray
- Embossed and Engraved does not work properly

Sorry
Comment 1 Rainer Bielefeld 2014-05-17 10:54:20 UTC
NOT reproducible with server installation of "AOO 4.1.0-dev – English UI / German locale - [AOO410m14(Build:9760)  -  Rev. 1583418 2014-05-03]" on German WIN7 Home Premium (64bit)", own separate user profile.

Seems to be really Mac only.

Might be related to "Issue 124595 - Font modifications in paragraph style dialog not applied to text ", "Issue 124862 - Font color and shadow color cannot be different"

@papayes: 
Some of those effects (Outline, Shadow) also are avalilable in Draw and Calc. Is your problem really limited to Writer?
Comment 2 papayes 2014-05-17 11:31:16 UTC
Hello,

sorry,
Outline, Shadow :
this is for all modules,
calc, impress, draw 
only whith OsX !

I will test further the next version with OSX, provided I have the RC available ...
Regards,
Comment 3 tintin60 2014-05-17 11:37:25 UTC
Hi,

I confirm. All modules.
Shadow is black in stead of grey ;
Character size is bigger.
Ugly result.

Regression.

exemple with AOO 4.0.1 : https://forum.openoffice.org/fr/forum/download/file.php?id=83784&t=1
with AOO 4.1.0 : https://forum.openoffice.org/fr/forum/download/file.php?id=83785&t=1

Slts
Comment 4 Ariel Constenla-Haile 2014-05-17 12:27:16 UTC
Looks like a regression introduced by the use of CoreText API in 4.1
Setting hdu on cc
Comment 5 Ariel Constenla-Haile 2014-05-17 12:47:54 UTC
Created attachment 83411 [details]
Screenshot: 4.0.1 on the right, 4.1.0 on the left
Comment 6 Ariel Constenla-Haile 2014-05-17 12:48:57 UTC
Confirming
Regression
All MacOSX
Comment 7 hdu@apache.org 2014-05-19 12:02:32 UTC
Created attachment 83420 [details]
sample test document
Comment 8 SVN Robot 2014-05-19 12:05:28 UTC
"hdu" committed SVN revision 1595858 into trunk:
#i124922# allow late setting of the font color for CoreText-layouted text
Comment 9 hdu@apache.org 2014-05-19 12:07:01 UTC
Fixed with the change above.
Comment 10 hdu@apache.org 2014-05-19 13:39:24 UTC
*** Issue 124862 has been marked as a duplicate of this issue. ***
Comment 11 jsc 2014-06-12 13:27:53 UTC
grant showstopper flag for AOO 4.1.1
Comment 12 SVN Robot 2014-06-13 10:54:13 UTC
"hdu" committed SVN revision 1602365 into branches/AOO410:
#i124922# allow late setting of the font color for CoreText-layouted text
Comment 13 hdu@apache.org 2014-06-13 11:01:45 UTC
The fix has been merged for the AOO 4.1.1 target.
Comment 14 David Paenson 2014-06-30 11:51:11 UTC
NOT OK. Problem not solved under AOO 4.1.1 Build 9770 Ubuntu 14.04. 

Marked a word, applied format "Small Caps" as well as "Shadow". Increased font size to 28pt so as to observe result: 2 sets of characters overlapping each other, grey letters in foreground and black letters in background, so the opposite of shadow effect!
Comment 15 Ariel Constenla-Haile 2014-06-30 12:23:24 UTC
(In reply to David Paenson from comment #14)
> NOT OK. Problem not solved under AOO 4.1.1 Build 9770 Ubuntu 14.04. 

This bug reports a regression in MacOSX, it does not make sense to verify it on Linux, although the following is a new bug, and should be reported in another issue

> Marked a word, applied format "Small Caps" as well as "Shadow". Increased
> font size to 28pt so as to observe result: 2 sets of characters overlapping
> each other, grey letters in foreground and black letters in background, so
> the opposite of shadow effect!
Comment 16 papayes 2014-07-03 12:27:51 UTC
Hello,

OO411m1(Build:9770)  -  Rev. 1603804
2014-06-12 17:05:56 (Thu, 12 Jun 2014)

It's OK.

Thank you for creating an additional version 4.1.1 and corrected as quickly !

The tabs are in capital letters, is this intentional?
I like this arrangement.
Comment 17 fanyuzhen 2014-07-18 09:37:38 UTC
It's verified fixed based on reporter's verification in comment 16
Comment 18 Ariel Constenla-Haile 2014-08-07 06:49:22 UTC
*** Issue 125382 has been marked as a duplicate of this issue. ***