Issue 124948 - sigsegv when starting AOO 4.1 as non-root on RHEL 6.5 64 bit
Summary: sigsegv when starting AOO 4.1 as non-root on RHEL 6.5 64 bit
Status: RESOLVED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.1.0
Hardware: PC Linux 64-bit
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 127153 127185 (view as issue list)
Depends on:
Blocks:
 
Reported: 2014-05-21 13:13 UTC by tseeling
Modified: 2017-09-02 16:22 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description tseeling 2014-05-21 13:13:33 UTC
AOO 4.0.1 was working fine, update to 4.1.0 with RPM from download site.
Invocation as root is possible and can open/edit any documents.
Invocation as user is *not* possible. Spash screen occurs for a short time.
Starting from terminal shows Application error 6.
Starting with strace shows SIGSEGV here:

lstat64("/opt/openoffice4", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
lstat64("/opt/openoffice4/program", {st_mode=S_IFDIR|0755, st_size=20480, ...}) = 0
lstat64("/opt/openoffice4/program/libuno_cppu.so.3", {st_mode=S_IFREG|0444, st_size=203908, ...}) = 0
access("/opt/openoffice4/program/unorc", F_OK) = 0
access("/opt/openoffice4/program/unorc", F_OK) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---


All files in /opt/openoffice4 are set a+r, all user files in .openoffice belong to that respective user.

no files in /opt/openoffice have been changed after installation.
Comment 1 Ariel Constenla-Haile 2014-05-21 13:53:52 UTC
(In reply to tseeling from comment #0)
> AOO 4.0.1 was working fine, update to 4.1.0 with RPM from download site.

Did you update from 4.0.1 to 4.1.0? The update might be broken (on your system, I cannot reproduce on my system - Fedora 20). Try removing all packages, removing all folders left on /opt, and installing 4.1.0 again.
Comment 2 tseeling 2014-05-21 14:15:46 UTC
my "update" was done by rpm -e all 4.0.1 packages, then fresh install of 4.1.0 packages.
If it runs as root I deduce there's some permission problem. How can I diagnose what it is exactly?

running as user results in this trace:

$ sh -x /opt/openoffice4/program/soffice
+ SAL_ENABLE_FILE_LOCKING=1
+ export SAL_ENABLE_FILE_LOCKING
++ pwd
+ sd_cwd=/home/tseeling/.openoffice/4/user
+ sd_res=/opt/openoffice4/program/soffice
+ '[' -h /opt/openoffice4/program/soffice ']'
++ dirname /opt/openoffice4/program/soffice
+ cd /opt/openoffice4/program
++ pwd
+ sd_prog=/opt/openoffice4/program
+ cd /home/tseeling/.openoffice/4/user
++ basename /opt/openoffice4/program/soffice
+ sd_binary=soffice.bin
+ sd_pagein_args=@pagein-common
+ /opt/openoffice4/program/pagein -L/opt/openoffice4/program @pagein-common
+ '[' -x /opt/openoffice4/program/javaldx ']'
+ case "`uname -s`" in
++ uname -s
++ /opt/openoffice4/program/javaldx -env:INIFILENAME=vnd.sun.star.pathname:/opt/openoffice4/program/redirectrc
+ my_path=/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/bin:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/jre/bin:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/bin/classic:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/jre/bin/classic:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/client:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/server:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/classic:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/jrockit:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/native_threads:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386
+ '[' -n /usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/bin:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/jre/bin:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/bin/classic:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/jre/bin/classic:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/client:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/server:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/classic:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/jrockit:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/native_threads:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386 ']'
+ LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/bin:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/jre/bin:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/bin/classic:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/jre/bin/classic:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/client:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/server:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/classic:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/jrockit:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386/native_threads:/usr/lib/jvm/java-1.6.0-ibm-1.6.0.15.1.x86_64/jre/lib/i386
+ export LD_LIBRARY_PATH
+ unset XENVIRONMENT
+ '[' -f /etc/adabasrc ']'
+ trap 'kill -9 $!' TERM
+ wait 30196
+ /opt/openoffice4/program/soffice.bin
Application Error

Fatal exception: Signal 6
Stack:
/opt/openoffice4/program/libuno_sal.so.3(+0x2203d)[0xb9903d]
/opt/openoffice4/program/libuno_sal.so.3(+0x22139)[0xb99139]
/opt/openoffice4/program/libuno_sal.so.3(+0x221e6)[0xb991e6]
[0x20d400]
/lib/libc.so.6(abort+0x17a)[0x4f63ea]
/opt/openoffice4/program/libvcl.so(+0x100494)[0x8c40494]
/opt/openoffice4/program/libvcl.so(_ZN11Application5AbortERK6String+0x1a)[0x8c6d1d0]
/opt/openoffice4/program/libsofficeapp.so(+0x18d0d)[0x340d0d]
/opt/openoffice4/program/libvcl.so(+0x1333be)[0x8c733be]
/opt/openoffice4/program/libvos3gcc3.so(_ZN3vos26signalHandlerFunction_implEPvP13oslSignalInfo+0x12)[0x67adfe]
/opt/openoffice4/program/libuno_sal.so.3(+0x21102)[0xb98102]
/opt/openoffice4/program/libuno_sal.so.3(+0x221cf)[0xb991cf]
[0x20d400]
/opt/openoffice4/program/../program/deployment.uno.so(+0x670d6)[0x2bfd0d6]
/opt/openoffice4/program/../program/deployment.uno.so(+0x42bfd)[0x2bd8bfd]
/opt/openoffice4/program/../program/deployment.uno.so(+0x42fa6)[0x2bd8fa6]
/opt/openoffice4/program/../program/deployment.uno.so(+0x2409e)[0x2bba09e]
/opt/openoffice4/program/../program/deployment.uno.so(+0x25354)[0x2bbb354]
/opt/openoffice4/program/../program/deployment.uno.so(+0x363ca)[0x2bcc3ca]
/opt/openoffice4/program/libdeploymentmisc.so(_ZN7dp_misc16syncRepositoriesERKN3com3sun4star3uno9ReferenceINS2_3ucb19XCommandEnvironmentEEE+0x1b8)[0x30265a]
/opt/openoffice4/program/libsofficeapp.so(+0x2ad13)[0x352d13]
/opt/openoffice4/program/libsofficeapp.so(+0x19974)[0x341974]
/opt/openoffice4/program/libvcl.so(+0x133d1b)[0x8c73d1b]
/opt/openoffice4/program/libvcl.so(_Z6SVMainv+0x2d)[0x8c73e09]
/opt/openoffice4/program/libsofficeapp.so(soffice_main+0xaa)[0x363e24]
/opt/openoffice4/program/soffice.bin(main+0x20)[0x8048c84]
/lib/libc.so.6(__libc_start_main+0xe6)[0x4e0d26]
/opt/openoffice4/program/soffice.bin(__gxx_personality_v0+0xad)[0x8048bb1]
/opt/openoffice4/program/soffice: line 121: 30196 Aborted                 "$sd_prog/$sd_binary" "$@"
+ sd_ret=134
+ '[' 134 -eq 79 -o 134 -eq 81 ']'
+ exit 134
Comment 3 tseeling 2014-05-21 14:24:47 UTC
the following as root solved the issue, most probably the last command.

# chmod -R a+r /opt/openoffice4
# chmod -R u+w /opt/openoffice4
# find /opt/openoffice4 -type d | xargs chmod a+rx
# chown -R root.root /opt/openoffice4
# rm -fr ~tseeling/.openoffice/

AOO started, went over the splash screen, asked my name, and works now as user tseeling.

Thanks!
Comment 4 oooforum (fr) 2016-07-25 10:21:31 UTC
Installation of AOO 4.1.2 with Fedora 24 x64 and same issue.
Launching AOO shows splashscreen and aborts.
Running soffice from a terminal displays a "fatal exception: signal 6" error.

Trying to following commands as root from comment 3 but don't work.

Very annoying
Comment 5 Ariel Constenla-Haile 2016-07-25 16:35:49 UTC
(In reply to oooforum (fr) from comment #4)
> Installation of AOO 4.1.2 with Fedora 24 x64 and same issue.
> Launching AOO shows splashscreen and aborts.
> Running soffice from a terminal displays a "fatal exception: signal 6" error.
> 
> Trying to following commands as root from comment 3 but don't work.
> 
> Very annoying

Yours is likely another issue.
Do you have gtk2 libraries installed?
Try the following on a terminal:

~]$ ldd -v /opt/openoffice4/program/libvclplug_gtk.so

In my system, this reports a missing library:

...
        libgdk_pixbuf_xlib-2.0.so.0 => not found
...

Find the package which provides this library, and install it:

[root@localhost ~]# dnf whatprovides */libgdk_pixbuf_xlib-2.0.so.0
Last metadata expiration check: 19:02:19 ago on Sun Jul 24 18:10:21 2016.
gdk-pixbuf2-xlib-2.34.0-1.fc24.i686 : Additional library for using gdk-pixbuf with bare xlib
Repo        : fedora

gdk-pixbuf2-xlib-2.34.0-1.fc24.x86_64 : Additional library for using gdk-pixbuf with bare xlib
Repo        : fedora

[root@localhost ~]# dnf install gdk-pixbuf2-xlib

Do the same with every missing library. Then, export the following variables:

~]$ export SAL_USE_VCLPLUGIN="gtk"
~]$ export OOO_FORCE_DESKTOP="gnome"

Now run AOO on that terminal

~]$ /opt/openoffice4/program/soffice

Does this work?
Comment 6 oooforum (fr) 2016-07-26 07:47:49 UTC
(In reply to Ariel Constenla-Haile from comment #5)
> Does this work?
YES! Thanks for this complete step-by-step.

> Do you have gtk2 libraries installed?
Well, is it possible to create a bash script to check this?
That will be fine for end-users and make an automated install.
Comment 7 Ariel Constenla-Haile 2016-07-26 18:24:26 UTC
(In reply to oooforum (fr) from comment #6)
> > Do you have gtk2 libraries installed?
> Well, is it possible to create a bash script to check this?
> That will be fine for end-users and make an automated install.

There could be a script that does a ldd -v on all the libraries in /opt/openoffice4/program and checks if there is a library with "not found", but I'm not sure if ldd localizes that string.
Comment 8 oooforum (fr) 2016-10-06 10:15:56 UTC
*** Issue 127153 has been marked as a duplicate of this issue. ***
Comment 9 oooforum (fr) 2016-10-25 08:54:40 UTC
*** Issue 127185 has been marked as a duplicate of this issue. ***