Issue 124966 - Picture loss on save
Summary: Picture loss on save
Status: VERIFIED FIXED
Alias: None
Product: Impress
Classification: Application
Component: save-export (show other issues)
Version: 3.4.0 Beta (OOo)
Hardware: All All
: P2 Normal (vote)
Target Milestone: 4.1.1
Assignee: Oliver-Rainer Wittmann
QA Contact:
URL:
Keywords: data_loss
Depends on:
Blocks: 124985
  Show dependency treegraph
 
Reported: 2014-05-23 07:58 UTC by Oliver-Rainer Wittmann
Modified: 2014-08-01 22:27 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.1.1_release_blocker+


Attachments
sample document to reproduce the picture los (15.08 KB, application/vnd.oasis.opendocument.presentation)
2014-05-23 07:59 UTC, Oliver-Rainer Wittmann
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Oliver-Rainer Wittmann 2014-05-23 07:58:49 UTC
Small embedded pictures (less than 128x128 pixels) which are not in *.png format are lost under special conditions during several save actions.

- Open attached presentation and assure that slide 5 is not visible in Slide Sorter. If slide 5 is visible in Slide Sorter, then resize application windows or Slide Sorter, close the presentation and open it again, having slide 5 not been visible.
- Save-As the presentation with a new file name
- Make slide 5 visible in Slide Sorter by scrolling its area
- Make an arbitrary change to slide 1
- Save
- Bring slide 4 or slide 5 into the main view by clicking on it in Slide Sorter
--> picture is lost.

Root cause:
A small picture (less than 128x128 pixels) have to be inserted at least twice in a presentation (or draw document). After an first save action the second picture had to become into the view. For the view only preview picture data are generated which does not keep the picture format information. In case the picture is small enough the preview data are equal the picture data the picture format data for the picture is also lost. The following save is not able to determine the picture format and stores the embedded picture file with extension *.png. The changed embedded picture file name is not set a the internal picture data
--> picture is lost
A reload in this situation will bring back the picture, but if another save action is triggered before the picture is lost forever.
Comment 1 Oliver-Rainer Wittmann 2014-05-23 07:59:44 UTC
Created attachment 83455 [details]
sample document to reproduce the picture los
Comment 2 Rainer Bielefeld 2014-05-23 08:37:50 UTC
Aquick test with "AOO 4.0.1 – German UI / German locale [AOO401m3(Build:9712) - Rev. 1520285 2013-09-05 13:52:01]" on German WIN7 Home Premium (64bit)", Common 4.0 User Profile did not show the problem
Comment 3 Oliver-Rainer Wittmann 2014-05-23 10:07:56 UTC
(In reply to Rainer Bielefeld from comment #2)
> Aquick test with "AOO 4.0.1 – German UI / German locale
> [AOO401m3(Build:9712) - Rev. 1520285 2013-09-05 13:52:01]" on German WIN7
> Home Premium (64bit)", Common 4.0 User Profile did not show the problem

Thanks for having a look.
I am able to reproduce the picture loss with AOO 4.0.1 under Windows 7 (64bit).
Unfortunately, the conditions which have to be meant are hard to setup.
Important is that the second picture on slide 5 is not visible until the document is save into a new file.
Comment 4 SVN Robot 2014-05-23 15:00:12 UTC
"orw" committed SVN revision 1597109 into trunk:
124966: keep picture format information - <GfxLink> instance - also for the r...
Comment 5 Rainer Bielefeld 2014-05-26 17:06:08 UTC
P2 because Blocks 124985
Comment 6 Oliver-Rainer Wittmann 2014-06-02 09:48:20 UTC
fixed on trunk
Comment 7 jsc 2014-06-16 09:12:47 UTC
grant showstopper flag, data loss and already fixed
Comment 8 SVN Robot 2014-06-19 09:26:34 UTC
"orw" committed SVN revision 1603774 into branches/AOO410:
124966: keep picture format information - <GfxLink> instance - also for the r...
Comment 9 Oliver-Rainer Wittmann 2014-06-19 09:28:07 UTC
fixed on branch AOO410 for planned 4.1.1 release
Comment 10 David Paenson 2014-06-30 11:35:55 UTC
OK. Under OpenOffice 4.1.1 Build 9770 under Ubuntu 14.04 no loss of images observed. Document length: 50 pages, 34 images and 35 frames.
Comment 11 fanyuzhen 2014-07-01 08:01:51 UTC
I cannot reproduce it in both AOO410m18(Build:9764)  -  Rev. 1589052 and AOO411m1(Build:9770)  -  Rev. 1603804 on Windows 7, so I am hesitating to mark it as fixed.
David Paenson, have you reproduced this problem in previous build which does not include the fix?
Comment 12 Pedro 2014-08-01 22:27:18 UTC
I could not reproduce the bug in AOO 4.1.0 or in AOO 4.1.1 RC1 (under Windows 7 x64)
This either means that the instructions are not clear enough or that the bug is fixed. The only way to be sure is for Oliver-Rainer to test it...