Issue 125023 - Constantly Crashes
Summary: Constantly Crashes
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.1.0
Hardware: Mac Mac OS X, all
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2014-06-01 22:14 UTC by Darren Littlejohn
Modified: 2019-11-01 21:04 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screen Shot of Crash on OS X (deleted)
2014-06-01 23:25 UTC, Darren Littlejohn
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Darren Littlejohn 2014-06-01 22:14:52 UTC
I only have a small 22 page document open on my Macbook Air. Everything is new and using the recent versions of wall. About half the time I make changes to a document it crashes. Usually after saving.
Comment 1 Ariel Constenla-Haile 2014-06-01 22:20:43 UTC
Can you attach a sample document, enumerating the steps to follow in order to reproduce the crash?
Comment 2 Darren Littlejohn 2014-06-01 22:41:36 UTC
Well the document that I'm working on is proprietary at the moment so I can't upload that. I could send it to you privately. As I said, OOW just crashes when I save the document on the Air. What else would you like to know?
Comment 3 Darren Littlejohn 2014-06-01 23:24:57 UTC
I emailed you a screen shot.
Comment 4 Darren Littlejohn 2014-06-01 23:25:34 UTC
Created attachment 83489 [details]
Screen Shot of Crash on OS X
Comment 5 Ariel Constenla-Haile 2014-06-01 23:40:13 UTC
(In reply to Darren Littlejohn from comment #4)
> Created attachment 83489 [details]
> Screen Shot of Crash on OS X

Thanks for the information.
It shows that you might be facing the problem described in Bug 124970

Can you confirm if this is a regression in 4.1.0? That is, did you test with 4.0.1, and there is no crash with that version?

And if possible, please attach the Apple crash report, see Bug 124970 comment 1 (quoting: "Usually Apple shows a dialog after a crash, asking if you want to report it to Apple; if you select to view the details of the report, it will display very useful information; if you get the Apple report dialog, please copy that crash report detail in a text file, and attach it here (but don't send the report to Apple).")

Also note that the picture you attached here in attachment 83489 [details] is publicly available to anyone; if it has confidential information that you don't want to share, remove it.
Comment 6 Darren Littlejohn 2014-06-02 04:03:51 UTC
No I dont' think I'll be doing all of that reinstalling and trouble shooting. I'm trying to write a book. I thought this software was finally stable for OSX. 

I don't see any way to delete the attachemet. There was no crash report dialog from Apple on this. Writer just crashes, no dialog from Apple any time. 

I'll look up the bug you mention to see if there's a fix. But that particular error that I sent in the screen shot has only appeared this last time it crashed, never before. 

-d

(In reply to Ariel Constenla-Haile from comment #5)
> (In reply to Darren Littlejohn from comment #4)
> > Created attachment 83489 [details]
> > Screen Shot of Crash on OS X
> 
> Thanks for the information.
> It shows that you might be facing the problem described in Bug 124970
> 
> Can you confirm if this is a regression in 4.1.0? That is, did you test with
> 4.0.1, and there is no crash with that version?
> 
> And if possible, please attach the Apple crash report, see Bug 124970
> comment 1 (quoting: "Usually Apple shows a dialog after a crash, asking if
> you want to report it to Apple; if you select to view the details of the
> report, it will display very useful information; if you get the Apple report
> dialog, please copy that crash report detail in a text file, and attach it
> here (but don't send the report to Apple).")
> 
> Also note that the picture you attached here in attachment 83489 [details]
> is publicly available to anyone; if it has confidential information that you
> don't want to share, remove it.
Comment 7 Darren Littlejohn 2014-06-02 04:13:25 UTC
I examined that thread and don't see any solutions.
Comment 8 Ariel Constenla-Haile 2014-06-02 05:07:22 UTC
(In reply to Darren Littlejohn from comment #6)
> I thought this software was finally stable for OSX. 

Well, there have been two major changes in this version
- the accessibility feature
- the switch to a new compiler and architecture in MacOSX
Both have been tested, there was even a Beta Release so that user could test and report the issues they found; unfortunately, at the time of the release, serious bugs like these crashes were not known.

In short, if you keep getting these constant crashed, you may need to revert to the previous 4.0.1.

> I don't see any way to delete the attachemet.

IIRC hdu is bugzilla admin.
@hdu: can you delete Darren's attachment? Thanks


(In reply to Darren Littlejohn from comment #7)
> I examined that thread and don't see any solutions.

That's because the developers couldn't still reproduce the crash.
Comment 9 hdu@apache.org 2014-06-02 06:48:29 UTC
The content of attachment 83489 [details] has been deleted for the following reason:

Deleted the attachment as requested in the comments above.
Comment 10 Darren Littlejohn 2014-06-02 23:15:22 UTC
I don't see any place to download an older version.
Comment 11 Ariel Constenla-Haile 2014-06-03 03:18:52 UTC
(In reply to Darren Littlejohn from comment #10)
> I don't see any place to download an older version.

Try with https://archive.apache.org/dist/openoffice/4.0.1/binaries/
Inside that folder, there are folders named according to the language code, for example, English USA is en-us:
https://archive.apache.org/dist/openoffice/4.0.1/binaries/en-US/

Inside that folder, download the file 
Apache_OpenOffice_4.0.1_MacOS_x86_install_en-US.dmg
https://archive.apache.org/dist/openoffice/4.0.1/binaries/en-US/Apache_OpenOffice_4.0.1_MacOS_x86_install_en-US.dmg
Comment 12 oooforum (fr) 2019-11-01 18:22:37 UTC
No news from OP