Issue 125028 - Attempt to scroll spreadsheet left actually scrolls right
Summary: Attempt to scroll spreadsheet left actually scrolls right
Status: CLOSED DUPLICATE of issue 124191
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: 4.1.0
Hardware: Mac Mac OS X 10.7
: P3 Normal (vote)
Target Milestone: ---
Assignee: hdu@apache.org
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-02 09:24 UTC by R Smith
Modified: 2017-05-20 09:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description R Smith 2014-06-02 09:24:30 UTC
Using the touchpad on my MacBook Pro (13" late 2011) to scroll left on any spreadsheet causes it to scroll to the right. Other directions work correctly - up, down and right - but not to the left. Also, this works correctly with OO 3.4.1 on the same hardware.

Steps to reproduce
1. Create a new spreadsheet, or load an existing one.
2. Two-finger touchpad swipe either left or right both scroll right.

Expected result
Two-finger touchpad swipe left scrolls in opposite direction to a two-finger touchpad swipe right.

Please fix this. Thank you.
Comment 1 hdu@apache.org 2014-06-02 12:02:37 UTC
Already fixed for bug 124191. A workaround until a new release becomes available is also provided there.

*** This issue has been marked as a duplicate of issue 124191 ***
Comment 2 R Smith 2014-06-02 14:54:53 UTC
Thanks for your swift response, and for the forthcoming fix.