Issue 125030 - CRASH when open edit mode copy of older document.odt version
Summary: CRASH when open edit mode copy of older document.odt version
Status: CLOSED DUPLICATE of issue 124891
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.1.0
Hardware: All Windows 7
: P3 Major (vote)
Target Milestone: 4.1.1
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: regression
Depends on:
Blocks: 124985
  Show dependency tree
 
Reported: 2014-06-02 17:47 UTC by Rainer Bielefeld
Modified: 2016-11-03 07:44 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.2.0-dev
Developer Difficulty: ---
jsc: 4.1.1_release_blocker+


Attachments
Sample Document (14.69 KB, application/vnd.oasis.opendocument.text)
2014-06-02 17:47 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2014-06-02 17:47:04 UTC
Created attachment 83490 [details]
Sample Document

Steps how to reproduce with "AOO 4.2.0-Dev – German UI / German locale [AOO420m1(Build:9800)  -   Rev. 1597166  2014-05-20 1]" on German WIN7 Home Premium (64bit)", “historic” 4. User Profile used for all predecessor versions

Create sample document (you also can use sample document and start with step 7):
1. From AOO Start Center open blank new Writer document, -> Save -> Type
   "Lorem"
2. Menu 'File -> Versions -> Always save Version when close -> [Save version] 
    -> Close
3. Save and Exit document
4. Open document
5. Behind existing text type " Ipsum"
6. Save and Exit document
7. In AOO File Menu 'Open -> Click sample document -> Select version before 
   latest -> [Open]
   > Write protected document will be opened
8. Click 'Edit Document' Icon in Standard Toolbar
   > Message " ... missing rights ... Open Copy?"
9. [Yes]
   > CRASH

Additional Info:
(a) Worked fine with AOO 4.0.0
    I can narrow down appearance of crash if necessary
Comment 1 Rainer Bielefeld 2014-06-02 17:51:10 UTC
(b) Single test with CALC: NO crash
(c) Single test with DRAW: CRASH
Comment 2 Rainer Bielefeld 2014-06-03 04:53:36 UTC
(d) Still Reproducible with "AOO 4.2.0-Dev – German UI / German locale 
   [AOO420m1(Build:9800)  -   Rev. 1598806  2014-06-02]" on German WIN7 Home
   Premium (64bit)", “historic” 4. User Profile used for all predecessor 
    versions
(e) Already Reproducible with server installation of "AOO 4.1.0-dev – English UI 
    / German locale - [AOO410m14(Build:9760)  -  Rev. 1583418 2014-04-02]" 
    on German WIN7 Home Premium (64bit)", own separate user profile.
(f) Blank new user profile will not heal the problem

a): Worked fine with 
   * server installation of "AOO 4.1.0-dev – English UI / German locale - 
     [AOO410m14(Build:9760)  -  Rev. 1577236 2014-03-15]" on German WIN7 Home 
     Premium (64bit)", own separate user profile.
   * server installation of "AOO 4.1.0-Dev – English UI 
     / English locale - [AOO410m1(Build:9750) - Rev. 1554205 - 2014-01-01]" 
     on German WIN7 Home Premium (64bit)", own separate user profile.
Comment 3 fanyuzhen 2014-06-16 07:34:15 UTC
I can reproduce it with 4.1.0 GA build "AOO410m18(Build:9764)  -  Rev. 1589052 2014-04-22 11:43:54 (Di, 22 Apr 2014)" on my Win7.

I suggest to update step 1 as:
1. From AOO Start Center open blank new Writer document and input some text -> Save -> Type some text, eg:   "Lorem"
Comment 4 fanyuzhen 2014-06-16 07:35:55 UTC
confirmed as this bug is reproducible
Comment 5 jsc 2014-06-16 09:32:04 UTC
This seems to be a bigger problem. for me it don't work at all on MacOS 10.9.3.
- automatic save versions on close don't work at all
- manual saving versions work.
- can't see and select versions in file open dialog on MacOS
- open version via version dialog and switch to edit mode -> crash
Comment 6 jsc 2014-06-16 09:40:10 UTC
restart after crash and open the doc shows at least the manual created version in the file dialog.

Changing the doc, save and explicitly use File -> Close again no new version. But when I open the doc I see again no version info in the file open dialog.
Comment 7 Oliver-Rainer Wittmann 2014-06-19 12:47:59 UTC
I also observed certain defect in the "Version" feature.
The observed crash has nothing to do with the "Version" feature. Internally, it is the same crash which happens by the actions described in issue 124891.
This issue shows more or less a different way how to trigger the crash which had been identified in issue 124891.
--> resolving this issue as duplicate of issue 124891

I also found a third way to trigger this crash:
- create a read-only text document in your file system.
- open this file in AOO 4.1.0
--> it is opened in in Read-Only mode; the Navigator is active in the Sidebar
- Click "Edit File"
- Choose to open a copy
--> crash

*** This issue has been marked as a duplicate of issue 124891 ***
Comment 8 fanyuzhen 2014-07-02 07:48:43 UTC
I do not see crash described in this bug(by Rainer) and in comment 7(by Oliver) on build AOO411m1(Build:9770)  -  Rev. 1603804
Comment 9 Pedro 2014-08-03 16:43:10 UTC
In AOO 4.1.1 opening the previous version of the document does not open in Read Only mode so step 8 does not apply, therefore there is no crash.

Is the previous version supposed to open as Read Only? If it is, then this is a regression...

Saving versions seems to be broken in AOO (at least 4.1.1 and 4.1.0)... If "Always save a version on closing" is supposed to save a new version of the document each time the document is modified and closed then this is NOT working. The only version created was the one manually saved in Step 2 and then all updates are saved on top of the same version...
Comment 10 Ariel Constenla-Haile 2014-08-03 17:57:02 UTC
(In reply to Pedro from comment #9)
> In AOO 4.1.1 opening the previous version of the document does not open in
> Read Only mode so step 8 does not apply, therefore there is no crash.
> 
> Is the previous version supposed to open as Read Only? If it is, then this
> is a regression...

From the "Online Help" pf the "Open" dialog:


Version
If there are multiple versions of the selected file, select the version that you want to open. You can save and organize multiple versions of a document by choosing File - Versions. The versions of a document are opened in read-only mode.
Comment 11 Ariel Constenla-Haile 2014-08-03 18:00:27 UTC
(In reply to Pedro from comment #9)
> Saving versions seems to be broken in AOO (at least 4.1.1 and 4.1.0)... If
> "Always save a version on closing" is supposed to save a new version [...]

There was bug 123812 but should be fixed in 4.1.1