Issue 125031 - Replace All hits rows hidden by filter
Summary: Replace All hits rows hidden by filter
Status: CLOSED DUPLICATE of issue 118008
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: 4.1.0
Hardware: All Mac OS X, all
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-02 18:37 UTC by pwm1991
Modified: 2014-06-02 19:04 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description pwm1991 2014-06-02 18:37:17 UTC
Massive problem discovered by a coworker of mine today, around 1,000 products I was working on were affected :/

Set up example:

Filter the following 6 rows so that only "Windows 8" is visible

ROW1: Microsoft Windows 8 - Small
ROW2: Microsoft Windows 7 - Small
ROW3: Microsoft Windows 8 - Medium
ROW4: Microsoft Windows 7 - Medium
ROW5: Microsoft Windows 8 - Large
ROW6: Microsoft Windows 7 - Large

This will leave you with:

ROW1: Microsoft Windows 8 - Small
ROW3: Microsoft Windows 8 - Medium
ROW5: Microsoft Windows 8 - Large

Select the three rows, find/replace with "Current Select Only" and change "Windows" to "Clippy". If you replace once (not all), it will go from ROW1 to ROW2, to ROW3. It will NOT Replace ONLY the rows on screen, but rows hidden by the filter.

What should happen: Find/Replace should Find/Replace for the on-screen selection only, doubly so if "Current Selection Only" is checked.

TLDR: Why is Openoffice find/replacing stuff that I've filtered out? Why is open office treating a filter as "hide from view"
Comment 1 pwm1991 2014-06-02 18:40:28 UTC
I should add: replace-all is also susceptible and I only did replace-once to check whether my hypothesis was correct.
Comment 2 Marcus 2014-06-02 19:02:00 UTC
It's not a bug but a normal and wanted behavior. The reason is simple:

A filter gives you only another view of the data but does not modify the data itself.

There are a few other issues (e.g., 118008, 105974, 101011).

You can find this also in the help (topic: "AutoFilter function;applying"):

[...]
When you select multiple rows from an area where a filter was applied, then this selection can include rows that are visible and rows that are hidden by the filter. If you then apply formatting, or delete the selected rows, this action then applies only to the visible rows. The hidden rows are not affected.
[...]

So, this is no bug but a wanted and correct working behavior.

The solution for you is to output the filtered data on a different place. Then only the filtered data is shown and editing these is affecting only these, too.

See menu "Data - Filter - Standard Filter", click on button [More Options], check "Copy results to" and click into the spreadsheet to define the start cell for the output.

*** This issue has been marked as a duplicate of issue 118008 ***
Comment 3 pwm1991 2014-06-02 19:04:59 UTC
Got it.

Thanks, Marcus.