Issue 125082 - OFFSET function returns wrong number of rows, if the first cell of external range is empty
Summary: OFFSET function returns wrong number of rows, if the first cell of external r...
Status: CLOSED DUPLICATE of issue 117389
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: 4.1.0
Hardware: All All
: P3 Major (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-12 01:29 UTC by HD
Modified: 2017-05-20 09:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
OFFSET refering external file (10.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-06-12 01:29 UTC, HD
no flags Details
referenced file (9.92 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-06-12 01:30 UTC, HD
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description HD 2014-06-12 01:29:01 UTC
Created attachment 83540 [details]
OFFSET refering external file

1.Load attached 2 files "test1.ods" and "test2.ods"
2.Go to cell "C3" in "test1.ods", OFFSET refers external cell range "B2:B11" in "test2.ods".

[Expected result]
 Formula SUM(OFFSET) should return "54".

[Current result]
 Formula SUM(OFFSET) returns wrong result "44", because "B2" (first cell of range) in "test2.ods" is empty.

[Behavior]
 -OFFSET in "C3"
 When the first cell of external range is empty, OFFSET removes a cell from the back of the range.
 -OFFSET in "D4"
 When the first and second cell of external range are empty, OFFSET removes 2 cells from the back of the range.

[Workaround] 
 Enter "0" in first empty cell of external range.
 OFFSET returns correct range.

 FYI, it works fine in LibreOffice 4.1.6 and 4.2.4

Operating System: Windows 7
Version: Apache OpenOffice 4.1.0, 3.4.1

Regards.
Comment 1 HD 2014-06-12 01:30:23 UTC
Created attachment 83541 [details]
referenced file
Comment 2 HD 2014-06-12 01:48:04 UTC
Sorry, there is a typo in the Description.

In [Behavior], the cell name must be "D3" not "D4".
Comment 3 mroe 2014-06-19 15:59:44 UTC
see issue 117389

*** This issue has been marked as a duplicate of issue 117389 ***