Issue 125085 - Inability to Print Comments In Sidebar = Useless in Real World
Summary: Inability to Print Comments In Sidebar = Useless in Real World
Status: CLOSED DUPLICATE of issue 94514
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.1.0
Hardware: PC Windows Vista
: P3 Normal with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2014-06-12 13:59 UTC by radfem
Modified: 2018-09-12 15:54 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Comments on Bug 125085 - Inability to Print comments in Sidebar (145.99 KB, Text/Images)
2014-06-18 16:36 UTC, Todd
no flags Details
New Options Print Libreoffice Writer (28.36 KB, image/png)
2015-02-20 09:54 UTC, papayes
no flags Details
Print LibreOffice 4.4 Comment (43.67 KB, image/png)
2015-02-20 09:55 UTC, papayes
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description radfem 2014-06-12 13:59:38 UTC
Note to Developers: Those of us using OO for writing critique groups look poor in many ways next to group participants using Word with it's printable sidebar for editing. The print dialogue option to print comments at the bottom of the page (in actuality though, on a separate page) is fairly useless because here's what an edit looks like as things now stand:

Page : 1 Line : 9 Author : John Doe 06/10/2014
cut


The "cut" HAD been referenced to an unnecessary word (specifically "the"), and marked/highlighted on the screen, with nice dotted lines to the sidebar comment of "cut", and so clearly understood on the screen, but useless on physical paper (ie: the Real World), since as it now stands, the edit appears to ask the writer to cut Line 9 entirely.  Moreover, if I took an extra step and said "cut 'the'", the reader might think another "the" was to be cut, rather than the one I meant.  I suppose if I were in a position to revamp a writing critique group, I could make the entire process electronic, but alas, I am not in that position. Nor do all participants own a laptop to bring to a meeting to be able to follow along during a discussion.

This can't be a problem for just writers/editors. Can you say if/when you will make the Comments Sidebar printable? Otherwise, it is not something useable for a hardcopy.  Lastly, it would be a valuable tool if it were printable.
Comment 1 Todd 2014-06-18 16:36:30 UTC
Created attachment 83573 [details]
Comments on Bug 125085 - Inability to Print comments in Sidebar

Attachment contains screenshots that won't display in comments box.
Comment 2 Todd 2014-06-18 16:38:21 UTC
I was able to replicate the reported behavior using AOO Version 4.0.1 Build 9714 on Windows 7 OS SP1 so this appears to not be isolated to a single version or OS.
To replicate this behavior:
1.	Using MS Word, I added sidebar comments to an existing .docx file.
2.	Saved and Closed the file.
3.	Opened the file using AOO.
4.	Use Ctrl+P to display the Print dialog.
5.	Select page range and a highlighted Print Comments option from the drop-down.
 
6.	Printed the document.

I chose to place the comments at the end of the page and it was done…see the following example:
Page : 4 Line : 78 Author : 06/18/2014
A QA role should be represented here. For repository tracability at the very least
Architecture doesn’t provide appropriate scalability based on projections.
Page : 5 Line : 94 Author : 06/18/2014
A QA role should be represented here. For repository tracability at the very least
Architecture doesn’t provide appropriate scalability based on projections.
This behavior IS AS DESIGNED, although if line numbers aren’t visible on the page, it would be difficult for a person who is unfamiliar with the document to know what the comment was in reference to, and in this aspect, I do agree with the reporter that the feature may be ‘fairly useless’.
This bug did not appear to be related to any others in the database.
When replicating this behavior, there was a very interesting observation.
The original file in which the sidebar comments were entered, contained the following comments, which are both separated and unique:
Comment 1 : A QA role should be represented here. For repository tracability at the very least
Comment 2: Architecture doesn’t provide appropriate scalability based on projections.
   

But when that same document is opened in AOO, the comments are combined and the identical text appears in both areas…see below.

 
Also, the logos that appear in the original document do not appear in the AOO version.
Although this appears to work as designed, it would be of greater benefit to users if the printed hardcopy were more like the on screen display and the MS Word equivalent, which makes the comments reference context more intuitive.
Comment 3 mroe 2014-08-18 10:17:01 UTC
Please attach an .docx with different comments and a PDF created from this file to reproduce the described behaviour.
Comment 4 papayes 2015-02-20 09:54:01 UTC
Created attachment 84518 [details]
New Options Print  Libreoffice Writer
Comment 5 papayes 2015-02-20 09:55:29 UTC
Created attachment 84519 [details]
Print LibreOffice 4.4 Comment
Comment 6 papayes 2015-02-20 10:01:00 UTC
Hello,
useless to search in Word because since version 4.3 LibO to print the comments in the margin.

Note: it would be better to correct the "End of page" with "Page by Page" or "After each page"
and add using the old F1 indication (OOo V2) "notes should be printed on one extra page after each page containing notes"
A+
Comment 7 oooforum (fr) 2018-09-12 07:50:39 UTC
Remember that LibO license is not compatible with AOO. So, enhancement can't be embedded. One way is to ask LibO's dev to build a patch for AOO.

*** This issue has been marked as a duplicate of issue 94514 ***