Issue 125163 - Cannot set table background using table dialog
Summary: Cannot set table background using table dialog
Status: VERIFIED FIXED
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 4.2.0-dev
Hardware: All All
: P3 Normal (vote)
Target Milestone: 4.2.0
Assignee: Armin Le Grand
QA Contact:
URL:
Keywords:
: 125167 125477 (view as issue list)
Depends on:
Blocks:
 
Reported: 2014-06-26 19:00 UTC by Regina Henschel
Modified: 2016-04-27 21:17 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2014-06-26 19:00:36 UTC
Start a new Writer document.
Insert a table.
Open table property dialog, goto tab "Background"
Select as "Color" for "Cell", select a color, OK.

Expected behavior: The cell, where the cursor is, becomes colored.
Seen behavior: Nothing happens.

If you open a file generated with AOO4.1, cells with background are shown correctly. If you use Table > AutoFormat, the colors are applied correctly.

The table property dialog still has the only tab "Background" in contrast to all the other dialogs, where "Background" were replaced by "Area" and "Transparency". Therefore I guess, that this dialog has been overseen.
Comment 1 Regina Henschel 2014-06-26 19:20:43 UTC
I use AOO420m1(Build:9800)  -  Rev. 1601656.
Comment 2 Oliver-Rainer Wittmann 2014-07-02 10:52:08 UTC
I have seen issue 125167 before this one ;-)

Taking over to work on a solution together with Armin.
Comment 3 Oliver-Rainer Wittmann 2014-07-02 10:53:07 UTC
*** Issue 125167 has been marked as a duplicate of this issue. ***
Comment 4 Armin Le Grand 2014-10-06 13:12:49 UTC
*** Issue 125477 has been marked as a duplicate of this issue. ***
Comment 5 Armin Le Grand 2014-10-06 13:14:55 UTC
Prepared a solution, checked with data exchange to older versions and MS formats. Problem was that table fill handling was not correctly identified as not yet supporting DrawingLayer FillStyles. Added needed stuff to support that.
Comment 6 Armin Le Grand 2014-10-06 14:02:53 UTC
Okay, done.
Comment 7 SVN Robot 2014-10-07 09:41:50 UTC
"alg" committed SVN revision 1629663 into trunk:
i125163 Corrected FillStyle handling for tables in Writer