Issue 125240 - Scrollbars seem to be blocked for right-most or bottom-most cells
Summary: Scrollbars seem to be blocked for right-most or bottom-most cells
Status: CLOSED DUPLICATE of issue 125234
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: 4.1.0
Hardware: Mac Mac OS X, all
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-11 11:58 UTC by hdu@apache.org
Modified: 2014-07-11 12:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hdu@apache.org 2014-07-11 11:58:34 UTC
Splitting of bug 124191 comment 1 which is not related to the original problem reported in that bug. See attachment 83366 [details], attachment 83669 [details] and attachment 83670 [details] for screenshots.

Papayes reported this recipe to reproduce the problem:
  open a new document Calc
  cmd + right arrow key
and / or
cmd + down arrow key
  2 scrollbars are blocked
and can not be moved with the mouse (or the trackpad)

Only on Mac OS. Scrollbars WIN 7 and 8 , OpenSuse or Debian 7 are active ( with Ctrl +...).
Not reproduced on AOO 4.0.1
Workaround: cmd + left arrow key
cmd + up arrow key
Comment 1 hdu@apache.org 2014-07-11 12:07:16 UTC
Debugging into the problem shows that the scrollbars are not blocked but that it is just hard to find and drag the scrollbar thumb, because native widget drawing doesn't know exactly how big OSX actually draws the thumb. [1] reports a similar problem.

[1] https://groups.google.com/forum/#!msg/chromium-dev/yxe372MeG3E/hdMd3Zft4N0J

Code pointer for people interested in fixing it:
  AquaGetScrollRect() for PART_THUMB_HORZ or PART_THUMB_VERT
as used in
  AquaSalGraphics::hitTestNativeControl() for CTRL_SCROLLBAR
Comment 2 oooforum (fr) 2014-07-11 12:53:05 UTC
(In reply to hdu@apache.org from comment #0)
> Papayes reported this recipe to reproduce the problem
Maybe a duplicate of issue 125234
Comment 3 hdu@apache.org 2014-07-11 12:57:46 UTC
T(In reply to oooforum from comment #2)
> (In reply to hdu@apache.org from comment #0)
> > Papayes reported this recipe to reproduce the problem
> Maybe a duplicate of issue 125234

Yup.

*** This issue has been marked as a duplicate of issue 125234 ***