Issue 125269 - Font Styles are limited to 16 styles per family
Summary: Font Styles are limited to 16 styles per family
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.1.0
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2014-07-17 06:50 UTC by Warpoholic
Modified: 2014-07-17 19:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Warpoholic 2014-07-17 06:50:30 UTC
I'm working at a typeface foundry and we try to make our fonts compatible with every relevant software. 
OpenOffice 4.1.0 has several issues one of them definitely can't be solved by us. 
The parts of a font family are limited to 16 styles.
We are creating extended families with up to 30 styles per family.
(in this case 15 weights + 15 italics)

OpenOffice limits them to 16 styles and is therefore randomly eliminating weights.

I’m looking into another issue at the moment but will have to make some testing before getting back.
Comment 1 Warpoholic 2014-07-17 10:19:29 UTC
I just installed OpenOffice 4.1.0 for Windows and can confirm that it's just the Mac version having this issues.
Comment 2 Ariel Constenla-Haile 2014-07-17 16:49:35 UTC
May be a duplicated of Issue 123081 or Issue 124496
Comment 3 Warpoholic 2014-07-17 17:13:19 UTC
Nop. US English here. Still the same problems.
Only 16 weights appear in the Typeface menu.

But thanks. Good to see other are having similar problems.

I've posted another issue 125270 with testfiles and a download link to a open-source family with more than 16 fonts.
Comment 4 Regina Henschel 2014-07-17 19:31:40 UTC
I see no such limit. The "Font" drop-down-list shows 30 fonts. That number is correct, because "Fira Sans", "Fira Sans Italic" and "Fira Sans Bold Italic" are grouped and you have to use the "Typeface" drop-down-list to differ them.

If case you refer to the font list in the context menu– that list is cut on purpose (see issue 61775) and it depends on what other fonts are installed whether you see a "Fira Sans" font or not.

The error I see is, that grouping does not work correctly.
AOO should group the regular and italic font of the same weight. So you should get only one entry in the "Font" list and differ via the "Typeface" list. But that does not work. For example, I see in the "Font list" the font "Fira Sans Eight" and "Fira Sans Eight Italic" as well. There should be "Fira Sans Eight" only. You can easily see, that the grouping fails; when you set a word with font "Fira Sans Eight" to italic via Format > Character, the glyphs are not taken from "Fira Sans Eight Italic" but slanted.
In case of "Fira Sans" AOO does not get the font, which corresponds to the "bold" weight from the "Typeface" drop-down-list, but uses "Fira Sans Bold Italic" for upright Bold too.

MS Word 2010 shows the same error, so it might be a problem in the font itself.

The problem of large font families is already discussed in issue 79878 but somehow stuck.

I work on Windows 7.
Comment 5 Warpoholic 2014-07-17 19:44:42 UTC
Thanks for your detailed response.

As I mentioned above, the issue is not taking place in the Windows version.
It's a Mac problem only.

The fonts we are developing are paired.
Because I could not provide the files, I uploaded a document with the most extended open-source family to prove my point. We are not developing Fira Sans.

Even though our fonts are grouped as a pair, they still show up in the menu.
Some of them don't because there seems to be a limitation which cuts at 16.