Issue 125292 - [SVG] style element is not used for tspan element
Summary: [SVG] style element is not used for tspan element
Status: CLOSED DUPLICATE of issue 125293
Alias: None
Product: Draw
Classification: Application
Component: code (show other issues)
Version: 4.2.0-dev
Hardware: PC Windows 7
: P3 Normal (vote)
Target Milestone: 4.2.0
Assignee: Armin Le Grand
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-21 16:39 UTC by Regina Henschel
Modified: 2014-07-23 15:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Example svg graphics with several places to define the fill color of a tspan element (132.10 KB, application/zip)
2014-07-21 16:39 UTC, Regina Henschel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2014-07-21 16:39:21 UTC
Created attachment 83718 [details]
Example svg graphics with several places to define the fill color of a tspan element

Unpack the attached file. Load the pictures into a browser. All picture have got a tspan element, which should be green.

AOO does only render those tspan content in green, where the fill color is defined with a style attribute or with a non-css property fill="...". All cases, where the fill is given in a style element, the tspan content is not green, independent of the used selector.
Comment 1 Armin Le Grand 2014-07-23 11:10:49 UTC
Grepping...
Comment 2 Armin Le Grand 2014-07-23 11:28:47 UTC
Found, caused by CssStyle handling. It is not hard to fix, but so similar to issue 125293 that it will be mainly fixed with the changes for that. Thus setting this one to double and doing the needed changes in issue 125293.
Comment 3 Armin Le Grand 2014-07-23 11:29:06 UTC

*** This issue has been marked as a duplicate of issue 125293 ***
Comment 4 SVN Robot 2014-07-23 15:09:03 UTC
"alg" committed SVN revision 1612846 into trunk:
i125292, i125293 enhanced CssStyle handling in SVG import