Issue 125293 - [SVG] In text the font-family and fill is dropped, when additional stroke is applied
Summary: [SVG] In text the font-family and fill is dropped, when additional stroke is ...
Status: CLOSED FIXED
Alias: None
Product: Draw
Classification: Application
Component: code (show other issues)
Version: 4.2.0-dev
Hardware: PC Windows 7
: P3 Normal (vote)
Target Milestone: 4.2.0
Assignee: Armin Le Grand
QA Contact:
URL:
Keywords:
: 125292 (view as issue list)
Depends on:
Blocks:
 
Reported: 2014-07-21 17:16 UTC by Regina Henschel
Modified: 2017-05-20 10:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Lines with and without additional stroke (1.01 KB, image/svg+xml)
2014-07-21 17:16 UTC, Regina Henschel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2014-07-21 17:16:52 UTC
Created attachment 83719 [details]
Lines with and without additional stroke

Open attachment in browser. Notice three pair of line with and without stroke. Insert the graphic into a presentation. Notice, that for those lines, which get an additional value for stroke, the properties for font-family and fill are wrong.
Comment 1 Armin Le Grand 2014-07-23 11:11:07 UTC
Grepping...
Comment 2 Armin Le Grand 2014-07-23 11:29:06 UTC
*** Issue 125292 has been marked as a duplicate of this issue. ***
Comment 3 Armin Le Grand 2014-07-23 11:32:19 UTC
Added issue 125293 as duplicate, both need changes in the CssStyle handling.
Adapted the usage of the read SvgStyleAttributes in decomposition creation so that the types 'id', 'class', type, direct attributes and inheritance (hierarchy) are handled as needed.
Checked with given bugdocs from both tasks.
Checked with given bugdocs from issue 125258 (the crash).
Doing more checks with my set of SVG test files...
Comment 4 Armin Le Grand 2014-07-23 15:19:02 UTC
Okay, all my test files look good. Commited version (Committed revision 1612846), done.
Comment 5 Armin Le Grand 2014-07-24 09:11:44 UTC
Also evtl a candidate for AOO411, waiting for Regina's comments...
Comment 6 Armin Le Grand 2014-07-25 15:37:43 UTC
Regina has sent more test docs with CssStyles which showed that more work is needed. Investigated, found solutions. Committing needed changes...
Comment 7 SVN Robot 2014-07-25 15:38:48 UTC
"alg" committed SVN revision 1613452 into trunk:
i125293 Further corrections for CssStyle handling in SVG importer
Comment 8 Armin Le Grand 2014-07-29 14:35:20 UTC
Even more tests with comma-separated selector definitions and mixed selectors in the nodes (type, class, id). Adapted CssStyle handling to be more unified (as preparation to deeper changes) and the solver to use prioritized hierarchy and specificity combinations. That solves all cases I have for now and the new ones. It handles space- and comma-divided selectors and combinations of type, id and class. Adding...
Comment 9 SVN Robot 2014-07-29 14:36:31 UTC
"alg" committed SVN revision 1614365 into trunk:
i125293 More unified (still simple) CssStyles and solvers
Comment 10 Regina Henschel 2014-08-01 15:22:10 UTC
Verfied on AOO420m1(Build:9800)  -  Rev. 1614365