Issue 125296 - conditional hidden paragraph does not update after textfield changes value
Summary: conditional hidden paragraph does not update after textfield changes value
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.2.0-dev
Hardware: All All
: P3 Major (vote)
Target Milestone: 4.1.1
Assignee: Oliver-Rainer Wittmann
QA Contact:
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-07-21 17:51 UTC by Oliver Brinzing
Modified: 2017-05-20 10:35 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.1.1_release_blocker+


Attachments
hidden_paragraph_no_refresh (10.89 KB, application/vnd.oasis.opendocument.text)
2014-07-21 17:51 UTC, Oliver Brinzing
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Oliver Brinzing 2014-07-21 17:51:50 UTC
Created attachment 83721 [details]
hidden_paragraph_no_refresh

- open attached *.odt
- click button to run macro
-> X_TEST is set to value "Hello Word!"
--> hidden paragraph should be shown now
-> F9 refresh does not help

it worked in aoo 401 - so it's a regression

maybe related to:
[Issue 125044] conditional text field does not update view after changing variable
https://issues.apache.org/ooo/show_bug.cgi?id=125044

[Issue 124231] named range with visibility condition can crash writer
https://issues.apache.org/ooo/show_bug.cgi?id=124231
Comment 1 Oliver Brinzing 2014-07-21 17:52:27 UTC
setting keywords
Comment 2 Oliver-Rainer Wittmann 2014-07-22 07:21:22 UTC
taking over to have a closer look.
Comment 3 Oliver-Rainer Wittmann 2014-07-22 10:15:36 UTC
Works fine also in AOO 4.1.0

Defect caused introduced by fix for issue 125044.

Fix is in progress.
Fix has to be integrated into planned 4.1.1 release from my point of view.
Comment 4 SVN Robot 2014-07-22 10:43:34 UTC
"orw" committed SVN revision 1612539 into trunk:
125296: correction of fix for issue 125044
Comment 5 jsc 2014-07-22 12:51:49 UTC
grant showstopper flag
Comment 6 SVN Robot 2014-07-23 07:12:03 UTC
"orw" committed SVN revision 1612778 into branches/AOO410:
125296: correction of fix for issue 125044
Comment 7 Oliver-Rainer Wittmann 2014-07-23 07:20:02 UTC
fixed on trunk and branch AOO410 for planned 4.1.1 release
Comment 8 Oliver Brinzing 2014-07-25 14:07:36 UTC
seems to be fixed in aoo 4.1.1 m3  rev. 1612804
Comment 9 fanyuzhen 2014-07-31 09:48:26 UTC
Mark it fixed based on reporter's comment 8