Issue 125391 - The textbox object's location changes after importing the sample file
Summary: The textbox object's location changes after importing the sample file
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: 4.2.0-dev
Hardware: All All
: P3 Minor (vote)
Target Milestone: 4.2.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-08 03:03 UTC by Steve Yin
Modified: 2016-03-21 22:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample (23.00 KB, application/msword)
2014-08-08 03:03 UTC, Steve Yin
no flags Details
snapshot (10.14 KB, image/png)
2014-08-08 03:04 UTC, Steve Yin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Steve Yin 2014-08-08 03:03:32 UTC
Created attachment 83805 [details]
Sample

Steps:
1. Open the sample document.
2. Check the textbox's location.

Problem:
Comparing with the snapshot (open with MSO), the textbox's location changes in AOO
Comment 1 Steve Yin 2014-08-08 03:04:05 UTC
Created attachment 83806 [details]
snapshot
Comment 2 Steve Yin 2014-08-08 03:34:18 UTC
Root cause:
The location of a textbox object will be different. It depends on whether the textbox is inside or outside a table.

Solution:
Add a condition of checking whether a textbox object is inside or outside a table.
Comment 3 Steve Yin 2014-08-08 03:37:43 UTC
The fix patch was provided by Oliver.
Comment 4 SVN Robot 2014-08-08 07:34:15 UTC
"steve_y" committed SVN revision 1616666 into trunk:
Issue 125391 - The textbox object's location changes after importing the samp...