Issue 125446 - Error Message "Key not valid for use in specified state" during attempted installation
Summary: Error Message "Key not valid for use in specified state" during attempted ins...
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: 4.1.0
Hardware: PC Windows Vista
: P3 Blocker (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 125692 (view as issue list)
Depends on:
Blocks:
 
Reported: 2014-08-17 10:44 UTC by aoobugs
Modified: 2014-10-20 08:28 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description aoobugs 2014-08-17 10:44:33 UTC
Error Message "Key not valid for use in specified state" during attempted installation.  Previous version installed and ran fine.  Now I get the same error when attempting to install any version.
Comment 1 oooforum (fr) 2014-08-18 07:51:21 UTC
As you mention Vista, this makes me think UAC and restricted tokens.
So, it's not an AOO issue but with your Windows system.
Comment 2 Rob 2014-08-23 15:44:24 UTC
I am running windows 8 and I have the same problem
Comment 3 Ariel Constenla-Haile 2014-08-23 16:16:53 UTC
A search on the web shows that this is a recurrent bug in Windows.
Try to solve it by running 
http://support.microsoft.com/mats/program_install_and_uninstall/en-us
Comment 4 aoobugs 2014-08-24 21:16:19 UTC
Ariel, Thank you for trying to help me.  Unfortunately downloading and running the fix from the Microsoft link you provided did not fix the problem.

 (In reply to Ariel Constenla-Haile from comment #3)
> A search on the web shows that this is a recurrent bug in Windows.
> Try to solve it by running 
> http://support.microsoft.com/mats/program_install_and_uninstall/en-us
Comment 5 Ariel Constenla-Haile 2014-08-24 21:40:44 UTC
(In reply to aoobugs from comment #4)
> Ariel, Thank you for trying to help me.  Unfortunately downloading and
> running the fix from the Microsoft link you provided did not fix the problem.

Did you try other fixes suggested on the web? Just search "Key not valid for use in specified state", you'll several suggestions (for example to move the contents of "C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Cry pto\RSA" to another location and then ran the install again, etc.)

This is likely a bug in your system, not with OpenOffice, because the installation files are not signed, that is, there is no key at all.
Comment 6 Ariel Constenla-Haile 2014-08-24 21:46:01 UTC
For example:

http://classicshell.net/forum/viewtopic.php?t=3089&p=14450
http://discussions.tomtom.com/t5/XL-XXL-HOME/FAQ-TomTom-HOME-installation-issues-quot-Key-not-valid-for-use/td-p/880423

These two sites suggest it is a bug in one of the recent MS updates.
Comment 7 Rob 2014-08-25 11:45:36 UTC
Many thanks to dviguhix.
Deleting KB29186414 worked for me.
Can now install OO latest version and update java which was impossible before.
Thank you !!
Comment 8 Rob 2014-08-25 11:46:44 UTC
thats KB 2918614
Comment 9 Ariel Constenla-Haile 2014-08-27 17:02:50 UTC
Also reported on the Forum:
https://forum.openoffice.org/en/forum/viewtopic.php?f=15&t=71850
Comment 10 aoobugs 2014-08-30 23:56:03 UTC
Deleting KB2918614 worked for me too.  Thanks everyone.
Comment 11 mroe 2014-09-29 19:07:40 UTC
*** Issue 125692 has been marked as a duplicate of this issue. ***
Comment 12 Marjorie 2014-10-13 19:24:23 UTC
I tried to installed 4.1.1 (upgraded from 4.1.0) no luck.  I always get error.  I use Windows 8.1.  I also not have KB2918614.  What should I do?  I like this better than MS Words, etc...  Help me  Thanks
Comment 13 oooforum (fr) 2014-10-20 08:28:38 UTC
(In reply to Marjorie from comment #12)
> I tried to installed 4.1.1 (upgraded from 4.1.0) no luck.  I always get
> error.  
What error?

If you want some help to install, the best way is to post on our end-users forum:
https://forum.openoffice.org