Issue 125579 - DOCX embedded graphic doesn't import
Summary: DOCX embedded graphic doesn't import
Status: CLOSED DUPLICATE of issue 118040
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: 4.1.1
Hardware: PC Windows XP
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-04 17:11 UTC by craigt
Modified: 2017-03-04 08:58 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Missing graphic (61.11 KB, application/octet-stream)
2014-09-04 17:11 UTC, craigt
no flags Details
Diagram comparison between .doc and .odt (45.85 KB, image/gif)
2015-05-01 19:39 UTC, Sally Lai
no flags Details
SampleFile.docx opened in LO and in Writer. (73.82 KB, image/png)
2016-02-15 00:01 UTC, John
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description craigt 2014-09-04 17:11:18 UTC
Created attachment 83931 [details]
Missing graphic

Several DOCX documents that I've opened have had this problem; embedded graphics are missing when opened with Writer.

The attachment "SampleFile.docx" illustrates this problem.
Comment 1 oooforum (fr) 2014-09-05 09:51:26 UTC
Import filter not perfect at 100%
Embeded objects from OOXML seems to be not managed
Possible duplicate of issue 115417 - issue 113860 - issue 118040
Comment 2 Heli Desai 2014-09-30 23:08:13 UTC
Hardware used : Windows 8

• First of all try and copy any document from Microsoft    Word or any other platform which contains logos or images with some description in it. 
• Now if we paste the same file in the Open Office    Writer it will give a blank space in place of the given logo. no logo appears when pasted, whereas actually it should copy all the details shown in the word but it does not so it is a bug. This is how I have compared Microsoft Word and Open Office Writer and have found the bug which should be corrected. 
There another example to prove that this is actually an error in Open Office Writer. This example is that I have tried copying stuff from the web if that works or not so let us check it : 
• Firstly open some page on the web which has some images and details about something. 
• That information I am going to paste in the writer and So while copying in the writer it stays as it is or it gives a blank space. There is a blank space in place of that image which means this is a bug in the Writer. Because if I copy the same thing in Word it gives the image as on the web but not on Writer. 
This means that the issue which I have picked is reproducible and it is an error or bug which has to be taken into account. And it replicates the problem given in the issue.
Comment 3 Sally Lai 2015-05-01 19:39:57 UTC
Created attachment 84717 [details]
Diagram comparison between  .doc and  .odt
Comment 4 Sally Lai 2015-05-01 19:43:05 UTC
I use the attached .docx file (attachment 83931 [details]) to replicate the problem successfully on Window 7.
I  also compare the .doc and .odt files which saved from the same original .docx file.

The steps I performed -- 
1.	Save the original .docx file to .doc and .odt.
a.	In MS Word 2010: Save the sample file (.docx)  provided by the original reporter to .doc
-	Get “MS Word Compatibility Checker” message. Click Continue button.
b.	In MS Word 2010: Save the original sample file (.docx) to .odt
-	Get “MS Word” warning – Samplefile.docx may contain features that are not  compatible with this format… Click Yes.
c.	Compare 3 files in MS Word 2010. I don’t notice any difference among these files.

2.	Open the original and two other file-extension sample files in AOO 4.1.1 / Window 8.
a.	Sample file.docx (72 KB) – attached by the original reporter
The bug is replicated. The diagram cannot display. 
b.	Sample file.doc (164 KB)
The bug is not replicated. The diagram displays on AOO Writer.
c.	Sample file.odt (21.8 KB)
The bug is not replicated. The diagram displays on AOO Writer.
d.	Compare .doc and .odt in AOO, I found the word “connector” in left-upper cloud is split into 2 lines (r is dropped to the next line). Please see attached “File Comparison”. 
  
From the above test results, we know AOO 4.1.1 can process  .doc and .odt files originated from MS Word but may have minor alignment issues in .odt.  Therefore, before AOO can deal with .docx files, saving the docx files to .doc file for AOO may be an accessible workaround.
Comment 5 Stephan Stross 2015-10-06 21:05:59 UTC
Windows 10
Open Office 4.1.1 AOO411m6(Build:9775)-Rev. 1617669
i7-4770 CPU
16GB RAM

I can confirm that the bug still exists in the above (rather recent) version of AOO on Windows 10.
Steps:
1. Load into Microsoft Word 365, and select Save-As, making .doc and .odt copies of the file.
2. Open all three formats of the file in AOO Writer. Only the .docx version fails to show the images. The .doc and .odt formats are working fine, and have the images represented correctly.
For the .docx file, it places blank lines in the file, which are approximately large enough to accommodate the image file being linked, but it doesn't actually load the image. After unzipping the docx, I noticed that the only filetypes inside of it are .xml files, and .rels files, neither of which seem to be a recognizable image format. Perhaps parsing those is the issue?
Comment 6 John 2016-02-14 23:31:02 UTC
This is almost certainly because the images are contained within Microsoft Word Textboxes, and Writer does not handle textboxes.  

There are 21 instances of the textbox tag in the HTML including, for example:

<v:textbox>
<w:txbxContent>
<w:p w:rsidR="00507A3F" w:rsidRDefault="00507A3F" w:rsidP="00507A3F">
<w:pPr>
<w:pStyle w:val="NormalWeb"/>
<w:spacing w:before="0" w:beforeAutospacing="0" w:after="160" w:afterAutospacing="0" w:line="256" w:lineRule="auto"/>
</w:pPr>
<w:r>
<w:rPr>
<w:rFonts w:eastAsia="SimSun" w:cs="Arial"/>
<w:sz w:val="22"/>
<w:szCs w:val="22"/>
</w:rPr>
<w:t xml:space="preserve">JP2 </w:t>
</w:r>
</w:p>
<w:p w:rsidR="00507A3F" w:rsidRDefault="00507A3F" w:rsidP="00507A3F">
<w:pPr>
<w:pStyle w:val="NormalWeb"/>
<w:spacing w:before="0" w:beforeAutospacing="0" w:after="160" w:afterAutospacing="0" w:line="256" w:lineRule="auto"/>
</w:pPr>
<w:r>
<w:rPr>
<w:rFonts w:eastAsia="SimSun" w:cs="Arial"/>
<w:sz w:val="22"/>
<w:szCs w:val="22"/>
</w:rPr>
<w:t xml:space="preserve"> 1</w:t>
</w:r>
</w:p>
</w:txbxContent>
</v:textbox>

See Textbox, and text in it, in docx file not recognised by OOo at https://forum.openoffice.org/en/forum/viewtopic.php?f=7&t=58829 which points to  https://issues.apache.org/ooo/show_bug.cgi?id=117910, https://issues.apache.org/ooo/show_bug.cgi?id=93842 and https://issues.apache.org/ooo/show_bug.cgi?id=117980

LibreOffice FULLY SUPPORTS textboxes in .docx files and also provides Insert > Textbox to permit users to add Textboxes to .odt files.
Comment 7 John 2016-02-15 00:01:19 UTC
Created attachment 85286 [details]
SampleFile.docx opened in LO and in Writer.

On further analysis it seemss that although the docx file has 10 paired instances of the MS Word textbox tag, and one instance of the textboxrect tag, the problem appears to be that Writer is not recognising the two Draw objects Canvas 1 and Canvas 33.  See attached image of file opened in LO and Writer.
Comment 8 Nick 2016-02-17 03:58:30 UTC
Windows 10, surface pro 3 i5
version 4.1.2

Was able to replicate bug as documented by other users on the latest update of AOO.
Opening the sample file provided "missing graphic" in MS Word 365 no problems were found. However, when opening the same file in Writer, it was unable to display the images. A blank space took their place.
Comment 9 Gemma Serra 2016-04-09 19:27:02 UTC
Windows 8.1
Writer 4.1.2
Docx created with Word 2013

I confirm that it's reproducible with this configuration. 

Steps:

1. Create a new document in Word
2. Add a canvas Insert -> Shapes -> Add drawing canvas
3. Add a shape, for example a rectangle
4. Save the document with docx format
5. Open the document with Writer -> the shape is not attached

Save the document in odt format
1. Repeat steps 1,2,3
2. Save the document with odt format
3. Open the document with Writer -> the shape is displayed
Comment 10 jcai27 2016-09-23 03:14:40 UTC
I have successfully replicated the bug using the following build and configuration:
Windows 7 professional service pack 1
Apache office 4.1.2 AOO412m3(Build:9782)  -  Rev. 1709696


Steps to replicate the bug 
1.	Open a new file in office 360
2.	Draw a shape (insert->shape)
3.	Insert a text box(insert->textbox), and type a few words in the text box
4.	Save the file in three different files (.docx, .doc, and .odt)
5.	Open the files in OO writer compare the files


Result:
The OO writer will open the .doc, and .odt file with the expected results. Everything are displayed the same as in office 360. However, when open the .docx file in OO writer, it did not display the shapes and even text boxes. It seems that OO writer does not fully support .docx file, some content will not be displayed.
Comment 11 jahsu 2016-09-28 00:05:01 UTC
Windows 10 Home
Apache OpenOffice 4.2.0 AOO420m1(Build:9800) - Rev.1761251

I have successfully replicated the bug on Windows 10 in the OpenOffice 4.2.0 build.

The following are steps I have taken to replicate the bug:
1.	Open a new document in Microsoft Word 2016.
2.	Insert a graph image by clicking on Insert->Chart then selected ‘ok’ on the default chart image.
3.	Insert a shape by clicking on Insert->Shapes then selected the “no” symbol under basic shapes.
4.	Saved the document in as a .docx file.
5.	Opened the .docx file in OpenOffice Writer.
6.	Repeated steps 1-5 but saved file as a .odt instead of .docx

Result:
OpenOffice Writer will open the .docx file, but the insert image and shape will not be displayed and instead display a blank line. However, Writer will display the images in the .odt version of the file. It appears that OpenOffice Writer does not fully support .docx files. This could potentially be an issue since Microsoft Office has a default save file type of .docx.
Comment 12 oooforum (fr) 2017-03-02 08:43:04 UTC
.

*** This issue has been marked as a duplicate of issue 118040 ***