Issue 125672 - Error "index out of bounds"
Summary: Error "index out of bounds"
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.1.0
Hardware: Mac Mac OS X 10.7
: P3 Normal with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: crash
Depends on:
Reported: 2014-09-25 07:54 UTC by Sebastian Weigert
Modified: 2017-05-16 22:16 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

console log (77.34 KB, text/plain)
2014-09-25 07:54 UTC, Sebastian Weigert
no flags Details
the file I was working on when the error started manifesting (46.01 KB, application/vnd.oasis.opendocument.text)
2017-05-16 21:54 UTC, myroslava
no flags Details
console log with a couple of reinstalls of OOo (96.84 KB, text/plain)
2017-05-16 21:55 UTC, myroslava
no flags Details
short log of launching ODT file, no error (2.33 KB, text/plain)
2017-05-16 22:06 UTC, myroslava
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Sebastian Weigert 2014-09-25 07:54:00 UTC
Created attachment 83986 [details]
console log

Writer 4.1.0 sometimes crushes down and creates Error "index out of bounds"
The problem maybe similar to Issue 124970, 
but the solution given (comment 30) there does not work in my case, and the crush is not dependent on any mouse or trash pad action.

view the console log as attachment
Comment 1 vo1d 2015-02-09 06:01:16 UTC
I get this error with OO 4.1.1 on MacOS 10.10.2 every few minutes. Makes OO unusable.
Comment 2 Rick 2015-02-18 20:43:08 UTC
Makes open office almost unusable...constantly crashes to a index out of range error 4.1.1 and OS X 10.10.1
Comment 3 Ariel Constenla-Haile 2015-02-19 00:13:29 UTC
Can you provide a terminal log?
Comment 4 Eric 2015-03-15 15:00:57 UTC
Mac OS 10.10.2
OpenOffice 4.1.1 
Fatal Error
Index out of bounds

Using word processor ...
    This often happens to me at the bottom of a document when I am pasting text from a clipboard copy taken from an Adobe Reader. It seems to be more likely to happen if I invoke 'overwrite' mode as opposed to 'insert' mode.
    I work around it by adding a number of blank lines (CRs) and an inserted page break that I ensure remains beyond my active work area.
Comment 5 Alex 2016-11-24 23:25:26 UTC
I am on OO 4.1.3 and receive an easily reproducible Fatal Error: Index Out of Bounds. This issue has persisted through previous versions of OO. I am running OS X El Capitan, 10.11.6.

The way I can reproduce it is as follows:

1. Create a new document
2. Insert a page break with cmd+enter
3. Click below where the cursor is on the 2nd page
Comment 6 tdinovo 2017-02-20 20:25:33 UTC
Mac OS 10.11.6
OpenOffice 4.1.3

Unable to reproduce issue via reported methods. Multiple PDF's were used in Test Cases 2 and 3;

Test 1:
1.	Launch Writer
2.	Insert a page break with cmd + enter
3.	Click below where the cursor is on the 2nd page

Test 2:
1.	Launch Writer
2.	Launch Adobe Reader
3.	Verify Insert mode
4.	Copy contents from pdf in Adobe Reader via cmd + c
5.	Paste contents to Writer via cmd + p

Test 3:
1.	Launch Writer
2.	Switch to overwrite mode
3.	Copy contents from pdf in Adobe Reader via cmd + c
4.	Paste contents to Writer via cmd + p
Comment 7 myroslava 2017-05-16 21:53:26 UTC
I have had a similar problem. Not a dev; advanced user.

The version of OOo that was installed was 4.1.1. I first got this error while, with another app (Firefox) in foreground and in focus, I clicked on an odt file that was below it, and clicked on a second page of a document that just barely overflowed onto a second page while the first page had a table that reached to the end of the first page. I relaunched OOo, waited for the recovery of the document, tried to click once again under the table on the second page—same s**t. After that there was a flurry of activity that I don't think I can reproduce, which is why I'm posting my console log starting from the time that I think the problem started, and it's a long log that ends only after the error stopped manifesting. What I was doing: I tried clicking within the table, it didn't produce an error. Clicking below the table—error repeats. I started downloading 4.1.3 and googling for solutions. I installed 4.1.3 (had to disable MacOS defense against unconfirmed developers). I think it was after that that I also tried resetting my user profile. I relaunched OOo, opened the same file, got the same error, and restored my old user profile. Opened the same file again, got the same error (again while clicking below the table). Created a new Writer file, clicked somewhere on the lower margin—same error. Then I downloaded 4.1.0, installed it. Opened my table file, clicked under table—same error. Opened an ODG file I have, created a new page in it, clicked around it—no error; I closed the file without saving. I'm not sure at which point I opened the ODG file. Also at some point I increased the cache allowance in OOo settings. At some point then, the error stopped manifesting, and I can't reproduce it now. Hope someone can make heads or tails of my console log. I'm also attaching the file with the table with which the error first started. Unfortunately, the file is _not_ in the same state in which it was when I got the error, because in-between it all I saved it, and then after the error stopped I edited it and then saved again. I'm attaching it just in case, too; please not it did _not_ have an image inside it when the error started. It was just a plain table, nothing heavy.
Comment 8 myroslava 2017-05-16 21:54:33 UTC
Created attachment 86103 [details]
the file I was working on when the error started manifesting
Comment 9 myroslava 2017-05-16 21:55:08 UTC
Created attachment 86104 [details]
console log with a couple of reinstalls of OOo
Comment 10 myroslava 2017-05-16 22:06:41 UTC
Created attachment 86105 [details]
short log of launching ODT file, no error

for comparison purposes, here is a short log created from the following:
- OOo not running;
- I launch my odt file by double-clicking from Finder;
- I add a couple of lines below the table, then add a couple of lines in the table, click on the 2nd page several times below the table; no error happens;
- I close the file;
- I quit OOo.
Comment 11 myroslava 2017-05-16 22:14:06 UTC
forgot to mention that I'm on OS X El Capitan, 10.11.6 (although the console log has information pointing to this :) )