Issue 125686 - English Spellchecker in Writer Underlines every word
Summary: English Spellchecker in Writer Underlines every word
Status: CLOSED DUPLICATE of issue 121930
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: 4.1.1
Hardware: PC Windows 8, 8.1
: P3 Major (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL: https://drive.google.com/file/d/0B_nJ...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-27 17:51 UTC by normanlk99
Modified: 2017-05-20 10:11 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description normanlk99 2014-09-27 17:51:22 UTC
Every Writer document I open/create has every word underlined as though it's misspelled, and the synonyms and thesaurus suggestions are blank (it does not provide a suggestion).

I have downloaded and installed the latest OpenOffice OS, as well as the latest language patch. I downloaded and installed various English dictionaries, testing them one by one to see if it fixes the problem. Nothing works; the problem persists.
Comment 1 Madeline Hall 2014-09-28 20:57:43 UTC
Spell check starts at the first word in a sentence and not where the cursor is.  The message says (no suggestions).
Comment 2 oooforum (fr) 2014-09-29 08:44:42 UTC
You are in wrong place here. This is a bug system tracket not an helpdesk.

A very large proportion of spellcheck problems in OpenOffice are cured by deleting or renaming the OpenOffice User Profile
See details are given in
https://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=12426

If this does not work, please bring your problem to the end-user forum at
https://forum.openoffice.org/en/forum/
Comment 3 tejaswini 2014-10-12 03:06:42 UTC
b)	Replicating the Bug:
I was unable to replicate the bug. The following are the steps to show that I was unable to replicate the bug:
1.	Create a new document in openoffice writer.
2.	Type some statements/words in the document and also include the wrongly spelt words in the middle of the statements.
3.	I have observed that only the wrongly spelt words were underlined and other words were not.
I follow-up the steps for detecting the bug. But I was unable to replicate the bug because I can able to show the correct working of the spell checker in the openoffice writer. But the report says that it’s still not working. So there is some misinterpretation in the report that portraying the enhancement as a defect. I have tested in the openoffice writer for twice to cross check the described defect but resulted in vain.
Comment 4 VJ 2014-10-12 06:32:17 UTC
System Specifications:

Windows 7 Home Premium
Service Pack 1
Model- VIAO Computer 
Processor- Intel (R ) Core(TM ) i3 CPU  M330 @2.13GHz
Installed memory (RAM)- 4.00 GB (3.67 GB usable) 
System Type- 64- Bit Operating System

The Bug DID NOT replicate under the following system specifications.

Steps taken to replicate it:

Attempt 1.
STEP1. Downloaded the new:  Apache OfficeOpen 4.1.1 version
STEP2. Installed the complete package
STEP3. Created a New Document in the OpenOfficer Writer 
STEP4. Once a new, empty file was open, I wrote a few lines of text with a combination of correct as well as incorrect words
STEP5. Saved the document as  .odt extension.
STEP6. While analyzing the document, only the words that were misspelled were underlined, not all the words

Attempt 2. 
I followed the STEPS 3 to 5 again to check if the results are different, but the OpenOffice Writer spell checker works completely fine and is not duplicating the bug reported.

Follow Up Test:

Attempt 3.
STEP1. Created a New Document in Microsoft Word 
STEP2. I wrote a few sentences with correct as well as incorrect words
STEP3.  Saved the document as .odt extension
STEP4. Opened the saved document in OpenOffice Writer  
STEP5. Only the incorrect words were underlined by spell checker 

After following the steps, I was not able to replicate the bug successfully. The Spell Checker worked perfectly and only underlined the misspelled words, and not every single word, unlike as mentioned in the Bug Report. Therefore, the bug does not replicate in Windows 7, but since the person who originally reported the bug uses Windows 8, there might be a problem with that system.
Comment 5 Rushabh 2014-10-12 07:08:31 UTC
When replicating the bug I was not able to create and here are the steps that I had followed to replicate the bug. 

1. Open new document on OpenOffice Writer.

2. Then write any number of words/statements on the document while including wrongly spelled words in between the sentences. 

3. In my document only wrongly spelled words were underlined with the red line and all the other words were not underlined and I tried to replicate this bug many times but I was not successful in replicating it.
Comment 6 Ariel Constenla-Haile 2014-10-12 15:47:21 UTC
Dup. of bug 121930
Follow the advice in bug 125634 comment 3

*** This issue has been marked as a duplicate of issue 121930 ***