Issue 125762 - Writer crashed when I tried to close bibliography table
Summary: Writer crashed when I tried to close bibliography table
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: 4.1.1
Hardware: Mac OS X 10.9
: P3 Normal (vote)
Target Milestone: 4.1.4
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2014-10-16 21:56 UTC by ugur
Modified: 2017-10-21 18:14 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.3
Developer Difficulty: ---
arielch: 4.1.4_release_blocker+

Writer crash log (97.23 KB, text/plain)
2014-10-16 21:56 UTC, ugur
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ugur 2014-10-16 21:56:44 UTC
Created attachment 84073 [details]
Writer crash log

1 Opened Bibliography by clicking "Data Sources" button on the toolbar
2 Tiered down until biblio table
3 Clicked "Nonprinting Characters" button on the toolbar
4 Clicked "Data Sources" button again.
Writer crashed!
Refer to the attachment for log.
Comment 1 gmoody2013 2015-09-22 23:54:51 UTC
Attempted to recreate bug, using a Windows build of version 4.1.0, instead of the Mac OS version.
Following the steps listed, could not recreate the crash.
Also attempted additional steps, such as: tiered down all items in Data Sources, entering text into biblio table, and entering text into document. None of these additions replicated the error.
Comment 2 Matthias Seidel 2016-09-08 20:57:30 UTC
I can confirm the crash with v4.1.2 on Ubuntu 16.04.1.

1. open "Data Sources" with F4
2. expand Bibliography
3. close "Data Sources" with F4
Program crashes

Without expanding "Bibliography" I can close "Data Sources" without crash.
Comment 3 Matthias Seidel 2016-09-10 14:49:42 UTC
Crash does not occur in 4.1.2 under Windows (Win 8.1 / 32bit).
Nor does it crash 4.1.2 under OS/2. ;-)

So it may be only related to Mac and Linux (Ubuntu 16.04.1 / 64 bit in my case)
Comment 4 Matthias Seidel 2016-09-15 15:45:22 UTC
If OpenOffice is started as root (sudo openoffice4) the crash does not occur on Ubuntu 16.04.1

Maybe the problem is related to issue 126980:
Comment 5 hanya 2016-09-19 13:25:31 UTC
I could confirm the problem on Ubuntu 16.04.1. 
The reson is null pointer reference in SvListView::IsExpanded method.
Comment 6 SVN Robot 2016-09-19 13:29:15 UTC
"hanya" committed SVN revision 1761439 into trunk:
#i125762# fix null pointer reference while accessibility related call
Comment 7 hanya 2016-09-19 13:32:12 UTC
Fixed on trunk.
Comment 8 Matthias Seidel 2016-09-22 21:34:44 UTC
Tested with a 4.2.0 dev build of SVN r1761670 (Ubuntu 16.04.1 / 64bit) and the problem is no longer visible!
Comment 9 Matthias Seidel 2016-10-06 20:22:48 UTC
(In reply to SVN Robot from comment #6)
> "hanya" committed SVN revision 1761439 into trunk:
> #i125762# fix null pointer reference while accessibility related call

This fix should be included in 4.1.4

It solves most of the crashes in Ubuntu (and maybe any distribution with a gnome-based DE?) together with
Comment 10 SVN Robot 2017-02-02 21:54:32 UTC
"arielch" committed SVN revision 1781473 into branches/AOO414:
i125762 - Prevent NULL pointer dereference
Comment 11 Ariel Constenla-Haile 2017-02-02 21:55:06 UTC
Revision 1761439 is merged now on branch AOO414
Comment 12 Kay 2017-08-17 20:54:36 UTC
Running Linux-32 bit on CentOS 6.9 with 4.1.4  Rev. 1804788 (RC 2). No issues going through the steps given in the initial description. So verified, fixed on my setup but we probably need additional testing.