Issue 125982 - OpenSymbol font cannot be displayed correctly by Windows 8
Summary: OpenSymbol font cannot be displayed correctly by Windows 8
Status: CLOSED DUPLICATE of issue 124203
Alias: None
Product: Math
Classification: Application
Component: ui (show other issues)
Version: 4.1.1
Hardware: PC Windows 8, 8.1
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2014-12-30 17:45 UTC by Martin
Modified: 2019-01-20 13:54 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

modified OpenSymbol font (44.38 KB, application/zip)
2014-12-30 17:45 UTC, Martin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Martin 2014-12-30 17:45:44 UTC
Created attachment 84328 [details]
modified OpenSymbol font

When using formulas (e.g. in Impress) Windows 8 replaces the glyphs by a different font (smaller and without serifs). One effect of this is that operstors like cdot are misplaced. Even more serious is the 'broken' square root sign.
This is independent from OO version - I've tried 3.3, 4.1.0 and 4.1.1. The same documents look correctly on Windows 7 (or older).
The root cause is the OpenSymbol.ttf - Version 2.4.3. Several font editors (e.g. FontForge, FontCreator) report bugs and inconsistencies loading this font file. So I created a new OpenSymbol based on the old version 1.7, added some missing glyphs and now it works even on a Win 8 system. You can find this file here:
Comment 1 Joe Smith 2014-12-31 06:53:52 UTC
Looks like the same problem reported in issue 124203
Comment 2 Peter 2019-01-20 10:56:05 UTC
Then lets mark this one as duplicate of 124203.

*** This issue has been marked as a duplicate of issue 124203 ***