Issue 126051 - Spurious insertion of page break and paragraph break in the footer
Summary: Spurious insertion of page break and paragraph break in the footer
Status: CLOSED DUPLICATE of issue 126001
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: 4.1.0
Hardware: PC Windows 8, 8.1
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-19 23:57 UTC by Ng Koh Wee
Modified: 2017-05-20 10:11 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
A cleaned up document for you to try editing and then saving to illustrate this spurious additions of breaks. (39.50 KB, application/msword)
2015-01-19 23:57 UTC, Ng Koh Wee
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Ng Koh Wee 2015-01-19 23:57:30 UTC
Created attachment 84441 [details]
A cleaned up document for you to try editing and then saving to illustrate this spurious additions of breaks.

If there is a footer on a page, the first time the document is saved in .doc format and closed, a page break is insert as the first character in the footer. Subsequent times the document is saved and closed, an additional paragraph break is inserted just after the page break inserted the first time around.

Deleting these spurious breaks does not help as the same cycle takes place every time.

I have attached an example (with the breaks already cleaned up) for you to edit and then save to illustrate this issue.

This issue existed as far back as version 3.4
Comment 1 oooforum (fr) 2015-01-20 14:43:36 UTC
I reproduce only with you document.
If I create a new doc, insert a footnote, save and reload.
None page break is inserted after anchor.

Your file seems to be a docx.
In Properties, I see "Normal.dotm" as Template.

So try to recreate your document from scratch directly with Writer.
Comment 2 Adina Moldovan 2015-01-20 21:52:52 UTC
I reproduce this issue with the attached document on
- Mac OS X 10.9.5
- Open Office 4.1.1
Comment 3 Adina Moldovan 2015-01-24 21:22:44 UTC
Hello ooforum,

I replicated the spurious insertion of paragraph breaks in the footer. This issues seems to be a duplicate of #126001.

Configurations:
OOo 4.1.1
OS: Windows 8.1 Pro x64, Mac OS X 10.9.5

My steps were:
1. Create a new OOo Writer document
2. Write a text at the beginning of the file (e.g Test)
3. Insert a footnote on that text (with numbering automatic or character, with or without text to footnote)
4. Insert a Manual break of type page break (from Insert Menu -> Manual Break) with style different than None or Default (I tried with styles Endnote, Envelope, First Page, Footnote)
5. Save document as .doc
6. Open it again

Result: the footnote has a paragraph break in the footer. 

Notes:
1. The issue seems to be reproduced only when saving document as .doc 97/2000/XP
2. In case of adding more footnotes on the same page, only the first footnote on that page is affected by the addition of paragraph breaks
3. The footnotes affected by this issue are the ones on the page after the Page break. Though, the first page in the document seems to alway be affected
Comment 4 oooforum (fr) 2015-02-26 09:39:04 UTC
(In reply to Adina Moldovan from comment #3)
> I replicated the spurious insertion of paragraph breaks in the footer. This
> issues seems to be a duplicate of #126001.
Duplicate

*** This issue has been marked as a duplicate of issue 126001 ***