Issue 12615 - Resizing of Formulae does not work
Summary: Resizing of Formulae does not work
Status: CLOSED DUPLICATE of issue 5266
Alias: None
Product: Math
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 Beta
Hardware: PC Linux, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: Oliver Specht
QA Contact: issues@sw
URL:
Keywords:
Depends on: 50234
Blocks:
  Show dependency tree
 
Reported: 2003-03-24 14:41 UTC by tschlechter
Modified: 2013-08-07 14:54 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description tschlechter 2003-03-24 14:41:32 UTC
In Writer version 1.0.2:  
* Resizing per drag&drop is prohibited (no-parking-symbol) even though the object 
size is NOT marked as protected. ERROR 
* Resizing per contextmenu (object-properties: size) is allowed, makes the 
object-box larger, but the formula remains the same size in the upper left corner 
of the resized object-box. ERROR 
=== 
In Presenter version 1.0.2:  
* Resizing per drag&drop is prohibited (no-parking-symbol). In fact the size is 
marked as protected --> no error.  Unchecking the protection box has no 
influence, this new setting is always lost when leaving / reentering the menu. 
* Resizing per contextmenu does work, even if protection is checked. (ERROR, 
fixed in 1.1beta) 
When resizing per contextmenu and unchecking the protection at the same time, 
exactly one resizing operation per mouse is allowed after applying these changes. 
=== 
In Writer version 1.1beta (from OOoCon03-CD):  
* Resizing per drag&drop is prohibited (no-parking-symbol).  
* Resizing per Context-menu is greyed-out.  
2 ERRORS as Protection Checkbox is NOT checked. 
=== 
In Presenter version 1.1beta (from OOoCon03-CD):  
* Resizing per mouse is prohibited (no parking symbol). In fact the size is marked 
as protected, --> no error 
* Resizing per Menue is greyed out. When unchecking protection, the size can be 
changed in the menue. --> no error. ERROR: The new protection setting is always 
lost when leaving the menu, thus always prohibiting resizing by mouse.
Comment 1 tschlechter 2003-04-01 13:12:05 UTC
square-root an n-root Symbols do not display correctly, the hooks are  
omitted, leaving just the line above the argument. 
 
Comment 2 michael.ruess 2003-04-17 09:48:09 UTC
MRU->OS: We finally need a consistent behaviour to prevent manual size
changes to Math-objects. Allowing it via dialog and not allowing it
via mouse is in fact not very reasonable.
Comment 3 Oliver Specht 2003-04-17 11:00:01 UTC
OS: ...need consistent behaviour... sounds like user experience -> CJ
Comment 4 christian.jansen 2003-04-23 12:33:01 UTC
I'll take care of this. We fix this to oo.o 2.0
Comment 5 pratesi 2003-04-27 09:41:43 UTC
> square-root an n-root Symbols do not display correctly, the hooks are
> omitted, leaving just the line above the argument.

Other similar issues: the sqrt, cdot, and right rbrace symbols
do not show correctly in OOo 1.1beta for Linux

- sqrt: only the horizontal line is shown
- cdot: not shown, wrong size for empty space
- right rbrace: vertical centering not correct

Another problem: sizes of formulas seem to be not exactly the same
passing from OOo 1.0.2 and 1.1beta and vice versa.
Comment 6 Unknown 2003-05-23 14:30:23 UTC
The sqrt, nroot symbol problem is fixed in 1.1.beta2
Comment 7 thoru 2003-05-30 20:07:29 UTC
When a caption is added to a (small) formula (by
right-clicking->caption...), the size of the formula stays the same,
thus making the text look very ugly and unreadable.
When I then try too make the text more readable by changing the border
width, the size of the formula itself stays the same (which I think is
ok in this case), but the height of the border scales with the same
aspect ratio (thus making it far too heigh). Changing it's height
isn't possible then. That's only allowed after making it's width smaller.
Comment 8 christian.jansen 2003-09-23 09:45:26 UTC
Accepted.
Comment 9 christian.jansen 2003-11-03 14:22:59 UTC
CJ -> OS: We should allow scaling of formulas in Writer, Calc, Impress
and Draw by mouse or by using the 'Object/Type/Size' dialog. When
users scale the MathObject by using the dialog, the 'Keep Ratio'
opention has to be checked and greyed out. This is important because
it makes only sense to scale MathObject proportional. Of coarse
scaling by mouse shall work proportional, too.

Thomas said that Math stores no 'Original Size' information, if we
can't change this for Q we should disable the 'Original Size' button
in the 'Object/Type/Size' dialog.
Comment 10 michael.ruess 2004-05-07 14:50:50 UTC
Can't be fixed in time. OO later.
Comment 11 tschlechter 2006-02-15 09:35:55 UTC
The described problems from writed 1.1beta and presenter 1.1beta are still
observable in OOo SRC680_m155.
Concerning the resizing of formulae in writer:

The most important way to resize formulae is by specifying the base font size in
the equation editor, because the formulae should fit the text. It would be great
if this font size could be changed for sets of formulae in a document using
different styles for formulae.
Comment 12 kpalagin 2008-01-07 14:04:33 UTC
Seems to be duplicate of http://www.openoffice.org/issues/show_bug.cgi?id=5266.

*** This issue has been marked as a duplicate of 5266 ***
Comment 13 kpalagin 2008-01-07 14:05:30 UTC
Closing.

Please vote for 5266.