Issue 12625 - PDF Export should embed more fonts
Summary: PDF Export should embed more fonts
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 644
Hardware: PC Windows NT
: P3 Trivial with 6 votes (vote)
Target Milestone: ---
Assignee: bettina.haberer
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2003-03-24 19:17 UTC by rainerjung
Modified: 2005-08-06 18:25 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description rainerjung 2003-03-24 19:17:00 UTC
In StarOffice 6.1 Beta 1, german localization, I generated a PDF document from a
writer document. The document contains characters from TrueType fonts which are
neither a standard part of the platform, nor of StarOffice (Frutiger) and also
characters from StarOffice fonts (Thorndale). I saved the document and closed
it. After opening again I could still see these characters correctly.

Then I exported as a PDF and opened the PDF in Acrobat 4. If I look at the list
of fonts in the document via the document properties, I can see, that the
frutiger fonts are embedded, but the Thorndale font is not. 

This might mean, that the PDF file after sending to a user who has not installed
StarOffice/OpenOffice has minor reproduction quality, because the font has to be
substituted.

I understand that the PDF export should be usable for document exchange with
arbitrary recipients (no assumption on their systems) and high quality of
reproduction. Then the PDF export needs to embed all fonts, at least the parts
of the fonts used in the documents (partially embedding fonts is possible).
Comment 1 thorsten.martens 2003-03-31 08:16:18 UTC
TM->BH: This one is an enhancement, please have a look, thanks !
Comment 2 eric.savary 2003-04-16 15:33:20 UTC
Set to "NEW"
Comment 3 lohmaier 2005-08-06 18:24:38 UTC
please try with a current version. OOo should not have problems with this anymore.

If the problem still persits, please file a more detailed report (sample
document, type of font, exported PDF).
Comment 4 lohmaier 2005-08-06 18:25:32 UTC
closing.