Issue 126372 - Default and “Normal” Left and Right page margin values are not equal to displayed margin values.
Summary: Default and “Normal” Left and Right page margin values are not equal to displ...
Status: CLOSED DUPLICATE of issue 45593
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 4.1.1
Hardware: All All
: P5 (lowest) Minor (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-18 04:26 UTC by amelia.maier.jikili
Modified: 2017-05-20 10:11 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Text Doc Examples and Image of Variable Locations (586.70 KB, application/x-zip-compressed)
2015-06-18 04:26 UTC, amelia.maier.jikili
no flags Details
screenshots before and after changing margin values (357.28 KB, application/x-zip-compressed)
2015-10-07 02:28 UTC, Jocsan Macias
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description amelia.maier.jikili 2015-06-18 04:26:17 UTC
Created attachment 84797 [details]
Text Doc Examples and Image of Variable Locations

OpenOffice Writer 4.1.1 
AOO411m6(Build:9775)  -  Rev. 1617669
2014-08-13 09:06:54 (Mi, 13 Aug 2014)

Windows 7 Home Premium Service Pack 1
iBUYPOWER Computers/AMD FX™-4300 Quad-Core Processor 3.80 GHZ
8GB RAM 64-bit Operating System


Summary: (Inches) The values displayed in the Left and Right Page Margin fields (found under Properties Sidebar |Page|Margin|Custom) when the document is just opened or after selecting the “Normal” option (found under Toolbar|Page|Margin) is not the actual value the system is using. They both display 0.79. If you manually enter the same settings (Properties Sidebar|Page|Margin|Custom|Typing in input fields: Left Page Margin/Right Page Margin), the margins move slightly which moves text around the page. This can drastically change the formatting on multi-page files.

1. Open new document. 
   a. Do not change the settings from default.
   b. I am working in inches. Tools|Options|OpenOffice Writer|General|Settings|Measurement unit|inch
2. Fill one page with text.
   a. Make sure the text runs to the end of the last line but does not flow onto a new page. I used text from:  http://randomtextgenerator.com/
3. Change Properties Sidebar|Page|Margin|Custom|Typing in input field: Left Page Margin to 0.79.
   a. This should be the same value that was already displayed in the input field.
   b. => The text will now flow onto a second page, even though the displayed value is still the same.
4. Without resetting the program, select Properties Sidebar|Page|Margin|“Normal”
   a. => The text will go back to displaying the way it did with default settings.
   b. Properties Sidebar|Page|Margin|Custom| Left Page Margin will still display 0.79

The same will happen with the right page margin and I have found that the value of the default or “Normal” margins seems to be somewhere between 0.78 and 0.79.
Comment 1 mroe 2015-06-18 07:21:37 UTC
Look at issue 45593. Maybe it's the same problem.
Comment 2 amelia.maier.jikili 2015-06-18 15:29:37 UTC
(In reply to mroe from comment #1)
> Look at issue 45593. Maybe it's the same problem.

I looked at the issue initially, but I think this is different. The problem isn't that the user needs more accuracy, but that the information displayed does not match the what the system is actually doing. I am fine with a "Normal" margin of 0.79, but I would expect the "Normal" 0.79 to be the same as the manually set 0.79.
Comment 3 mroe 2015-06-18 18:07:11 UTC
You can input any metric independent from your system/program settings.
Your document has margins 2.00 cm = 0.7874[...] in ~ 0.79 in
0.79 in = 2.0066 cm ~ 2.01 cm

Simply input 2.00 cm and 2.01 cm to see your described effect.
Comment 4 Jocsan Macias 2015-10-07 02:26:53 UTC
System configuration:

OpenOffice Writer Version 4.2.0 
AOO420m1(Build:9800)  -  Rev. 1692551
Windows 10 Home Edition
4th Generation Intel® Mobile Core i7-4710MQ Haswell Processor
16GB RAM 64-bit Operating System

I was unable to reproduce the bug with my own document and text. However, I successfully replicated the bug with the sample document itself and also by copying the text from the sample document into my own and following the steps outlined in the original report.
 
Replication steps:

1. Open sample document titled: Step 1 & 2 Error Report OpenOffice Writer.
2. Make sure you are using inches as the measurement unit. 
   a. Found under: Tools->Options->OpenOffice Writer->General->Settings->Measurement            unit.
3. In the Properties sidebar to the right, under Page, click on Margin then select Normal.
4. Input .79 (same as default value already there) in the field corresponding to the Left margin. 
5. Hit OK.

Following these steps, the text overflows into a new page messing up the format of the original document. Clicking on Normal again under the Margin section in the sidebar will cause the document to return back to the original format. The bug only shows up when changing the Left and Right margins from the Properties sidebar with the Normal option selected. The other margin options, top and bottom, did not result in the bug appearing. 

I followed the steps while working with the sample document using millimeter, centimeter, pica, and point measurement units and inputting their default values. The bug only appeared when using inches. 

Additionally, instead of changing the Left Page Margin value from the Properties sidebar as outlined in step 4, I tried changing the margin options from the Page options directly. This can be done by navigating to the margin options by using the menu and clicking Format->Page->Page and finding the Margins section. The bug did not appear using this method.

I included a couple additional screenshots showing the before and after effects of the bug, which also show the locations of the margin values to supplement the sample documents already provided. The original screenshot is in an odd format, and I didn’t have a program to open it.
Comment 5 Jocsan Macias 2015-10-07 02:28:23 UTC
Created attachment 85013 [details]
screenshots before and after changing margin values
Comment 6 mroe 2015-10-07 04:38:57 UTC
Issue 45593 describes rounding problems with inch. It is a generally problem for all modules.

*** This issue has been marked as a duplicate of issue 45593 ***