Issue 126464 - Windows 10 Upgrade Interference with OpenOffice
Summary: Windows 10 Upgrade Interference with OpenOffice
Status: CLOSED OBSOLETE
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: 4.1.1
Hardware: All All
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-15 00:05 UTC by orcmid
Modified: 2018-08-27 19:51 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description orcmid 2015-08-15 00:05:48 UTC
An issue has been entered as a comment 5 on Issue #121581.  That is an inappropriate place.  The relevant text is 

> I recently upgraded to Windows 10. I have no idea whether this is connected,
> but when I looked on Openoffice for the two novels that I am trying to
> publish, they no longer existed. Strangely enough, the colors that I had set
> on my OO writer had been changed back to the gray and white screens. I
> searched for the files in Explorer, and they were listed, but when I tried
> to open them, I got the message that they did not exist. They do not appear
> in Dropobox either, but I just recently installed it.
> 
> In addition to all this, when I tried to login to OO, my account no longer
> existed.I had to create it all over again.
> 
> I still have time to switch back to Windows 7, if this will help. If not, is
> there anything I can do?
> 
> 
> Thank you,  Kate Galante

The text is moved here to provide a recognizable location for issues that appear to be post Windows 10 upgrade related.
Comment 1 orcmid 2015-08-15 00:06:21 UTC
We have not confirmed that there is a defect at this point.
Comment 2 orcmid 2015-08-15 00:12:15 UTC
(In reply to orcmid from comment #0)
> > In addition to all this, when I tried to login to OO, my account no longer
> > existed.I had to create it all over again.

Please explain what you mean by "login to OO."  Please be specific.  Are you talking about something on your computer or are you talking about something on the web?
Comment 3 Kate Galante 2015-08-15 01:12:27 UTC
I meant login to Open Office Community Forum. I had an account before, but the login site did not recognize my name, email, or password. As a result, I created a new account under the name I had before.
Comment 4 orcmid 2015-08-15 04:05:40 UTC
(In reply to Kate Galante from comment #3)
> I meant login to Open Office Community Forum. I had an account before, but
> the login site did not recognize my name, email, or password. As a result, I
> created a new account under the name I had before.

Thanks, glad you got that problem solved.
Comment 5 orcmid 2015-08-15 04:14:15 UTC
(In reply to orcmid from comment #0)
> > I recently upgraded to Windows 10. I have no idea whether this is connected,
> > but when I looked on Openoffice for the two novels that I am trying to
> > publish, they no longer existed. 

Thanks Kate.  Let's look at this problem now.

I assume that you did the upgrade that was offered automatically and that you went through it without incident.

Now, what did you do to look on OpenOffice for the two novels?  Just that part.

Did you open up OpenOffice Writer?  or did you open up the OpenOffice "dashboard" that provides a panel with the different kinds of documents and some other icons?

(I assume you have not touched anything since and can do this again.)

I am going to give you a procedure for collecting some data now.  You can reply to this comment and fill in the information where it is asked for, below.

After that, there will be more questions.

UPGRADE PATH

 1. Was the upgrade to Windows 10 from Windows 7, 8, or 8.1?:


 2. Did you do a "clean-install" or use the automatically-offered upgrade procedure?


 3. In the original system, did you have a "classical" user account with a one-word User ID or did you have a "Microsoft" user account which has the form of an email address?


 4. After the Windows 10 upgrade, did you create a different account from the one in (3) as your main account?
Comment 6 Marcus 2015-08-21 19:17:04 UTC
*** Issue 126482 has been marked as a duplicate of this issue. ***
Comment 7 Kate Galante 2015-08-21 19:47:55 UTC
I reverted back to Windows 7, and all issues with Open Office, Word, and electrical input to my laptop resolved themselves. Windows 10 was causing all the problems.
Comment 8 orcmid 2015-08-21 20:03:00 UTC
(In reply to Kate Galante from comment #7)
> I reverted back to Windows 7, and all issues with Open Office, Word, and
> electrical input to my laptop resolved themselves. Windows 10 was causing
> all the problems.

Sorry about that.

There appears to be a workaround, but you can't try it without upgrading.

Do you know if your upgrade was to "Windows 10 Home" edition?  There may have been a requirement in your Account settings to re-authenticate your account.  Until that is done, much is kept read-only.  This is apparently a security precaution.

Apparently the re-authentication notification is easy to miss or ignore, if that was the source of your difficulty.
Comment 9 orcmid 2015-08-21 23:40:31 UTC
For those who come here about files suddenly becoming read-only (not locked against writing, that is a different problem),

** NOTE ** This is not necessarily the only way that a Windows 10 Upgrade may interfere with use of OpenOffice (and other applications).

There are two prospective remedies when documents suddenly become read-only after upgrade to Windows 10.  These cases have nothing to do with OpenOffice directly, but appear to be side-effects of the update in the case of Windows 10 Home.  We want you to be a successful user and are interested in providing the resolution for those who notice this problem in conjunction with their use of Apache OpenOffice.

TRY THIS FIRST

This is the simplest case.

 1. In Windows 10, go into "Settings"
    a. At the end of the desktop task bar, next to the Window icon, enter "Settings" into the search entry field.  (If you do not have a search entry field in the task bar, click the round icon next to the Window icon, then use the field at the bottom of the pane that pops open.)
    b. The top search result should be "Settings" with a gear icon.
    c. Click Enter
 2. In the Settings Window, click Accounts.
 3. Under your account or anywhere else, see if it says your account needs to be authenticated.  If so, click on the option to do that now and follow the instructions.
 4. See if your previously-writable files are now writable.
 5. If that doesn't work, Restart your system, and see if that makes the difference.

Please report if that succeeds or fails by replying to this comment.
Comment 10 Keith N. McKenna 2018-08-27 19:51:44 UTC
No responses since 2015. Closing as obsolete