Issue 126467 - ods format does not retain content
Summary: ods format does not retain content
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: 4.2.0-dev
Hardware: All All
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2015-08-15 12:07 UTC by Jon C.
Modified: 2015-09-22 16:05 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

attachment (7.41 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-08-15 12:07 UTC, Jon C.
no flags Details
Attached-file-edited (15.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-09-22 15:47 UTC, Oz Wasserman
no flags Details
example-file-from-version- (14.29 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-09-22 16:05 UTC, Oz Wasserman
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Jon C. 2015-08-15 12:07:01 UTC
Created attachment 84880 [details]

I saved a file in .ods format, however, the contents are not saved.
Comment 1 Oz Wasserman 2015-09-22 15:47:10 UTC
Created attachment 84927 [details]
Comment 2 Oz Wasserman 2015-09-22 16:05:04 UTC
Created attachment 84928 [details]

Tried to replicate the bug by several methods(I used calc with LibreOffice version

-Tried to create a file in calc, write numbers to the spreadsheet in different locations(some within the first lines and some further out in the spreadsheet) and save it as .ods format. wrote and retrieved the information well for me when tried to open the file again(I've also attached this spreadsheet to this message)
-Tried to write numbers on various locations to the same attached file you supplied, and save it. retrieving the correct data worked well for me(you can see the attached document in the comment above

can you provide more specifications in order to try and solve this problem?
Some good information will be:
-The version of OpenOffice you have used when this problem happened
-The operating system this problem happened on
-The content you had in your spreadsheet(numbers,characters, special characters, different languages). 
-The function you have used for saving(either the save button from the menu or a shortcut like CTRL+S)
-Any other specifications that you think might be relevant

This information will be beneficial to try and trace the problem down and potentially fix your issue

Thank you