Issue 126573 - Update English dictionary to version 2015.10.01
Summary: Update English dictionary to version 2015.10.01
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 4.1.2-dev
Hardware: All All
: P3 Blocker (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-07 00:50 UTC by Andrea Pescetti
Modified: 2015-10-18 00:59 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
Latest Confirmation in: ---
Developer Difficulty: ---
pescetti: 4.1.2_release_blocker+


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andrea Pescetti 2015-10-07 00:50:29 UTC
Version 2015.10.01 of the English dictionary is available. Update source code to use it. See http://extensions.openoffice.org/en/node/17102/

This is one of the "routine" low-risk fixes included in the dev list discussion and considered to be Release Blockers.
Comment 1 Andrea Pescetti 2015-10-07 22:43:09 UTC
Done on trunk with revision 1707412 and on AOO410 for OpenOffice 4.1.2 with revision 1707413.
Comment 2 Pedro 2015-10-14 13:03:37 UTC
Not updated in 4.1.2 RC2 r1707648 so the problem is not fixed yet.
The 
(I do not have permission to change Status)
Comment 3 Andrea Pescetti 2015-10-17 15:51:43 UTC
Pedro: I see it correctly updated in the Italian version.

So, I'm reopening according to your report but I believe this is fixed.

I assume you downloaded the "pt" version. As you can see in line 40 here: https://svn.apache.org/viewvc/openoffice/branches/AOO410/main/extensions.lst?view=markup
the English dictionary in only bundled with three version: the Italian, German and (obviously) the English version.

So any English dictionaries you had installed would simply be preserved like any other custom extension.

A way to quickly check this is to open the program/bootstraprc (probably bootstrap.ini on Windows?) file and change the "UserInstallation" parameter. This will give you a clean installation, with a separate user profile, and you will be able to check what is installed exactly, since other extensions you have installed will not be considered that way.
Comment 4 Pedro 2015-10-18 00:58:34 UTC
(In reply to Andrea Pescetti from comment #3)
> I assume you downloaded the "pt" version. As you can see in line 40 here:
> https://svn.apache.org/viewvc/openoffice/branches/AOO410/main/extensions.
> lst?view=markup
> the English dictionary in only bundled with three version: the Italian,
> German and (obviously) the English version.
> 
> So any English dictionaries you had installed would simply be preserved like
> any other custom extension.

You are correct. I installed the Portuguese (pt) version. The reason I expected to see the latest English dictionary present was because I also installed the en_US Language Pack.

I forgot that Bug #124473 (derived from Bug #124423) hasn't been fixed...

In my mind installing a Language _Pack_ means installing the UI translation, the associated Help files and templates and obviously the language tools (spelling, grammar, etc)

(and yes, the English dictionary had been separately installed at some point)

The 4.1.2 RC2 en_US installer does contain the latest English dictionary, so I'm setting it back to Resolved Fixed