Issue 126589 - Animation exported as GIF is saved as static image.
Summary: Animation exported as GIF is saved as static image.
Status: CLOSED DUPLICATE of issue 117750
Alias: None
Product: Impress
Classification: Application
Component: save-export (show other issues)
Version: 4.1.1
Hardware: All All
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-14 17:21 UTC by David McCracken
Modified: 2015-10-14 18:37 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description David McCracken 2015-10-14 17:21:23 UTC
When an animated image is exported from Impress as GIF, the file is a static image of one of the constituent images. This bug seems to have been previously reported but it has either been reintroduced or the status of those reports is erroneous. 

Issue ID 81610 "Exported animated gif doesn't animate" status VERIFIED FIXED in 2011 but this is exactly the problem in 2015. 

Issue ID 108076 "export animated gif only exports first frame with no animation" status CLOSED IRREPRODUCIBLE in 2010 would seem to be entirely wrong status but the confusion may be related to version control. I have tested an old StarOffice 7 from 2004, which functions very much like the latest version of OpenOffice in how it creates and exports animated images. It does not have the problem. It correctly exports an animated GIF. The problem certainly seems to have been introduced after 2004, perhaps in 2010 as a circumstantial bug, which may not have always manifested. The 2012 "fix" may have been a complementary error, which made the problem go away but didn't really fix it.
Comment 1 Regina Henschel 2015-10-14 18:37:18 UTC
The export dialog was improved to make it possible to set the size of the exported picture. With that the feature of animation got lost for export, because there exists no code to change the size of an animated gif. That is described in bug 81610.

For this missing feature the followup bug 117750 was written. It has not a hiegh priority because an export as animated gif is still possible via context menu and the picture is stored as animated gif in the file.

So your observation is correct, but the problem is already covered by bug 117750.

*** This issue has been marked as a duplicate of issue 117750 ***