Issue 126621 - Extremely slow performance
Summary: Extremely slow performance
Status: CLOSED DUPLICATE of issue 67412
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: 4.1.1
Hardware: PC Windows 7
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-31 17:31 UTC by Michael
Modified: 2017-05-20 09:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Slow calc use case (125.37 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-11-02 12:12 UTC, Michael
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Michael 2015-10-31 17:31:16 UTC
First, I'm not sure that "UI" component is necessarily the right place to go fixing the issue. I am experiencing extremely slow performance with 5000+ rows. Some blogs I have read puts the number of rows threshold at somewhere around ~2000, but I haven't independently confirmed this. Symptoms include delayed and missed keystroke response, which results in an extremely sluggish UI/UX. I cannot post the file itself for repro since it contains sensitive information, however I can tell you we're not talking about anything massively complex. There aren't even any charts. Just some rows, columns, and formatting going on. There's one lookup that is repeated in each group of rows, but that's about it. Nothing earth shattering by any means.
Comment 1 oooforum (fr) 2015-11-02 08:36:11 UTC
Your bug report is being closed as NOT_AN_ISSUE due to a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of AOO that you have confirmed the bug to be present

b) Provide a step-by-step procedure to reproduce (the simpler will be the better)

c) Provide any test case(s) which will help us confirm the problem (like a sample document)

d) Provide screenshots of the problem if you think it might help


Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue.
Comment 2 Michael 2015-11-02 10:32:14 UTC
Please confirm, there have been at least half a dozen similar reports, as well as numerous blogs. Are you saying this has been fixed in 4.1.2? Thank you.
Comment 3 Michael 2015-11-02 12:12:55 UTC
Created attachment 85094 [details]
Slow calc use case

May also add some dates, email addresses, phone numbers (and formatting), and so on.
Comment 4 Michael 2015-11-02 12:13:17 UTC
See attached. It's the closest thing I could come up with to the actual slow use case.
Comment 5 oooforum (fr) 2015-11-02 13:17:29 UTC
Already reported

*** This issue has been marked as a duplicate of issue 67412 ***
Comment 6 Michael 2015-11-02 13:33:15 UTC
Again, fixed in 4.1.2? Because I haven't noticed much of a change in 4.1.1.
Comment 7 orcmid 2015-11-02 17:48:53 UTC
(In reply to Michael from comment #6)
> Again, fixed in 4.1.2? Because I haven't noticed much of a change in 4.1.1.

Michael, thank you for the test file.  AOO 4.1.2 is a maintenance release and there is no remedy to this performance problem there.  4.1.1 and 4.1.2 behavior are indistinguishable, taking about 20 seconds of blank document window after the green Loading and Adapt Row Height status bars end.

This appears to be some characteristic of the OpenOffice code that has been there for some time.  Distributions of other projects based on code from OpenOffice.org behave similarly.  

(I do note that Excel 2016 opens this file near-instantly on my high-performance desktop.  Out of curiosity, I save that document to a new .ods file.  That was about half the size but it opened just as slowly, maybe more slowly, in OpenOffice.)

The suspicion at issue 67412 is that "Adapt Row Height" is the culprit.  The tests and work-arounds seem to have inconsistent results about that, though.
Comment 8 orcmid 2015-11-02 18:05:46 UTC
(In reply to orcmid from comment #7)
> (In reply to Michael from comment #6)
> > Again, fixed in 4.1.2? Because I haven't noticed much of a change in 4.1.1.
> 
> Michael, thank you for the test file.  AOO 4.1.2 is a maintenance release
> and there is no remedy to this performance problem there.  4.1.1 and 4.1.2
> behavior are indistinguishable, taking about 20 seconds of blank document
> window after the green Loading and Adapt Row Height status bars end.

For calibration, the 20 seconds of blank document display Windows 10 Pro x64 on a Dell XPS 8500 with 32GB RAM and Intel i7-3770 processor.  That time was around 30 seconds with a 2009-model Dell Inspiron 1545 (15R) laptop.