Issue 126622 - Base 4.1.2 does not open Tables and Queries in Mac OSX
Summary: Base 4.1.2 does not open Tables and Queries in Mac OSX
Status: CLOSED FIXED_WITHOUT_CODE
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: 4.1.2
Hardware: Mac Mac OS X, all
: P1 (highest) Critical with 15 votes (vote)
Target Milestone: 4.1.3
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: regression
: 126624 126642 126744 (view as issue list)
Depends on:
Blocks:
 
Reported: 2015-11-01 08:13 UTC by charlie.it
Modified: 2017-11-24 20:16 UTC (History)
19 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
pats: 4.1.3_release_blocker-
marcus: 4.1.4_release_blocker-


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description charlie.it 2015-11-01 08:13:04 UTC
Base v. 4.1.2  on Mac OSX 10.7.5 and Mac OSX 10.11.1

tables:
- Create Table in Design View: not working
- Wizard: runs but the final window does not close (End key disabled), closes with button (X)
- The newly created table and the existing ones do not open (double-click or right-click> open). They do not even open in edit mode.

queries:
- Create Query in Design View: Users can not add tables
- Wizard: runs but the final window does not close (End key disabled), closes with button (X)
- The query you just created and the existing ones do not open (double-click or right-click> open). They do not even open in edit mode.
forms
- Seem to run on both tables query

closing Open Office:
- If you create a new table or new query (with the wizard) OO does not close, a forced exit from o.s. OSX is required.
Comment 1 Andreas Säger 2015-11-01 08:30:05 UTC
Confirmed by another Mac user Larry I. Gusaas on the user forum: https://forum.openoffice.org/en/forum/viewtopic.php?f=13&t=80059
Comment 2 Larry Gusaas 2015-11-01 09:14:29 UTC
(In reply to Andreas Säger from comment #1)
> Confirmed by another Mac user Larry I. Gusaas on the user forum:
> https://forum.openoffice.org/en/forum/viewtopic.php?f=13&t=80059

You are quicker than me. 
Comment 3 Keith N. McKenna 2015-11-01 13:52:47 UTC
Confirmed via comment 2
Comment 4 tintin60 2015-11-01 22:53:40 UTC
Hi, 

I see this issue lately.

Il already wrote the issue 126623

SLTS
Comment 5 John 2015-11-02 20:51:35 UTC
I'm having same issue & hope a resolution is coming
Comment 6 Marcus 2015-11-02 23:30:57 UTC
*** Issue 126624 has been marked as a duplicate of this issue. ***
Comment 7 Kay 2015-11-11 23:34:27 UTC
*** Issue 126642 has been marked as a duplicate of this issue. ***
Comment 8 Mark Wallace 2015-11-19 06:09:44 UTC
Confirmed on 10.11.1 with Java 8 Update 66.
Comment 9 Marcus 2015-12-19 23:34:05 UTC
*** Issue 126744 has been marked as a duplicate of this issue. ***
Comment 10 Joseph 2015-12-31 02:53:34 UTC
I have the exact issue. 

Able to create a table, but cannot edit, open, change, or do anything with it whatsoever. 

I have to force quit the application and sometimes even that does not work... I have to shut down the computer using the power button!

Using the latest version of OpenOffice, which is Version 4.1.2, and using Mac OS X, El Capitan version 10.11.2
Comment 11 deadline13 2016-04-06 04:41:11 UTC
Has this been solved? I am encountering the same issues
Comment 12 orcmid 2016-04-06 16:34:19 UTC
(In reply to deadline13 from comment #11)
> Has this been solved? I am encountering the same issues

This may be related to some difficulties finding the Java JRE on recent OSX.  My recollection is that the problem has been isolated.  I don't know where the fix is described and whether there is a workaround until the next release of Apache OpenOffice.  If we find that, we can link it to this issue.
Comment 13 Andreas Säger 2016-04-06 22:22:12 UTC
(In reply to orcmid from comment #12)
> (In reply to deadline13 from comment #11)
> > Has this been solved? I am encountering the same issues
> 
> This may be related to some difficulties finding the Java JRE on recent OSX.
> My recollection is that the problem has been isolated.  I don't know where
> the fix is described and whether there is a workaround until the next
> release of Apache OpenOffice.  If we find that, we can link it to this issue.

It affects all databases on Mac OS including dBase, spreadsheets and text. The whole Base component does not work since 4.1.2
Comment 14 Keith N. McKenna 2016-08-21 17:57:44 UTC
(In reply to Andreas Säger from comment #13)
> (In reply to orcmid from comment #12)
> > (In reply to deadline13 from comment #11)
> > > Has this been solved? I am encountering the same issues
> > 
> > This may be related to some difficulties finding the Java JRE on recent OSX.
> > My recollection is that the problem has been isolated.  I don't know where
> > the fix is described and whether there is a workaround until the next
> > release of Apache OpenOffice.  If we find that, we can link it to this issue.
> 
> It affects all databases on Mac OS including dBase, spreadsheets and text.
> The whole Base component does not work since 4.1.2

There is information in the 4.1.2 Release Notes in the Know Issues Section at the following link: https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+4.1.2+Release+Notes#AOO4.1.2ReleaseNotes-KnownIssues in the second bullet. Does this workaround allow Base to work?
Comment 15 Andreas Säger 2016-08-21 20:10:30 UTC
(In reply to Keith N. McKenna from comment #14)
> (In reply to Andreas Säger from comment #13)
> > (In reply to orcmid from comment #12)
> > It affects all databases on Mac OS including dBase, spreadsheets and text.
> > The whole Base component does not work since 4.1.2
> 
> There is information in the 4.1.2 Release Notes in the Know Issues Section
> at the following link:
> https://cwiki.apache.org/confluence/display/OOOUSERS/AOO+4.1.
> 2+Release+Notes#AOO4.1.2ReleaseNotes-KnownIssues in the second bullet. Does
> this workaround allow Base to work?

No. I can use Base withtout any Java being installed. I can use all kinds of non-Java databases, build forms, queries and spreadsheet reports, write Macros in Python and Basic and I can compose serial letters that do not depend on any bean of Java.
All this seems to be impossible on the Mac platform.
Comment 16 Ariel Constenla-Haile 2016-09-10 19:18:16 UTC
Can you please test with the DMG on http://home.apache.org/~arielch/mac/ ?
Comment 17 Larry Gusaas 2016-09-10 19:46:46 UTC
(In reply to Ariel Constenla-Haile from comment #16)
> Can you please test with the DMG on http://home.apache.org/~arielch/mac/ ?

Base worked for me. I only have one database. All functions worked. Was able to create a new database.
Comment 18 charlie.it 2016-09-11 07:03:00 UTC
(In reply to Ariel Constenla-Haile from comment #16)
> Can you please test with the DMG on http://home.apache.org/~arielch/mac/ ?

It works for me with new database, with existing database and connected to spresdsheet.
Comment 19 Andrea Pescetti 2016-09-11 20:53:42 UTC
This is the only known regression in 4.1.2. Even tough I see no patches attached, it's increasingly clear that Ariel's test build fixes the issue for the users who reported it. This deserves to be considered for 4.1.3 - even though more details about Ariel's fix would be needed.
Comment 20 jlbrown 2016-09-13 06:46:15 UTC
Ariel's version works for me too. I can now see tables and queries on macOS 10.12 Sierra.

Unfortunately my queries don't return any data.
Comment 21 charlie.it 2016-09-13 06:53:39 UTC
(In reply to jlbrown from comment #20)

> Unfortunately my queries don't return any data.

This issue doesn't seem a OO version problem.
Comment 22 Jim Jagielski 2016-09-15 14:23:25 UTC
I can't recreate on 4.1.3-dev/HEAD
Comment 23 jlbrown 2016-09-19 00:55:13 UTC
(In reply to charlie.it from comment #21)
> (In reply to jlbrown from comment #20)
> 
> > Unfortunately my queries don't return any data.
> 
> This issue doesn't seem a OO version problem.

My issue is actually with Calc, not Base - sorry.

OpenOffice and LibreOffice return no data in the top right box of the window (to the right of the Explorer). Queries never show data. But it does with NeoOffice. Unfortunately NeoOffice has memory leak with running the query, causing the app to crash.
Comment 24 charlie.it 2016-09-19 07:51:10 UTC
(In reply to jlbrown from comment #23)
> (In reply to charlie.it from comment #21)
> > (In reply to jlbrown from comment #20)
> > 
> > > Unfortunately my queries don't return any data.
> > 
> > This issue doesn't seem a OO version problem.
> 
> My issue is actually with Calc, not Base - sorry.
> 
> OpenOffice and LibreOffice return no data in the top right box of the window
> (to the right of the Explorer). Queries never show data. But it does with
> NeoOffice. Unfortunately NeoOffice has memory leak with running the query,
> causing the app to crash.

This Issue 126622 concerns Base in MAC OSX. Open a new thread for Calc.
Comment 25 Larry Gusaas 2016-10-05 09:37:09 UTC
Base works in 4.1.3-rc1.
Comment 26 Andrea Pescetti 2016-10-06 06:26:29 UTC
Repeating from the mailing list discussion: more feedback is needed for confirmation that this is fixed in 4.1.3-RC1. Builds to be tested are at https://dist.apache.org/repos/dist/dev/openoffice/4.1.3-rc1/
e.g., https://dist.apache.org/repos/dist/dev/openoffice/4.1.3-rc1/binaries/en-US/Apache_OpenOffice_4.1.3_MacOS_x86-64_install_en-US.dmg
Comment 27 tintin60 2016-10-06 08:19:03 UTC
Hi,

I'm at the origin of the issue 126623 (https://bz.apache.org/ooo/show_bug.cgi?id=126623)

I just tested AOO 4.1.3 as suggested and I confirm no more problem with Data Bases tables. It works.
Comment 28 Ariel Constenla-Haile 2016-10-06 11:43:42 UTC
This and bug 126623 are indeed fixed on AOO413 by building on OS X Mountain Lion, the issue might have been introduced because the developer building the macOS release updated his/her system and 4.1.2 was thus built with a different clang version than 4.1.1.

Building 4.1.3 on Mac OS X El Capitan with Xcode 7 will produce a binary release where this issue can be reproduced; if you recompile main/framework/source/loadenv/loadenv.cxx without optimization (-O0, the build environments builds with -O2), the application no longer hangs in the cases described in this bug and issue 126623.

Building 4.1.3 on macOS Sierra with Xcode 8 produces a binary release where this is no longer reproducible.

I will just resolve this as fixed, as it is indeed fixed; later on, it can be reopened if needed.
Comment 29 charlie.it 2016-10-06 12:57:23 UTC
(In reply to Andrea Pescetti from comment #26)
> Repeating from the mailing list discussion: more feedback is needed for
> confirmation that this is fixed in 4.1.3-RC1. Builds to be tested are at
> https://dist.apache.org/repos/dist/dev/openoffice/4.1.3-rc1/
> e.g.,
> https://dist.apache.org/repos/dist/dev/openoffice/4.1.3-rc1/binaries/en-US/
> Apache_OpenOffice_4.1.3_MacOS_x86-64_install_en-US.dmg

Confirm: Base in AOO 4.1.3-RC1 works in Mac OSX 10.7.5
Comment 30 Peter 2016-10-08 15:34:49 UTC
I have tested this Error in Version 4.1.3-rc1 on Macbook Air 2009 Edition with OSX El Capitan and can not confirm this Bug! :-)
Comment 31 Don Lewis 2017-11-24 20:16:05 UTC
I can confirm this bug on FreeBSD 10.3 amd64, which is built with clang 3.4.1.  It does not occur on FreeBSD 11.0, which uses clang 3.8.0.  It also does not occur FreeBSD i386.