Issue 126623 - Application hangs during mailing procedure
Summary: Application hangs during mailing procedure
Status: CLOSED FIXED_WITHOUT_CODE
Alias: None
Product: Writer
Classification: Application
Component: printing (show other issues)
Version: 4.1.2
Hardware: Mac OS X 10.11
: P5 (lowest) Normal with 2 votes (vote)
Target Milestone: 4.1.3
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 126676 126715 (view as issue list)
Depends on:
Blocks:
 
Reported: 2015-11-01 22:38 UTC by tintin60
Modified: 2017-05-20 10:11 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description tintin60 2015-11-01 22:38:48 UTC
Hi 

Using successfully this procedure on AOO 4.1.1 / MacOS 10.11.1 :
1- Opening and saving a letter template ;
2- File > Print > Print a form ;
3- Windows "Mailing" comes ;
4- Selecting recipients (marked records + Printer) > OK ;
5- Windows "Print" comes ;
6- Print.

After AOO 4.1.2 install (profile purging) : crash at step 3.
- Windows "Mailing" doesn't appear.
- Pushing F4 to call Data Base > Zone comes but is empty.
- Pushing again F4 > multicolored wheel > Force out.
OR
- File > Close > multicolored wheel > Force out.

No recovery.


Could your check ?

Thanks
Comment 1 tintin60 2015-11-01 22:41:09 UTC
Test realised with old and new database.
Comment 2 Andrea Pescetti 2015-11-06 20:52:52 UTC
At the moment, focus is on https://bz.apache.org/ooo/show_bug.cgi?id=126622 ; this issue might or might not be related to it, but investigation for the moment will happen on the other issue; it is possible that the two share a root cause.
Comment 3 Larry Gusaas 2015-11-09 03:17:45 UTC
(In reply to Andrea Pescetti from comment #2)
> At the moment, focus is on https://bz.apache.org/ooo/show_bug.cgi?id=126622
> ; this issue might or might not be related to it, but investigation for the
> moment will happen on the other issue; it is possible that the two share a
> root cause.
It seems to be related. See discussion and testing reported on the forum:
https://forum.openoffice.org/en/forum/viewtopic.php?f=13&t=80059
Comment 4 oooforum (fr) 2015-11-23 10:04:16 UTC
*** Issue 126676 has been marked as a duplicate of this issue. ***
Comment 5 oooforum (fr) 2015-12-02 10:45:25 UTC
*** Issue 126715 has been marked as a duplicate of this issue. ***
Comment 6 Richard 2015-12-03 13:26:45 UTC
Restoring to OpenOffice version 4.1.1 makes the problem go away.
Comment 7 Andrew Fraser 2015-12-03 20:33:28 UTC
Restoring to 4.1.1 does not make the problem with 4.2 go away.
Comment 8 tintin60 2016-01-11 09:33:52 UTC
Hi,

What's new ?

This issue is still unconfirmed ?
Comment 9 Chris Withers 2016-01-17 22:24:37 UTC
Subject line says 10.11, but this appears to be tagged with 10.10.
Please can someone edit the issue metadata to correct?
Comment 10 orcmid 2016-01-17 23:06:59 UTC
[Changed OS X version in Issue metadata]
Comment 11 Sparsh 2016-10-01 03:20:49 UTC
I have also had this problem. 
The steps I took to archive this was 

1st Opening and saving a letter template 
2nd File > Print > Print a form
3rd Windows "Mailing" comes 

Then I have a problem and need to Force close/out 

Restoring to OpenOffice version 4.1.1 makes the problem go away.
Comment 12 Ariel Constenla-Haile 2016-10-01 05:20:28 UTC
(In reply to Sparsh from comment #11)
> I have also had this problem. 
> The steps I took to archive this was 
> 
> 1st Opening and saving a letter template 
> 2nd File > Print > Print a form
> 3rd Windows "Mailing" comes 
> 
> Then I have a problem and need to Force close/out 
> 
> Restoring to OpenOffice version 4.1.1 makes the problem go away.

Can you try with the 4.1.3 version that is going to be the release candidate?
https://dist.apache.org/repos/dist/dev/openoffice/4.1.3/binaries/
Comment 13 Ariel Constenla-Haile 2016-10-01 05:33:42 UTC
Changing the subject.
There is no crash, it is a "hang", a dead lock, seen in other scenarios, like 126622
Comment 14 tintin60 2016-10-06 08:30:41 UTC
HI,

Just tried AOO 4.1.3. NO more problem. It works
Comment 15 Marcus 2016-10-06 11:39:13 UTC
@tintin60:
Thanks a lot for testing. As I don't know so far what the fix is I'll set the status to "Resolved - Without code".
Comment 16 tintin60 2016-10-06 11:49:12 UTC
Hi,

I H
Comment 17 tintin60 2016-10-06 11:50:13 UTC
Hi, 

I have to add The test was performed with 10.12.0 Sierra