Issue 126634 - program will not quit
Summary: program will not quit
Status: UNCONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.1.2
Hardware: Mac OS X 10.11
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-07 18:51 UTC by Duane Small
Modified: 2015-11-09 20:47 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Duane Small 2015-11-07 18:51:21 UTC
The Macintosh version, if opened directly from the application (not by opening a document), does not respond to the Quit menu item (menu bar, keyboard equivalent, or menu associated with the OO icon in the dock).  Quit will cause open document windows to close, but leaves the initial window (with icons for Text Document, Spreadsheet, etc.) open.  It is necessary to force-quit the application.  I'm experience this running on Mac OS X 10.11.1.
Comment 1 Marcus 2015-11-07 19:07:48 UTC
I've added a new "Mac OSX 10.11" value to the OS field.
Comment 2 oooforum (fr) 2015-11-09 09:45:31 UTC
Is it an upgrade from a previous build or a fresh install from scratch?
Comment 3 Duane Small 2015-11-09 14:38:29 UTC
I recently upgraded the OS from 10.10.x, upgrading in place, not a fresh install.  I subsequently installed OO 4.1.2 as a replacement for 4.3.1.
Comment 4 oooforum (fr) 2015-11-09 16:45:24 UTC
(In reply to Duane Small from comment #3)
> I recently upgraded the OS from 10.10.x, upgrading in place, not a fresh
> install.  I subsequently installed OO 4.1.2 as a replacement for 4.3.1.
4.3.1 is not a AOO version.
Did you mean that you had install LibO 4.3.1 previously.
Comment 5 Duane Small 2015-11-09 16:50:41 UTC
Sorry, I meant I replaced OO 4.1.1.
Comment 6 oooforum (fr) 2015-11-09 17:13:35 UTC
I don't know how you had upgraded AOO.
First, reinit your profile. Details about it are given in:
https://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=12426

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 7 Duane Small 2015-11-09 19:11:52 UTC
Resetting the profile made no difference.  However, I had to reinstall OO 4.1.2 (I had reverted to the old version because the new version of Base is unusable for unrelated bugs), and now I can consistently replicate this problem only in one situation:  when I open an existing database.  I can now quit immediately after opening the program.  When I create or open a document other than a database, the initial screen disappears, and I can quit normally.  When I open an existing database using the Open icon on the initial screen, or using the menu bar, the same is true.  However, if I open an existing database using the Database icon on the initial screen and filling in the subsequent dialog, the initial screen remains visible behind the database window.  It cannot be be closed and the program will not quit.

As for how I installed the new version, I dragged it from the .dmg file to the Applications folder.  The first time I replaced the older version.  This time, knowing I'd want to revert, I left the old version in place and let the new version be called Open Office 2.
Comment 8 mroe 2015-11-09 19:36:31 UTC
Please have a look which Java version is used.

If you connect to an external database please check the driver installation.
Comment 9 Duane Small 2015-11-09 20:47:43 UTC
Java version selected is 1.8.0_65.  I"m not sure if that's what's used.  The previous version of OO showed the same Java version selection, but wouldn't run until I installed Apple's legacy Java 6.  Neither version of OO shows version 6 of Java as being installed.

Driver installation checks out okay (I'm using the mysql java db connector, v 5.1.19), and I can access the external database.  I get the failure-to-quit problem whether I access an external database or a local one created by OO.