Issue 126659 - Extension update is suggesting the installed version
Summary: Extension update is suggesting the installed version
Status: RESOLVED FIXED_WITHOUT_CODE
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.1.2
Hardware: All All
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-15 18:11 UTC by Pedro
Modified: 2020-08-27 11:08 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screenshot of extn mgr with pop-up "You are about to install... That version is already installed." (121.78 KB, image/jpeg)
2016-09-19 04:28 UTC, Mark Mandel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Pedro 2015-11-15 18:11:19 UTC
Automatic update check is reporting that version 15.10.3.1 of extension "European Portuguese Dictionary (PRE AO90)"

http://extensions.openoffice.org/node/17990/update

is available but that is the version that is already installed
Comment 1 Mark Mandel 2016-09-19 04:28:32 UTC
Created attachment 85678 [details]
Screenshot of extn mgr with pop-up "You are about to install... That version is already installed."

This has been happening to me with English ever since I installed Oo years ago on the MacBook Air I am still using (13-inch, Mid 2011; Mac OS X Lion 10.7.5 (11G63b)). I keep getting software update notices, opening them, and going to install an updated English spelling and hyphenation dictionary. If I'm not quick enough to notice the version number/date, I download, click install, and get this message:

You are about to install version ___ of the extension 'English spelling and hyphenation dictionaries and thesaurus'. 
That version is already installed.
...

This has gotten to be quite a PITA, since the interruption throws me off the track of what I'm trying to do — as if my AD(H)D weren't already bad enough. What's more, I'm beginning to brush off and ignore software update notices in general, which is a REALLY BAD IDEA.
Comment 2 Pedro 2019-12-06 17:03:26 UTC
Confirmed in Comment#1
It is impossible to know if it is still relevant since Update checking is broken
Comment 3 Matthias Seidel 2019-12-06 17:16:22 UTC
(In reply to Pedro from comment #2)
> Confirmed in Comment#1
> It is impossible to know if it is still relevant since Update checking is
> broken

You could still check it with 4.2.0.

BTW: Update check for AOO and extensions are two separate things.
Comment 4 Pedro 2019-12-06 22:16:47 UTC
(In reply to Matthias Seidel from comment #3)

> You could still check it with 4.2.0.

It is also broken (at least under Ubuntu 18.04)
 
> BTW: Update check for AOO and extensions are two separate things.

I do know that. But both are broken in 4.1.x
Comment 5 Matthias Seidel 2019-12-06 22:24:53 UTC
(In reply to Pedro from comment #4)
> (In reply to Matthias Seidel from comment #3)
> 
> > You could still check it with 4.2.0.
> 
> It is also broken (at least under Ubuntu 18.04)

That's an Ubuntu problem. Maybe you can open an issue for that.
It works at least on Xubuntu and of course on Windows.

>  
> > BTW: Update check for AOO and extensions are two separate things.
> 
> I do know that. But both are broken in 4.1.x

For different reasons...
Comment 6 Pedro 2020-08-27 11:08:05 UTC
Verified fixed in version 4.1.8