Issue 126680 - Unable to save a document in ODS
Summary: Unable to save a document in ODS
Status: CONFIRMED
Alias: None
Product: Calc
Classification: Application
Component: save-export (show other issues)
Version: 4.1.2
Hardware: PC Windows 7
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needhelp
Depends on:
Blocks:
 
Reported: 2015-11-23 12:46 UTC by Andrey Repin
Modified: 2018-05-12 22:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.5
Developer Difficulty: ---


Attachments
An example document. (26.11 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-11-23 12:46 UTC, Andrey Repin
no flags Details
Resulting document after a save as from original example.ods (25.28 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-11-23 18:40 UTC, Keith N. McKenna
no flags Details
Safe mode… (273.11 KB, video/webm)
2015-11-24 15:59 UTC, Andrey Repin
no flags Details
Another workaround. (23.91 KB, image/png)
2018-05-12 15:16 UTC, Andrey Repin
no flags Details
Mac version info (46.16 KB, image/png)
2018-05-12 20:44 UTC, Andrey Repin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Andrey Repin 2015-11-23 12:46:20 UTC
Created attachment 85147 [details]
An example document.

I've had this issue on multiple occasions, and this is what really stops me from using OpenOffice or recommending it to other people.
When you are working with Calc, after reaching a certain point in document's life, Calc will refuse to save the document in native format for no apparent reason.

Please see the example document attached. Reproduction steps are quite simple.
Open the document, and try to "Save As..." it.
The error pops up claiming that it is iimpossible to save the document, even though the document has been saved by the same application a few hours ago.
Comment 1 Regina Henschel 2015-11-23 13:37:23 UTC
I cannot reproduce the problem. I open the attached document and save it using "save as" without any problem. I have tried it with Windows' file dialog and with AOOs file dialog.

I use AOO412m3(Build:9782)  -  Rev. 1709696
2015-10-21 09:53:29 (Mi, 21 Okt 2015)
on Windows 7.

Are your sure the destination is writeable? Do you use a local destination?
Comment 2 Keith N. McKenna 2015-11-23 14:20:19 UTC
Like Regina I cannot confirm this. I can open and "save as" with no problem. Tested with both Windows native file dialogue and the OpenOffice file dialogue.

System Configuration:
Processor: Intel Core i5 CPU M560 @2.67GHz
Installed Memory: 2.00 GB (1.6 usable)
Operating System: Windows 7 Home Premium 64 bit

Apache Open Office:
AOO412m3(Build:9782)  -  Rev. 1709696
2015-10-21 09:53:29 (Mi, 21 Okt 2015)
Language: en_US
Additional Language Packs: None
Comment 3 Andrey Repin 2015-11-23 17:57:06 UTC
Yes, the destination is local (Documents dir in a local profile), and yes the destination is writable.
Like I said, the same program was used to save the same file just a few hours ago. I didn't even restart the system after that save.
But now every attempt at saving the file resulted in a message (approx.):

-- OpenOffice 4.1.2 --
Error while saving document example:
Write error.
Unable to write file.
[Ok]

I've tried to save it right now on a five different systems with the same AOO version (4.1.2/ru) - same effect.
Though antivirus may be affecting, but disabling it did nothing to the effect.

If you think it may be an environmental issue, I'd like to hear your suggestions as to how to trace it down to the root.

(BTW, what's wrong with standard Win32 MessageBox that OpenOffice does not use it for notifications? I had to retype the error message by hands instead of just Ctrl+C/Ctrl+V it... WTF?)
Comment 4 Andrey Repin 2015-11-23 18:11:02 UTC
Speaking of saves. May be one of you could re-save the document and attach the resulting one for investigation?
Comment 5 Keith N. McKenna 2015-11-23 18:40:04 UTC
Created attachment 85150 [details]
Resulting document after a save as from original example.ods

Attached is the resulting document from my doing a "save as" with our original example.ods
Comment 6 Andrey Repin 2015-11-24 00:20:26 UTC
Great. Same problem. Unable to save.
I'll take a closer look at the structure of the two files tomorrow. No idea what I'm looking for, but we'll see.

I'm still interested in the ideas on how to track the problem.
Comment 7 oooforum (fr) 2015-11-24 08:43:02 UTC
Start Windows in Safe Mode and run OpenOffice when Windows is in that mode. 
Try to repeat your "save as" operation.
Comment 8 Andrey Repin 2015-11-24 15:59:37 UTC
Created attachment 85157 [details]
Safe mode…

Safe mode didn't quite work.
Comment 9 Andrey Repin 2015-12-04 13:13:40 UTC
If you have trouble reproducing it, the only way I could see this resolved is I'm uloading a complete VM installed with Office, ready to demonstrate the issue.
Comment 10 oooforum (fr) 2016-04-05 07:19:10 UTC
I see that you use a russian UI.
Could you try directly with an en_US version?
Comment 11 Andrey Repin 2016-04-25 00:48:54 UTC
I'll, of course, try it. I've been busy with work and I don't have any ready VM that I can fiddle with right now.

But…

If just changing localization would make a difference, my faith in AOO will drop a good few points down.
Comment 12 oooforum (fr) 2016-04-25 07:33:23 UTC
(In reply to Andrey Repin from comment #11)
> If just changing localization would make a difference, my faith in AOO will
> drop a good few points down.
No difference, but I don't speak russian.

Are you reset your AOO profile?
Comment 13 Andrey Repin 2016-04-25 12:45:25 UTC
In at least two cases it was freshly generated user profile for 4.1.2 version.
As I said, I'll try again with fresh English version, once this latest system stop wasting my time. (It installing updates for the last 20 gours already.)
Comment 14 Andrey Repin 2016-04-25 23:43:06 UTC
English (en-US) OO saves the document just fine.
Russian fails with "unable to save".

That's… http://kolobok.us/smiles/madhouse/dash2.gif

Do you want me to, perhaps, try En-US + Langpack?
Comment 15 Andrey Repin 2016-04-26 00:15:34 UTC
Tried that just out of desperation.
Same but save problem.
Install en-US - new user profile - open document - save - all fine.
Install langpack - new user profile - open document - save - "Impossible to save". (I think that would be more precise reverse translation of "Невозможно сохранить файл".)
Comment 16 Theodore Matula 2016-04-28 20:44:08 UTC
Maybe a problem unique to the Russian version?
Comment 17 Andrey Repin 2016-04-28 21:25:25 UTC
That's not the right question.
Right question would be "how localization could possible affect file saving?"…
Someone played with locale and forgot that not everyone using commas as thousand separators?
Comment 18 Andrey Repin 2016-04-28 21:44:21 UTC
If there's some steps I can perform to produce useful debugging output, I can do that. Just point the way.
Comment 19 oooforum (fr) 2016-11-24 14:25:35 UTC
4.1.3 is available.
Did you still have this issue with the last build?
Comment 20 Andrey Repin 2016-11-24 17:21:33 UTC
Yes. Same error, same reproduction steps.
Comment 21 Andrey Repin 2016-11-24 17:22:56 UTC
AOO413m1(Build:9783)  -  Rev. 1761381
2016-09-29 02:39:19
Comment 22 Andrey Repin 2018-02-12 22:11:41 UTC
AOO415m1(Build:9789)  -  Rev. 1817496
2017-12-11 17:25

Still same issue.
Comment 23 Andrey Repin 2018-05-11 23:19:08 UTC
Any movement on the bug? I just got bitten by it in an important work document.
Which I can not save in MS Excel format, because it uses column grouping incompatible with Excel.
Why should I lose several hours of hard work?
Comment 24 Keith N. McKenna 2018-05-12 00:56:50 UTC
Can someone using a Russian UI please try to confirm this so it can be advanced.

Andrey until we can get independent confirmation of this issue there is really little that can be done. I have set the needhelp tag and am asking that another person using a Russian UI try to confirm this.
Comment 25 oooforum (fr) 2018-05-12 08:54:48 UTC
Maybe (In reply to Keith N. McKenna from comment #24)
> Can someone using a Russian UI please try to confirm this so it can be
> advanced.
+1
We don't have mailing list in this language.
But OP could post directly to the russian forum:
http://forumooo.ru
Comment 26 Andrey Repin 2018-05-12 14:38:07 UTC
The tripping line it seems is an extensive use of autolfilters.
And a workaround is to set decimal separator to a period in regional settings. Then you can save the document. At least that worked for me this time.
Comment 27 Andrey Repin 2018-05-12 15:16:24 UTC
Created attachment 86422 [details]
Another workaround.

Reportedly, the bug is well-known in a russian community, and one possible workaround is to reset the file metadata.
Comment 28 Andrey Repin 2018-05-12 18:53:05 UTC
Another interesting sequence of events discovered with help of the community:
1. On a freshly booted system, open the example codument.
2. If you attempt to "Save as" it, it will fail, as described.
3. Close the document, leaving program window open.
4. Open it back and try to "Save as". Surprize! It saved without a hitch.

The investigation of the saved document shows that there's minor changes in meta.xml/settings.xml/styles.xml (changed times and application build numbers), but there's also changes in the actual "content.xml", even though we did not edit the file. These changes could be rather substantial (people reported wildly different results, with up to double the resulting file size, comparing to the original) and are hard to evaluate.
Comment 29 Andrey Repin 2018-05-12 20:44:05 UTC
Created attachment 86423 [details]
Mac version info

Reproduced on MacOS 10.11.6 / AOO 4.1.3 (Integrated russian langpack)
Comment 30 Keith N. McKenna 2018-05-12 22:35:49 UTC
Given all the evidence gathered by Andrey both on his own and on the Russian Forum I am going to set this as Confirmed. At this point it appears to be dependent on using a Russian UI either as direct download in Russian or with a Russian language pack.