Issue 126691 - Text is unreadable when font size is set too large.
Summary: Text is unreadable when font size is set too large.
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 4.1.1
Hardware: Mac OS X 10.11
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2015-11-25 01:49 UTC by Brett Porter
Modified: 2016-04-26 22:15 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Image of how the bug should look when replicated. (239.15 KB, image/png)
2015-11-25 01:49 UTC, Brett Porter
no flags Details
Times New Roman Text (229.65 KB, image/png)
2015-11-25 02:27 UTC, Brett Porter
no flags Details
Ariel Text: Font Style causing bug (217.98 KB, image/png)
2015-11-25 02:28 UTC, Brett Porter
no flags Details
attachment 4 (35.93 KB, image/png)
2016-03-01 22:44 UTC, harrisw2014
no flags Details
attachment 5 (31.87 KB, image/png)
2016-03-01 22:46 UTC, harrisw2014
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Brett Porter 2015-11-25 01:49:51 UTC
Created attachment 85161 [details]
Image of how the bug should look when replicated.

Environment: 
Mac OS X 10.11, 
Open Office 4.1.1, build: AOO411m6(Build:9775) - Rev. 1617669

Steps to reproduce bug
1: set font size to 999.9
2: type the character "a"
3: text will be cut off vertically

This needs to be tested further to find the largest font size a page will allow vertically. It already checks if the font size will fit horizontally.
Comment 1 Brett Porter 2015-11-25 02:27:00 UTC
Also changing font styles will cause the text to be cutoff as well.

Environment: 
Mac OS X 10.11, 
Open Office 4.1.1, build: AOO411m6(Build:9775) - Rev. 1617669

Test
1: set font size to 750
2: type the character "a"
3: set font style to times new roman
4: then set font style to ariel to see bug

There are two attachments with one showing the text in times new roman and one showing the text in ariel.
Comment 2 Brett Porter 2015-11-25 02:27:42 UTC
Created attachment 85162 [details]
Times New Roman Text
Comment 3 Brett Porter 2015-11-25 02:28:36 UTC
Created attachment 85163 [details]
Ariel Text: Font Style causing bug
Comment 4 Cem Kaner 2015-11-27 23:47:30 UTC
I don't think there is a bug here. A character that is 999 points tall is about 13.875 inches tall. Obviously, that won't fit on an 8.5 x 11" page, but it will fit on larger pages and OOO can work with larger pages. The program is giving you what you told it you wanted.
Comment 5 harrisw2014 2016-03-01 22:42:27 UTC
OS: Windows 10
Open Office 4.2.0, build:9800 - Rev. 1692551

I was able to reproduce this by doing the following steps:
1) Go To Format->Character
2) Type 999.9 into size
3) Type the letter "a"

By doing this I was able to observe a vertical cut off of the letter but as stated by Cem Kaner a 999 point character would be about 13.75" tall so I did the following step to test this font size on a custom sized piece of paper:

1) Go to Format->Page
2) Change height to 14.00"

After completing these steps, the letter "a" now fits on the page and is not cutoff in any way.  Note: that I reduced all margins in the document to 0."
Comment 6 harrisw2014 2016-03-01 22:44:22 UTC
Created attachment 85333 [details]
attachment 4 [details]

image of the letter "a" in 999.9 points and on standard 8.5" by 11" page
Comment 7 harrisw2014 2016-03-01 22:46:23 UTC
Created attachment 85335 [details]
attachment 5 [details]

image of the letter "a" in 999.9 points on a custom 8.5" by 14" page.  Notice the height marker on the left-hand side
Comment 8 harrisw2014 2016-03-02 02:59:11 UTC
(In reply to harrisw2014 from comment #5)
> OS: Windows 10
> Open Office 4.2.0, build:9800 - Rev. 1692551
> 
> I was able to reproduce this by doing the following steps:
> 1) Go To Format->Character
> 2) Type 999.9 into size
> 3) Type the letter "a"
> 
> By doing this I was able to observe a vertical cut off of the letter but as
> stated by Cem Kaner a 999 point character would be about 13.75" tall so I
> did the following step to test this font size on a custom sized piece of
> paper:
> 
> 1) Go to Format->Page
> 2) Change height to 14.00"
> 
> After completing these steps, the letter "a" now fits on the page and is not
> cutoff in any way.  Note: that I reduced all margins in the document to 0."

Before step 1 in creating the vertical, open a document, new or previously saved, and then continue on to replicate the behavior.
Comment 9 Nicola Owen 2016-04-10 16:46:48 UTC
I suggest rephrasing the summary of the bug to: the text is unreadable when the font-size is set to 999.9 on the default page size.

"Too big" is relative as it depends on how big the page you want to print on is.
Comment 10 Nicola Owen 2016-04-10 17:08:29 UTC
I was able to replicate this bug on Apache 4.1.2 on a Mac OS X Yosemite Version 10.10.5.


I lowered the font size to 880 (font size stayed at Times New Roman) and was able to replicate the bug. But would also add extra information on the summary that it specifically applies to Times New Roman (the default font). The max font size allowed on the page varies, depending on which font you choose.
Comment 11 Theodore Matula 2016-04-26 02:35:38 UTC
(In reply to Cem Kaner from comment #4)
> I don't think there is a bug here. A character that is 999 points tall is
> about 13.875 inches tall. Obviously, that won't fit on an 8.5 x 11" page,
> but it will fit on larger pages and OOO can work with larger pages. The
> program is giving you what you told it you wanted.

I agree with Cem Kaner. What what I understand, you are essentially trying to fit a character that is too long for a 8.5 x 11" page, so the program is compensating for that by showing what will fit, since the whole character cannot physically fit. I think it is working as intended, so I am moving this to Resolved/Not an Issue since it looks to me like that is what the writer should be doing in the first place.

In regards to the different font sizes, Times New Roman is a smaller font than Arial, so if both are at size 750, then it makes sense that Times new Roman fits on a 8.5 x 11" page where Arial does not, as Arial is a larger font.