Issue 126915 - Display error on the cell when opening a sheet with no update option if the cell refers to a lookup range that is on an non existing worksheet.
Summary: Display error on the cell when opening a sheet with no update option if the c...
Status: CLOSED DUPLICATE of issue 20495
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: 4.1.2
Hardware: PC All
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-10 11:23 UTC by Guy Chan
Modified: 2017-11-27 22:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
attached files in a zip file (254.10 KB, application/zip)
2016-04-10 11:23 UTC, Guy Chan
no flags Details
vlookuperror-01.jpg, the result from Calc 4.1.2 (154.27 KB, image/jpeg)
2016-04-10 11:25 UTC, Guy Chan
no flags Details
vlookuperror-02.jpg result from Excel viewer (83.50 KB, image/jpeg)
2016-04-10 11:26 UTC, Guy Chan
no flags Details
vlookuperror-03.jpg result from Excel 2007 (orignal equation shown) (70.58 KB, image/jpeg)
2016-04-10 11:27 UTC, Guy Chan
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Guy Chan 2016-04-10 11:23:25 UTC
Created attachment 85402 [details]
attached files in a zip file

This happens when opening a worksheet (in xlsx format) with Calc (I tried both 4.1.0 & 4.1.2, Traditional Chinese)under Windows XP SP3 & Windows 7 Pro TC x64 SP1. The original equation changed to "=vlookup(C$1:C$1048576;;23;0)" (attached 'vlookuperror-01.jpg')from "=VLOOKUP(C:C,'<FOLDER REFERENCE>[<FILE REFERENCE>]<SHEET REFERENCE>'!$A$1:$W$129,23,FALSE)" (attached 'vlookuperror-03.jpg') and lost its cached value. The attached 'vlookuperror-02.jpg' shows the result from Excel viewer.

It would be good if the cell can at least show the cached value and the best points to the same range even if it is not exists.
Comment 1 Guy Chan 2016-04-10 11:25:21 UTC
Created attachment 85403 [details]
vlookuperror-01.jpg, the result from Calc 4.1.2
Comment 2 Guy Chan 2016-04-10 11:26:26 UTC
Created attachment 85404 [details]
vlookuperror-02.jpg result from Excel viewer
Comment 3 Guy Chan 2016-04-10 11:27:49 UTC
Created attachment 85405 [details]
vlookuperror-03.jpg result from Excel 2007 (orignal equation shown)
Comment 4 oooforum (fr) 2017-11-26 17:39:19 UTC
Already reported

*** This issue has been marked as a duplicate of issue 20495 ***