Issue 126939 - Applied Styles List Should Be Updated After Deleting Cells/Columns/Rows Instead of Resetting to Defaults
Summary: Applied Styles List Should Be Updated After Deleting Cells/Columns/Rows Inste...
Status: CLOSED DUPLICATE of issue 98998
Alias: None
Product: Calc
Classification: Application
Component: formatting (show other issues)
Version: 4.1.2
Hardware: PC Windows, all
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-24 21:05 UTC by White Phoenix
Modified: 2017-05-20 09:53 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Spreadsheet to assist in creating a new keyboard layout (138.72 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-04-24 21:05 UTC, White Phoenix
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description White Phoenix 2016-04-24 21:05:27 UTC
Created attachment 85499 [details]
Spreadsheet to assist in creating a new keyboard layout

+++ This issue was initially created as a clone of Issue #98998 +++

When a cell, column or row is deleted and custom styles are being used, the list to the Applied Styles resets to the default styles. The list does not update until after you close and re-open the file.

The list should update (whether there are custom formats no longer being used or not) instead of reset to the default styles without needing to close and re-open the file.

This happens on both Windows and Linux. I do not know if it happens on Mac.
Comment 1 Yousuf (Jay) Philips 2016-04-24 21:16:50 UTC
As stated in issue #98998, it can be reproduce with the below steps.

1) Open attachment 85498 [details]
2) Make sure the 'Apply Style' drop down menu is visible in the formatting toolbar
3) Notice the two custom styles 'Test' and 'Test 2' are listed in the drop down
4) Select and delete column D
5) Select column B
6) Notice that the 'Apply Style' drop down has now been reset and both custom styles are missing

AOO412m3(Build:9782)  -  Rev. 1709696
2015-10-21 09:51 - Linux x86_64
Comment 2 orcmid 2016-04-24 22:18:38 UTC
Let's keep it all in one place.  Issue 98998 has the complete history.

*** This issue has been marked as a duplicate of issue 98998 ***