Issue 126980 - Crashes Page Styles
Summary: Crashes Page Styles
Status: RESOLVED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 4.1.2
Hardware: PC Linux 64-bit
: P5 (lowest) Critical with 4 votes (vote)
Target Milestone: 4.2.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 126979 127180 (view as issue list)
Depends on:
Blocks:
 
Reported: 2016-05-20 07:21 UTC by David Paenson
Modified: 2017-05-27 17:34 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.3
Developer Difficulty: ---


Attachments
Gdb log (7.14 KB, text/plain)
2016-09-18 13:59 UTC, hanya
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description David Paenson 2016-05-20 07:21:39 UTC
Writer regularly crashes when opening menu for page styles (F11).

Yesterday I bought a new computer, because I thought this might be due to a hardware defect such as graphic card on my netbook. But exactly same phenomenon: I create a completely fresh document with two or three headers, create a table of contents, open the styles menu and the program crashes. I have been having this problem now for over six months and tried absolutely everything.
Comment 1 oooforum (fr) 2016-05-23 06:49:16 UTC
This behavior is not typical and AOO works fine with Linux distro.
Crash can be cured with classical procedure: reset the profile.
Detailed information can be found in https://forum.openoffice.org/en/forum/viewtopic.php?t=12426

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 2 David Paenson 2016-05-23 08:44:44 UTC
(In reply to oooforum (fr) from comment #1)
> This behavior is not typical and AOO works fine with Linux distro.
> Crash can be cured with classical procedure: reset the profile.
> Detailed information can be found in
> https://forum.openoffice.org/en/forum/viewtopic.php?t=12426
> 
> Please report back the outcome of your testing, so this Issue may be closed
> or
> progressed as necessary - otherwise the issue may be Resolved as Invalid in
> the
> future.

sorry but cteating a new profile did not help. as i said in my original post i installed ubuntu 16.04, removed libreoffice and installed aoo from the apache site on a second brand new computer with the same results as on my older netbook. i was able to complete formatting on the same document using lo without any crashes. also on another forum a couple of people have reported the same problem. i'm not trying to imply that this is a general problem, on the other hand having used the programme openoffice for the past 15 years for formatting complete books with never any such problem occurring it was a great disappointment. also i didn't just post a bug for fun - before that i tried reinstalling the whole system (including going for ubuntu 32bit and aoo 32bit) half a dozen times  with exactly the same results. one person suggested their might be a problem with ubuntu libraries since version 15.10 (which is exactly the version under which i started to have this problem). so i would very much appreciate it if you didn't close the issue. yours dave
Comment 3 David Paenson 2016-05-23 14:16:21 UTC
Also received notification from others that this problem also applies to calc and draw ... Josef Latt expressly asked me to therefore reopen this issue.
Comment 4 billp 2016-05-23 14:52:50 UTC
I can reproduce this problem on Ubuntu 16.04 and Ubuntu Mate 16.04. I just opened a new document in Writer, then opened the Styles and Formatting window before adding any content, then clicked the Page Styles icon and Writer crashed. Resetting the user profile did not solve the problem.

When using Ubuntu 15.10, Lubuntu 16.04, or Xubuntu 16.04, Writer did not crash when following the same procedure.

This issue may be related to Issue 126824 which I can also reproduce using Ubuntu 16.04 or Ubuntu Mate 16.04.
Comment 5 jolatt 2016-05-23 15:44:47 UTC
I can reproduce the crash with an empty writer file, calc file and not so heavy with draw. 

BS: Ubuntu 16.06

With Ubuntu 12.04, which I installed for testing, I get no crash.

Considering Comment 4 I would say, that Ubuntu is the problem.

Because of this bug, I switched to Windows.
Comment 6 oooforum (fr) 2016-05-23 16:13:41 UTC
(In reply to billp from comment #4)
> When using Ubuntu 15.10, Lubuntu 16.04, or Xubuntu 16.04, Writer did not
> crash when following the same procedure.
Lubuntu = LXDE
XUbuntu = Xfce
Seems to be related with Unity interface
Comment 7 David Paenson 2016-05-25 11:59:47 UTC
Newest Situation:

Installed Lubuntu and then the US-EN version of OpenOffice. Could not start the programme. Then installed the German version. Programme started. Was able to open the Page Styles window without crashing, and could delete a few unnecessary page styles, still without crashing. Then wanted to close the second window with "unnamed text file", it asked me, if I wanted to save it before closing it, I clicked "No", programme crashed completely and all other programmes too. I had to relog into the system. So experience with Lubuntu is not better than with Ubuntu. For the time being will have to use LibreOffice until a stable solution is found.
Comment 8 David Paenson 2016-05-25 12:44:07 UTC
.... So now just deleted Lubuntu, reinstalled Ubuntu 16.04. Used the packaged LO without any changes on the same document. No crashes while applying page styles.
Comment 9 oooforum (fr) 2016-05-25 13:43:03 UTC
Ubuntu = Canonical = LibreOffice
So, work with OpenOffice is for me a non-sense.
For AOO 4.1.2, use a distro less involved.
I use on Debian 8 (Lxde or Gnome UI) with no problem.
Comment 10 David Paenson 2016-05-25 14:01:38 UTC
Thanks for your advice! I was indeed wondering if Debian might be the right solution for me.
Comment 11 jolatt 2016-05-25 16:28:52 UTC
I tried (only with writer):

Apache_OpenOffice_4.2.0_Linux_x86-64_install-deb_en-US_2016-05-03_03_38_55_1742057 and 4.1.2 en-US full installation. Both without crash.

4.1.2 en-US full installation with German langpack crashed with German UI, with English UI no crash. Same behavior with 4.1.2_de full installation with en-US langpack.

BS: Ubuntu 16.04



BTW, Ubuntu = Canonical = LibreOffice (Comment 9) is no reason for me to use LibreOffice.
Comment 12 jolatt 2016-05-25 16:43:51 UTC
1. The Summary should be changed because paragraph styles crash AOO, too. E.g. to "Crashes Page and Paragraph Styles"

2. The Importance should be raised because its a heavy bug for German users..
Comment 13 jolatt 2016-05-26 08:42:37 UTC
I made further testings, with the result that the described behavior in my comments 11 and 12 seems to be a subsidiary bug. 


New result is:
Selecting a style category results in a crash of AOO.

Starting AOO from a command line, you get a warning:
(soffice:5794): WARNING **: Unknown type: GailWindow
Comment 14 billp 2016-05-30 12:50:39 UTC
AOO 4.1.2 on Ubuntu 16.04: I also see the "GailWindow" warning when opening AOO 4.1.2 from the command line and AOO 4.1.2 crashes with any use of the Styles and Formatting window. However, if AOO 4.1.2 is started as root using the sudo command, the warning does not appear and the Styles and Formatting window can be used without crashing AOO.

Older versions of AOO on Ubuntu 16.04: AOO 4.1.0 crashes but AOO 4.0.0 does not crash when using the Styles and Formatting window.
Comment 15 oooforum (fr) 2016-05-30 13:43:34 UTC
(In reply to jolatt from comment #13)
> Starting AOO from a command line, you get a warning:
> (soffice:5794): WARNING **: Unknown type: GailWindow
Sounds like this thread: https://forum.openoffice.org/en/forum/viewtopic.php?f=7&t=74601 and issue 124948
Comment 16 hanya 2016-05-30 14:00:39 UTC
Is this related to accessiblity issue, such as issue 125147 ?
Comment 17 David Paenson 2016-05-30 17:06:10 UTC
(In reply to billp from comment #14)
> AOO 4.1.2 on Ubuntu 16.04: I also see the "GailWindow" warning when opening
> AOO 4.1.2 from the command line and AOO 4.1.2 crashes with any use of the
> Styles and Formatting window. However, if AOO 4.1.2 is started as root using
> the sudo command, the warning does not appear and the Styles and Formatting
> window can be used without crashing AOO.
> 
> Older versions of AOO on Ubuntu 16.04: AOO 4.1.0 crashes but AOO 4.0.0 does
> not crash when using the Styles and Formatting window.

I can confirm this behaviour: "sudo openoffice4" starts the programme and I can open the styles menu and at least delete a couple of superfluous user page styles without the programme crashing.
Comment 18 jolatt 2016-05-30 17:53:57 UTC
Using an application with sudo ina singel user system may be o.k. but it's IMO very dodgy in a multiuser system.
Comment 19 David Paenson 2016-05-30 19:08:59 UTC
(In reply to jolatt from comment #18)
> Using an application with sudo ina singel user system may be o.k. but it's
> IMO very dodgy in a multiuser system.

Agreed. But at least we are getting closer to some sort of solution.
Comment 20 David Paenson 2016-05-31 18:23:22 UTC
Also crashes when searching for synonyms using Strg+F7 (or the menu). Does not crash if programme is started with "sudo openoffice4".

Am not a programmer, but I have a hunch that the Thesaurus as well as the Styles menu (and possibly other menus) need an extra process or thread. If the programme is started as root, then Linux gives it green light to start parallel processes, but not if started as ordinary user. Something to do with ownership rights seems to me to be the cause.
Comment 21 jolatt 2016-06-13 07:24:37 UTC
Still UNCONFIRMED!
Comment 22 jolatt 2016-07-11 06:15:06 UTC
I don't understand why this bug is still unconfirmed.
You can't use AOO with Ubuntu 16.04. 

I don't like libreoffice.
Comment 23 mroe 2016-07-11 08:32:54 UTC
I still work with Ubuntu 14.04. So at the moment I cannot test this issue.
Comment 24 jolatt 2016-07-15 17:50:20 UTC
(In reply to mroe from comment #23)
> I still work with Ubuntu 14.04. So at the moment I cannot test this issue.

Are you a software developer? If so, I don't understand that you don't use the actual release of Ubuntu for testing.
Comment 25 jolatt 2016-08-25 16:28:20 UTC
Still unconfirmed.

Is there an anti-AOO lobby?
Comment 26 Matthias Seidel 2016-09-10 21:12:02 UTC
*** This issue has been confirmed by popular vote. ***
Comment 27 Johnny Rosenberg 2016-09-11 17:17:56 UTC
I have this bug with Ubuntu 14.04.
Someone suggested that the window manager could be the problem. I have Compiz and I don't use the default settings. For instance, I use the desktop cube for switching desktops.

No problems with LibreOffice (I have several versions installed, but NOT the pre-installed Ubuntu version).
Comment 28 Matthias Seidel 2016-09-17 14:46:47 UTC
I can confirm "crash on applying styles" with:
 AOO 4.1.2 (de) on Ubuntu 16.04.1 (64 bit)

NO crash with:
 AOO 4.1.2 (en-GB) on Ubuntu 16.04.1 (64 bit)

Further NO crash with:
 AOO 4.1.2 (de) on Xubuntu 16.04.1 (32 bit)
 AOO 4.1.2 (de) on Windows 7 (32 bit)
 AOO 4.1.2 (de) on Windows 8.1 (32 bit)
 AOO 4.1.2 (de) on OS/2 (32 bit)

So in my case it seems to be related to AOO german version on Ubuntu.
If it is started as root (sudo openoffice4) the crash does not occur.

Maybe a developer could join the discussion, so that we can isolate this bug?
Comment 29 spyre 2016-09-17 15:07:37 UTC
In addition to comment #28, I can confirm the following with french AOO:

Crash with:
 AOO 4.1.2 (fr) on Linux Mint 18 (64 bit)

NO crash with:
 AOO 4.1.2 (fr) on Linux Mint 17 (64 bit)
 AOO 4.1.2 (fr) on Windows 7 (64 bit)

The same if it is started as root (sudo openoffice4): the crash does not occur.
Comment 30 Matthias Seidel 2016-09-17 21:23:33 UTC
(In reply to jolatt from comment #11)
> I tried (only with writer):
> 
> Apache_OpenOffice_4.2.0_Linux_x86-64_install-deb_en-US_2016-05-
> 03_03_38_55_1742057 and 4.1.2 en-US full installation. Both without crash.
> 
> 4.1.2 en-US full installation with German langpack crashed with German UI,
> with English UI no crash. Same behavior with 4.1.2_de full installation with
> en-US langpack.
> 
> BS: Ubuntu 16.04

I can confirm, that AOO 4.1.2 (en-GB) does crash on Ubuntu 16.04.1, when the german language pack is installed and the user interface is set to german.
When switching back the user interface to english (UK) the crash does not occur.

As indicated in comment #29, crashes do occur also with french language pack.
Comment 31 Johnny Rosenberg 2016-09-18 10:00:54 UTC
(In reply to Matthias Seidel from comment #30)
> (In reply to jolatt from comment #11)> As indicated in comment #29, crashes do occur also with french language pack.

And Swedish; I can confirm that.
Comment 32 Matthias Seidel 2016-09-18 10:45:10 UTC
(In reply to Johnny Rosenberg from comment #31)
> (In reply to Matthias Seidel from comment #30)
> > (In reply to jolatt from comment #11)
> 	⁝
> > As indicated in comment #29, crashes do occur also with french language pack.
> 
> And Swedish; I can confirm that.

Issue 126824 seems related...

AOO 4.1.2 dutch version on linux.
Comment 33 hanya 2016-09-18 13:55:29 UTC
I could reprecate the problem on Ubuntu 16.04.1 but not on Xubuntu 16.04. 
From my observation, the reson is the same with issue 125147. The issue 126824 is caused by the same reson it seems.
This is happen if you enable accessibility function of your desktop environment.
Comment 34 hanya 2016-09-18 13:59:17 UTC
Created attachment 85677 [details]
Gdb log

Here is gdb log when the crash happen.
Comment 35 Matthias Seidel 2016-09-18 14:11:01 UTC
(In reply to hanya from comment #33)

> This is happen if you enable accessibility function of your desktop
> environment.

I have not (knowingly) enabled accessibility functions on Ubuntu 16.04.1.
Any way to disable them?
Comment 36 Ariel Constenla-Haile 2016-09-21 13:32:16 UTC
This is reproducible in macOS by enabling VoiceOver
Comment 37 Matthias Seidel 2016-09-22 21:34:14 UTC
Tested with a 4.2.0 dev build of SVN r1761670 (Ubuntu 16.04.1 / 64bit) and the problem is no longer visible!
Comment 38 Marcus 2016-09-22 22:05:31 UTC
fixed in trunk
Comment 39 jolatt 2016-10-22 06:23:54 UTC
Target Milestone: 4.2.0 
Why not 4.1.4
Comment 40 Matthias Seidel 2016-10-22 08:06:53 UTC
(In reply to jolatt from comment #39)
> Target Milestone: 4.2.0 
> Why not 4.1.4

For some reason I can not change it to 4.1.4.
It  is not in the list...

But related issue 125147 is a release blocker for 4.1.4!
Comment 41 David Paenson 2016-10-22 08:59:58 UTC
Writer also regularly crashes when, within Navigator, you attempt to Promote or Demote a chapter. Perhaps this is related: the capacity to open parallel processes, be it Style formatting or the Navigator, seems to me to be the problem.
Comment 42 Matthias Seidel 2016-10-22 09:19:47 UTC
(In reply to David Paenson from comment #41)
> Writer also regularly crashes when, within Navigator, you attempt to Promote
> or Demote a chapter. Perhaps this is related: the capacity to open parallel
> processes, be it Style formatting or the Navigator, seems to me to be the
> problem.

There are several crashes related to this one.
But the code is fixed in trunk, so no need to reopen the issue.

You may install 4.2.0dev to see if your problem is solved. If not please open a separate issue.
Comment 43 Matthias Seidel 2016-10-22 09:53:15 UTC
I can confirm that I can promote/demote a chapter within navigator in 4.2.0dev without crash.

So let's hope the code gets into 4.1.4.
Comment 44 oooforum (fr) 2016-10-24 10:35:28 UTC
*** Issue 127180 has been marked as a duplicate of this issue. ***
Comment 45 Marcus 2016-10-24 18:05:23 UTC
@Matthias:
Thanks for testing. Please see issue 125147. That fix is suggested for 4.1.4 and it's also applying for this issue. So, no need to do any further action.
Comment 46 Matthias Seidel 2016-10-25 08:57:21 UTC
(In reply to Marcus from comment #45)
> @Matthias:
> Thanks for testing. Please see issue 125147. That fix is suggested for 4.1.4
> and it's also applying for this issue. So, no need to do any further action.

I know, that's why I changed it back from REOPENED to RESOLVED... ;-)
Comment 47 oooforum (fr) 2017-05-27 17:34:23 UTC
*** Issue 126979 has been marked as a duplicate of this issue. ***