Issue 127083 - mod(whole number;1) = 1
Summary: mod(whole number;1) = 1
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: 4.1.2
Hardware: PC Windows XP
: P5 (lowest) Minor (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2016-08-21 19:58 UTC by klei0173
Modified: 2016-09-27 18:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

spreadsheet for calculating size/angles for building gazebo (225.59 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-08-21 19:58 UTC, klei0173
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description klei0173 2016-08-21 19:58:50 UTC
Created attachment 85643 [details]
spreadsheet for calculating size/angles for building gazebo

so i have  sheet and some values are whole number, ie 17, say in cell G20. if i enter =mod(G20;1) i get 1 (should be 0). if i enter =mod(17;1) i get 0 (correct). i copy the value (value only) out of G20 into, say J29, and i enter =mod(J29;1) i still get 1???? i enter a 17 on I29 and enter a formula =mod(I29;1) i get 0 (correct).  on the attached spreadsheet in sheet "layout pts", the whole numbers in the upper table have this issue - look at G30 referencing G20.  very odd..... i tried changing the table from formulas to values by copying/special pasting values only, but it still gave the same issue. very odd....

PS: i picked editing for the component because the issue followed when i copied the value out of the table.
Comment 1 crosleyzack 2016-09-27 18:48:27 UTC
I downloaded the provided file but was unable to recreate the issue. I am currently running OpenOffice 4.1.2 Build:9782 on Windows 10.

I attempted to recreate by:
- Opening provided file and checking cells specified, but they displayed as 0 values
- Creating new Calc file and performing Mod operation with various numbers, including ones derived by calculation.
- Performed mod operations on formulas, including n*2/2 for various n as shown in downloaded file.

In all of these above attempts to recreate I got a value of 0 as the output of the mod operation.

@Klei0173 can you provide any further recreation steps?