Issue 127176 - Java not recognized after update to AOO 4.1.3
Summary: Java not recognized after update to AOO 4.1.3
Status: CLOSED FIXED_WITHOUT_CODE
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.1.3
Hardware: All Windows, all
: P3 Normal with 1 vote (vote)
Target Milestone: 4.1.4
Assignee: Ariel Constenla-Haile
QA Contact:
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-10-21 15:36 UTC by billp
Modified: 2017-12-03 16:35 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.3
Developer Difficulty: ---
jim: 4.1.4_release_blocker?


Attachments
OpenOffice 4.1.2 - JRE is detected (150.91 KB, image/jpeg)
2016-10-23 18:23 UTC, Andrea Pescetti
no flags Details
OpenOffice 4.1.2 - JRE is not detected (177.26 KB, image/jpeg)
2016-10-23 18:23 UTC, Andrea Pescetti
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description billp 2016-10-21 15:36:58 UTC
AOO 4.1.2 recognizes Java 8 Update 101 and Java 8 Update 111. Both are listed as installed Java runtime environments in Java Options and the option to use a Java runtime environment is checked. After upgrading to AOO 4.1.3, the option to use a Java runtime environment has become unchecked and neither Java update is listed as an installed Java runtime environment. Clicking Add and pointing to the folder where they are installed returns the message "The folder you selected does not contain a Java runtime environment. Please select a different folder.
Comment 1 Matthias Seidel 2016-10-22 12:01:32 UTC
I just upgraded AOO and JAVA on two Windows 8.1-PCs.
I see no problems...

Are you sure the installed JAVA is 32bit?
Comment 2 billp 2016-10-23 12:07:12 UTC
Yes, Java is 32-bit. I always install the 32-bit and 64-bit versions of Java. AOO 4.1.2 recognizes the 32-bit version. AOO 4.1.3 doesn't recognize either version.

This problem first came to my attention from a post on the Apache OpenOffice User Community Forum by a Windows 7 user having this problem. At the time I had AOO 4.1.2 installed and 32-bit versions of Java 8 Update 101 and Update 111 were recognized by AOO 4.1.2. It was only after upgrading to AOO 4.1.3 that Java wasn't recognized. Since then, another forum post by a Wiindow 10 user has appeared on the forum reporting the same problem. Both users had to roll back to AOO 4.1.2 to get Java to be recognized.

https://forum.openoffice.org/en/forum/viewtopic.php?f=9&t=85667

https://forum.openoffice.org/en/forum/viewtopic.php?f=15&t=85698

In my case, resetting the user profile makes no difference. I have tried downloading AOO 4.1.3 and Java using Firefox instead of Edge, but that makes no difference. I am still unable to find and enable Java on AOO 4.1.3.
Comment 3 Matthias Seidel 2016-10-23 12:20:00 UTC
I have additionally updated from AOO 4.1.2 to 4.1.3 in my Windows 7 VM.

JAVA 1.8.0_111 is recognized...
It is located in "C:\Program Files\Java\jre1.8.0_111"

So this not a general problem, but we must find the special circumstances for your problem.

But my Windows-PCs are all 32bit, can somebody else test this under 64bit Windows?
Comment 4 Keith N. McKenna 2016-10-23 12:57:13 UTC
I have tested this on the following configuration:

System Configuration:
Processor: Intel Core i5 CPU M560 @2.67GHz
Installed Memory: 2.00 GB (1.6 usable)
Operating System: Windows 7 Home Premium 64 bit

Apache Open Office:
AOO413m1(Build:9783)  -  Rev. 1761381
2016-09-29 02:39:19AOO413m3(Build:9782)  -  Rev. 1709696
Language: en_US
Additional Language Packs: None
and
AOO420m1(Build:9800)  -  Rev. 1692551
Rev.1692551

The Java update installs in C:\Program Files (x86)\Java\jre1.8.0_111 and AOO 4.1.3 automatically finds it.
Comment 5 Andrea Pescetti 2016-10-23 18:22:45 UTC
This was reported by Roberto Crosio on the Italian mailing list too. So it is not a general problem, but we start to have several different reports.

I'll shortly attach screenshots he provided, showing the Java Options for 4.1.2 (JRE is detected) and 4.1.3 (empty); they were taken on the same (Windows) machine, uninstalling 4.1.2 and installing 4.1.3; if one uninstalls 4.1.3 and reinstalls 4.1.2, Java is properly detected again.

(setting CONFIRMED due to independent reports, even though I didn't personally reproduce)
Comment 6 Andrea Pescetti 2016-10-23 18:23:37 UTC
Created attachment 85757 [details]
OpenOffice 4.1.2 - JRE is detected
Comment 7 Andrea Pescetti 2016-10-23 18:23:59 UTC
Created attachment 85758 [details]
OpenOffice 4.1.2 - JRE is not detected
Comment 8 Matthias Seidel 2016-10-23 18:56:10 UTC
(In reply to billp from comment #2)
> Yes, Java is 32-bit. I always install the 32-bit and 64-bit versions of
> Java. AOO 4.1.2 recognizes the 32-bit version. AOO 4.1.3 doesn't recognize
> either version.

Just a guess:
Could it be that 4.1.3 has problems with the detection when both, a 32- and a 64-bit JAVA are installed?
Comment 9 billp 2016-10-24 00:06:21 UTC
After uninstalling 64-bit Java Updates, AOO 4.1.3 still can't find the 32-bit updates.
Comment 10 Patricia Shanahan 2016-10-24 02:07:30 UTC
I have a Windows 7 laptop with both 64-bit and 32-bit JREs. 4.1.3 finds the 32-bit JRE. I went back to 4.1.2, uninstalled it, and installed 4.1.3, and it still found the JRE.
Comment 11 billp 2016-10-25 03:26:46 UTC
I've found a workaround for AOO 4.1.3 on my system, but I don't know if it might have adverse effects. AOO 4.1.2 and AOO 4.1.3 have different versions of the msvcr100.dll file installed in C:\Program Files (x86)\OpenOffice 4\program. I deleted the msvcr100.dll file installed by AOO 4.1.3 and replaced it with the msvcr100.dll file from AOO 4.1.2. When AOO 4.1.3 was restarted, the Java Runtime Environments appeared almost immediately in Java Options.
Comment 12 Matthias Seidel 2016-10-25 13:25:20 UTC
(In reply to billp from comment #11)
> I've found a workaround for AOO 4.1.3 on my system, but I don't know if it
> might have adverse effects. AOO 4.1.2 and AOO 4.1.3 have different versions
> of the msvcr100.dll file installed in C:\Program Files (x86)\OpenOffice
> 4\program. I deleted the msvcr100.dll file installed by AOO 4.1.3 and
> replaced it with the msvcr100.dll file from AOO 4.1.2. When AOO 4.1.3 was
> restarted, the Java Runtime Environments appeared almost immediately in Java
> Options.

That's a good find!

Could you please give the date/version of msvcr100.dll?

On my system (Win7/32bit/AOO4.1.3) it is:
date "‎8.9.2011, ‏‎16:18:42"
version "10.0.40219.325"
Comment 13 billp 2016-10-25 14:25:56 UTC
The msvcr100.dll version installed by AOO 4.1.3 on my system is also version 10.0.40219.325, but I've now found that it is the 64-bit version of msvcr100.dll but it should be the 32-bit version. If the 32-bit version isn't found somewhere else, then the Java Runtime Environments won't be found. The better workaround for the problem is to download the vcredist_x86.exe file in the Microsoft Visual C++ 2010 Service Pack 1 Redistributable Package MFC Security Update from Microsoft and install it. That installs the 32-bit version of msvcr100.dll system wide and AOO 4.1.3 should find it and can then find the Java Runtime Environments.
Comment 14 Keith N. McKenna 2016-10-25 16:23:17 UTC
As an over-site the entry for this Known Issue was omitted from the 4.1.2 and 4.1.3 Release Notes. I have added it back to the 4.1.3 Release Notes. My question is is this a regression that should be Release Blocker for 4.1.4?
Comment 15 Matthias Seidel 2016-10-25 17:10:52 UTC
(In reply to Keith N. McKenna from comment #14)
> As an over-site the entry for this Known Issue was omitted from the 4.1.2
> and 4.1.3 Release Notes. I have added it back to the 4.1.3 Release Notes. My
> question is is this a regression that should be Release Blocker for 4.1.4?

Just my € 0,02:

This is a regression, as billp stated that his dll from 4.1.2 worked (hence it was 32bit).

It should be a release blocker for 4.1.4!
Comment 16 billp 2016-10-25 21:05:54 UTC
@Keith N. McKenna: I checked the Release Notes and found the link, but the link is to the older version 10.0.30319.1 which was the version installed in AOO 4.1.2. The version which I downloaded from Microsoft was the security update 10.0.40219.325. I have seen no problems with that version in very limited use. Is there a known issue with using version 10.0.40219.325?
Comment 17 Keith N. McKenna 2016-10-25 22:13:11 UTC
(In reply to billp from comment #16)
> @Keith N. McKenna: I checked the Release Notes and found the link, but the
> link is to the older version 10.0.30319.1 which was the version installed in
> AOO 4.1.2. The version which I downloaded from Microsoft was the security
> update 10.0.40219.325. I have seen no problems with that version in very
> limited use. Is there a known issue with using version 10.0.40219.325?

As far as I know there is no issue with using 10.0.40219.325, that is what I am using currently with 4.1.3. I just did a quick copy and paste from the old Release Notes. Will double check the link and reset it in the 4.1.3 Release Notes. Have reset the link to the x86 sp1.
Comment 18 phip 2016-10-28 08:49:42 UTC
Installing 413 AOO right click as administrator.
Without changing any option
therefore standard.
not just the dictionary extension.

no detection of JRE.
has not happened to him either add a JRE
and no Java in final

Installation de AOO 413 clic droit comme administrateur.
Sans modifier la moindre option
donc en standard.
pas d’extension juste le dico.

pas de détection du JRE.
pas arrivé a lui faire ajouter un JRE non plus
et pas de Java en final
Comment 19 oooforum (fr) 2016-10-28 09:04:25 UTC
(In reply to Matthias Seidel from comment #15)
> It should be a release blocker for 4.1.4!
Seems to be fixed. See Issue 127197
Comment 20 Ariel Constenla-Haile 2016-10-28 14:20:19 UTC
(In reply to billp from comment #13)
> The msvcr100.dll version installed by AOO 4.1.3 on my system is also version
> 10.0.40219.325, but I've now found that it is the 64-bit version of
> msvcr100.dll but it should be the 32-bit version.

Good catch.

C:\Program Files (x86)\OpenOffice 4\program>dumpbin /headers msvcr100.dll
Microsoft (R) COFF/PE Dumper Version 9.00.30729.01
Copyright (C) Microsoft Corporation.  All rights reserved.


Dump of file msvcr100.dll

PE signature found

File Type: DLL

FILE HEADER VALUES
            8664 machine (x64)


(In reply to billp from comment #16)
> @Keith N. McKenna: I checked the Release Notes and found the link, but the
> link is to the older version 10.0.30319.1 which was the version installed in
> AOO 4.1.2. The version which I downloaded from Microsoft was the security
> update 10.0.40219.325. I have seen no problems with that version in very
> limited use. Is there a known issue with using version 10.0.40219.325?

This shows that we shouldn't bundle the DLL, see issue 127197
Comment 21 Matthias Seidel 2016-10-31 14:44:14 UTC
This shows that we should bundle the right DLL (32bit, NOT 64bit) ;-)
Comment 22 morgan.wingfield 2017-03-12 17:13:47 UTC
I'm trying to setup OpenOffice for the first time to get a DB, and I'm getting these same Java not found errors discussed in this thread (which is how I got here).  I may have initially downloaded the 64 bit Java version, but I've since uninstalled it and installed the 32 bit - numerous times now.  OO never can recognize Java.

I'm using Windows 10 Home Version 1607 OS Build 14393.693
OpenOffice 4.1.3 AOO413m1(Build:9783)  -  Rev. 1761381
Java version 8 Update 121 (build 1.8.0_121-b13)

Is there a fix for this?  I've seen some suggestions above, but I'm not really a sophisticated enough user to follow what needs to be done.

Thanks in advance!
Comment 23 Matthias Seidel 2017-03-12 18:00:09 UTC
(In reply to morgan.wingfield from comment #22)
> I'm trying to setup OpenOffice for the first time to get a DB, and I'm
> getting these same Java not found errors discussed in this thread (which is
> how I got here).  I may have initially downloaded the 64 bit Java version,
> but I've since uninstalled it and installed the 32 bit - numerous times now.
> OO never can recognize Java.
> 
> I'm using Windows 10 Home Version 1607 OS Build 14393.693
> OpenOffice 4.1.3 AOO413m1(Build:9783)  -  Rev. 1761381
> Java version 8 Update 121 (build 1.8.0_121-b13)
> 
> Is there a fix for this?  I've seen some suggestions above, but I'm not
> really a sophisticated enough user to follow what needs to be done.
> 
> Thanks in advance!

Hi,

See comment 13.
You should be able to download vcredist_x86.exe from here:

https://www.microsoft.com/en-us/download/details.aspx?id=8328

After installation JAVA should be recognized...

Kind regards, Matthias
Comment 24 Matthias Seidel 2017-03-12 19:26:15 UTC
Regarding msvcr100.dll:

In AOO 4.1.4 (r1781705) and 4.2.0 (r1785175) we are still bundling version 10.0.30319.1

This should be updated to version 10.0.40219.325 from:

https://www.microsoft.com/en-US/download/details.aspx?id=26999

for the 4.1.4 Release Candidate.
Comment 25 morgan.wingfield 2017-03-12 19:37:52 UTC
Matthias,

Thanks very much.  That was the easiest 30 second fix to something I've been fighting for days.

Morgan
Comment 26 Matthias Seidel 2017-03-12 20:00:28 UTC
(In reply to morgan.wingfield from comment #25)
> Matthias,
> 
> Thanks very much.  That was the easiest 30 second fix to something I've been
> fighting for days.
> 
> Morgan

You're welcome.

This issue should be fixed in AOO 4.1.4 ;-)

Matthias
Comment 27 oooforum (fr) 2017-03-22 16:25:24 UTC
Closed as fixed
Comment 28 Matthias Seidel 2017-04-09 16:47:00 UTC
(In reply to oooforum (fr) from comment #27)
> Closed as fixed

Are you sure you want to close a release blocker for 4.1.4?
Did you talk to the release manager?
Comment 29 Jim Jagielski 2017-05-02 11:37:55 UTC
REOPEN for 4.1.4 consideration
Comment 30 Keith N. McKenna 2017-07-03 14:34:38 UTC
I see that a request for release_blocker status for 4.1.4 was requested. I believe this should be granted.
Comment 31 Matthias Seidel 2017-07-03 14:45:01 UTC
This is mainly a building/bundling issue.

But you can try my latest test build to see if it works:

https://home.apache.org/~mseidel/AOO-builds/AOO-414-Test/Full%20Installation/
Comment 32 oooforum (fr) 2017-07-05 15:59:05 UTC
Fixed with 4.1.4
So we can close it as fixed
Comment 33 Andrea Pescetti 2017-07-06 06:25:52 UTC
For actually closing, we must wait until 4.1.4 is released; at the moment we only have preview builds, not even Release Candidates. But we can mark resolved/fixed.

Matthias: when you do that, please also provide a brief explanation that we will also add to the 4.1.4 scripts so that knowledge is preserved, thanks!
Comment 34 Matthias Seidel 2017-07-07 17:35:03 UTC
This is just a matter of building with the right version (32bit) of msvcr100.dll bundled.

See https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Windows_7.2C_Windows_8.1.2C_Windows_10 for details.