Issue 127246 - Writer does not coordinate properly with HPLIP driver for envelopes
Summary: Writer does not coordinate properly with HPLIP driver for envelopes
Status: CLOSED DUPLICATE of issue 83659
Alias: None
Product: Writer
Classification: Application
Component: printing (show other issues)
Version: 4.1.3
Hardware: PC Linux 64-bit
: P5 (lowest) Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-11 19:54 UTC by kitchm
Modified: 2017-04-26 18:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Writer 1 (8.72 KB, application/vnd.oasis.opendocument.text)
2016-12-15 21:25 UTC, kitchm
no flags Details
PDF 1 (7.08 KB, application/pdf)
2016-12-15 21:27 UTC, kitchm
no flags Details
Writer 2 (8.48 KB, application/vnd.oasis.opendocument.text)
2016-12-15 21:28 UTC, kitchm
no flags Details
PDF 2 (7.08 KB, application/pdf)
2016-12-15 21:30 UTC, kitchm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kitchm 2016-12-11 19:54:21 UTC
I am using Writer on Xubuntu 14.04.5 with HPLIP and HP PhotoSmart 3100 series printer.  No matter which instructions, which predefined format or which custom format I use to create an envelope, the output is always wrong.

It took a little bit to realize that Writer formats from the right.  Bizarre compared to other word processors, where we are used to format from the left, including envelopes.

Notwithstanding, all of the predefined #10 envelope formats fail to allow full bleed.  But even if I set the left margin at 1/4 inch, it is still cut off.  Even at 1/2 inch.

But then it gets worse.  If I select a format of 11x8.5 letter, which displays correctly as landscape, and I do a test print at left margin of .4 inches, I get printout that gets as close as I can without cutoff.  But if I change the height to 4.5, the output shifts dramatically toward the right of the page, and cuts off the left margin text when it was working fine before that change.  What a mess.

It appears that the internal presets of the program are confused in two ways; first there is a problem with it allowing the user to make a custom document, and second it seems to be unable to properly drive the printer within the printer's full range.

I have read somewhere that the current driver may only allow full-bleed in three margins.  But even still, there are serious problems with Writer.
Comment 1 oooforum (fr) 2016-12-13 16:49:52 UTC
Export your document in PDF and print it.
Did you have the same result?
Comment 2 kitchm 2016-12-13 19:34:54 UTC
I did the 11x8.5 format again, and exported it to PDF.  I opened the PDF file in a document viewer and printed from there.  Then I changed the format to 4.5 instead of 8.5, saved to pdf and printed it from the viewer.  The output was different.

I used 8.5x11 paper each time.  Compared to the first print, the second shifted the page text down 1-1/2 inches and left 1/2 inch.
Comment 3 oooforum (fr) 2016-12-15 17:19:08 UTC
Don't understand what you means.
Thanks to attach your ODT document and its PDF exported.
Comment 4 kitchm 2016-12-15 21:25:11 UTC
Created attachment 85888 [details]
Writer 1
Comment 5 kitchm 2016-12-15 21:27:39 UTC
Created attachment 85889 [details]
PDF 1
Comment 6 kitchm 2016-12-15 21:28:35 UTC
Created attachment 85890 [details]
Writer 2
Comment 7 kitchm 2016-12-15 21:30:06 UTC
Created attachment 85891 [details]
PDF 2
Comment 8 oooforum (fr) 2016-12-16 14:40:07 UTC
No problem between ODT and PDF
Sample 1: format letter 27.94x21.59 cm
Sample 2: format user 27.94x11.43 cm
Same dimensions for me
Comment 9 kitchm 2016-12-16 15:08:22 UTC
Must be something else.

How did you compare?
Comment 10 oooforum (fr) 2016-12-16 16:06:09 UTC
For ODT : menu Format > Page
For PDF : menu File > Properties

Now, if you print a PDF and this have not right dimensions, the problem is not with AOO.
Comment 11 mroe 2016-12-16 16:59:07 UTC
AOO/OOo/SO has problems with envelopes since years – mostly from the beginning.

https://bz.apache.org/ooo/buglist.cgi?quicksearch=envelope

Your problem sounds like issue 83659.
Comment 12 oooforum (fr) 2017-04-26 12:32:02 UTC
According to previous comment

*** This issue has been marked as a duplicate of issue 83659 ***