Issue 127333 - Units of Measure for US fails Usability for Common Gradations
Summary: Units of Measure for US fails Usability for Common Gradations
Status: CLOSED DUPLICATE of issue 45593
Alias: None
Product: Internationalization
Classification: Code
Component: ui (show other issues)
Version: 4.1.3
Hardware: Other Linux 64-bit
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-24 01:27 UTC by David Chamberlin
Modified: 2017-02-24 17:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description David Chamberlin 2017-02-24 01:27:16 UTC
Common gradations for the implementation of US units of measurement in Imperial units fail usability for the market. 

Units of measure for US market are in inches.  The gradations for US market are typically in terms of 1/16th of an inch and sometimes down to 1/32th of an inch.

The current GUI and representational implementation does not support this granularity of gradations to be usable for the US market.

In general, any field that represents units of measurements of the page should support at least 3 decimal places, optimally 4, to accurately represent page sizes and gradations of measurement. 


Case in point (no pun intended).

Page Sizes: 

Although US Paper sizes are typically need 1 decimal places of precision (i.e. 8.5"), most of the US Envelope sizes require 3 decimal places of precision. 

Envelope
6¼	        6.0 x 3.5	
6¾	        6.5 x 3.625	
7	        6.75 x 3.75	
7¾ - Monarch	7.5 x 3.875	
8 5/8	        8.625 x 3.625	
9	        8.875 x 3.875	
10	        9.5 x 4.125	
11	        10.375 x 4.5	
12	        11.0 x 4.75	
14	        11.5 x 5.0	
16	        12.0 x 6.0	

Gradations of Measurements:

For margins and tabs, most rules have tick marks that are divisible by 2.  So, 1/2", 1/4", 1/8", 1/16" of an inch are normal spacing measurements.  Yet, without 3+ decimal places of precision, you can only space things on 1/4 increments.  

Analogy:

It's like if we made spanners in the US at 0.25", 0.50", 0.75", and 1".  This would be useful for only 25% of the case because we have bolts in sizes of 1/16", 1/8", 3/16", 1/4", 5/16", 3/8", 7/16", 1/2", 9/16", 5/8", 11/16", 3/4", 13/16", 7/8", 15/16", 1".  These latter increments are common gradations to allow usability in the US market.

So, 2 decimal places of precision on a US document is only 25% usable in terms of features for margins, tabs, rulers, etc.


How to demonstrate the problem...

Labels

Some of the the Label Sheets that you have predefined are incorrect due to this precision limitation and are wasting good sheets when the user tries to print costing them money.  May not be big issue for one label sheet, but sends the wrong message to the end-user if you start wasting their sheets because you fail to support the precision necessary for the unit of measure in order to implement the correct settings for spacing on the label sheet.  


File/New/Labels, then on the labels tab select Avery Letter Size for the Brand and 5266 File Folder-Assorted for the Type.

This label is 1/2" margin at top and bottom, and has 15 labels that take up 10" on the page.  Each label is exactly 2/3" height.  

If you represent that with a Vertical Pitch of 0.66" you end up with a negative shift of 0.1" at the end of the page, or pretty much equivalent to a 7.2 pt text line.

If you represent that with a Vertical Pitch of 0.67" you end up with a positive shift of 0.05" at the end of the page, or pretty much equivalent to a 3.6 pt text line.  

So, by the last label, we've either moved text up 7.2 pt, or down 3.6 pt which on a 48 pt tall label is 15% or 7.5% of the label.

It doesn't help that the default Vertical Pitch for that label is incorrectly set at 0.68, producing a noticeable 10.8 pt shift in the label.  That means the last one is moved 22.5% shift down on the label!

Now, consider how this applies to other aspects of the program.  Rulers, tabs and spacing in general.  Most features are based on a 2 decimal place precision for input.   

It is equivalent to saying you can only use up to 1/4" increments even though we supply you 1/100" increments.  This might be similar to saying you can only layout in cm and not mm, but it's more like you can do 1/n^2 spacing up to 1/4" then are forced to use increments in 1/100ths of an inch which leads to  non-uniform spacing in design and layout.

Rulers/Tabs

Look at the rulers.  In the US, we have a ruler that shows both metric and imperial (inches).  The gradations ticks are always at 1/2, 1/4, 1/8, 1/16 intervals, yet the ruler in the program only shows 1/4".  The tabs that are in-between are not in the gradations we would use, because they are in 1/100ths" of an inch.  So you are basically using 1/100th of an inch for units of measure entry into the edit box, but 1/4, 1/2, 3/4 units for showing the ticks.  These are different intervals.  It may work for those values, but 1/8 and 1/16 don't work with only 2 decimal places of precision.

These 2 decimal places of precision are prevalent throughout the program.  Its like saying you can layout your document in inches, but must be in terms of 1/100th of an inch.  1/100 as a gradation works for metric, but not for imperial US units.

Predefined Forms

Another common use case is printing on predefined forms.  Again, those forms typically have a layout that is in gradations of 1/2^n, in the unit of measure of inches, which should be 1/2", 1/4", 1/8", 1/16" or maybe even 1/32" in terms of precision.  

And if they try to make a form in the use, well, they can't space anything in 1/8ths or 1/16th of an inch because they limited to 1/100" increments.  

Although possible, it basically creates forces them to use a hybrid measurement that  will have users thinking in terms of 1/100th of an inch and that doesn't even make it easier to migrate to metric.  

On a form, how will they create something spaced at 3/8" apart? 

Until this program is revised to support 1/8", 1/16" gradations at a minimum with 3 and 4 decimal places of precision on all edit boxes and fields with a unit of measure in inches, the program will continue to be poorly localized for the US market.

It should be considered the highest priority as it is an "epic-fail" in terms of localization and usability for the US market. 

Not only you...:

MS Word uses points as the means for paragraph spacing instead of inches.  Their indentation is 1/100", and their tabs are 1/100", which is strange because their ruler shows 1/8" (0.125") ticks.  So they have the same issue.

In this case its better not to design to be the same, but to be functional.

Their labels for Avery don't even correlate to the product numbers from the store, they show generalize names and fancy thumbnails but fail on the usability at that point.

Their labels are based on tables, and still suffer from the granularity issue of 1/100".

Frankly, increasing the units of precision would solve the issue for the misaligned labels, fix the usability issue and provide market differentiation.

It should be considered for your next major revision.
Comment 1 oooforum (fr) 2017-02-24 14:20:07 UTC
Already reported

*** This issue has been marked as a duplicate of issue 45593 ***