Issue 127532 - Can select protected cells when option is set not to.
Summary: Can select protected cells when option is set not to.
Status: CLOSED DUPLICATE of issue 123703
Alias: None
Product: Calc
Classification: Application
Component: formatting (show other issues)
Version: 4.1.3
Hardware: PC All
: P5 (lowest) Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-09-06 00:34 UTC by Tommy M. Carver
Modified: 2017-09-07 09:06 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Cell Protection Steps (805.36 KB, application/pdf)
2017-09-06 00:49 UTC, Tommy M. Carver
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Tommy M. Carver 2017-09-06 00:34:20 UTC
AOO413m1(Build:9783)  -  Rev. 1761381
2016-09-29 02:39:19.

OS: W10-64, 1703

See attached steps taken. After deselecting "select locked cells" in the "Protect Sheet" dialog protection works as it should. After exiting out of Calc and reopening the spreadsheet I can select protected cells. However, the cells are protected and when clicking on them the message box "Protected Cells Cannot Be Modified" pops up, which it should. So it's not a major issue but protected cell selection setting is not working correctly.
Comment 1 Tommy M. Carver 2017-09-06 00:49:45 UTC
Created attachment 86214 [details]
Cell Protection Steps
Comment 2 Peter 2017-09-06 06:00:41 UTC
Can you elaborate on the part "dialog protection works as it should."

I fail to see the Problem. It works as designed.

So if at all it is not a bug but a feature, and you request an enhacement.
Lets hear you out on that :-)

All the best
Peter
Comment 3 oooforum (fr) 2017-09-06 16:42:41 UTC
>and you request an enhacement.
Already reported

*** This issue has been marked as a duplicate of issue 71468 ***
Comment 4 Tommy M. Carver 2017-09-07 00:01:47 UTC
(In reply to Peter from comment #2)
> Can you elaborate on the part "dialog protection works as it should."
> 
> I fail to see the Problem. It works as designed.
> 
> So if at all it is not a bug but a feature, and you request an enhacement.
> Lets hear you out on that :-)
> 
> All the best
> Peter

Hello Peter. It does work as designed until you exit out of AOO. Upon reopening the worksheet you can select the protected cells even though the "Select Protected Cells" check box is unchecked or deselected.

The steps are: 1. select all the cells I want unprotected.
               2. Go to "Format Cells" and uncheck "protected".
               3. Go to "Tools" > Protect Document > Sheet
               4. In the popup "Protect Sheet" box I UNCHECK "Allow all users of   this sheet to: "Select locked cells", and leave "Select unlocked cells" checked. I also leave "Protect this sheet and contents of locked cells" checked.
               5. I check to see if my choices are working, and they are. I cannot select locked cells.
               6. Save the worksheet and exit AOO.
               7. Upon reopening the worksheet I can select locked cells, which I set to not be able to select locked cells.
               8. The protected cells are protected, but you can select. Calc gives the popup message "Protected cells can not be modified" when I double click on protected cells.

Hope this helps Peter.
Comment 5 Tommy M. Carver 2017-09-07 00:12:18 UTC
I'm not sure if I'm supposed to reopen this or not. I reviewed issue 71468 that is supposed to be a duplicate, but I'm not seeing this is the same issue although I may be wrong. I am responding to Peter's inquiry below.
Comment 6 mroe 2017-09-07 09:06:40 UTC
(In reply to Tommy M. Carver from comment #5)
> I'm not sure if I'm supposed to reopen this or not. I reviewed issue 71468
> that is supposed to be a duplicate, but I'm not seeing this is the same
> issue although I may be wrong. I am responding to Peter's inquiry below.

Yes, you have the right. You are the owner of this issue. But it is always a duplicate of another issue: issue 123703.

*** This issue has been marked as a duplicate of issue 123703 ***