Issue 127570 - Can't fill data into base forms
Summary: Can't fill data into base forms
Status: CONFIRMED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: 4.1.4
Hardware: PC Linux 64-bit
: P2 Major (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-24 16:09 UTC by Mechtilde
Modified: 2018-01-06 11:19 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Insert values into form failed (9.87 KB, application/vnd.oasis.opendocument.database)
2017-10-25 15:47 UTC, Mechtilde
no flags Details
ODB back in town (9.83 KB, application/vnd.sun.xml.base)
2017-10-25 15:56 UTC, oooforum (fr)
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Mechtilde 2017-10-24 16:09:57 UTC
To reproduce:

1. open a new database
2. Create a table with two columns, one as ID as autoincrement
3. create a form in table design 
4. connect to that table
5. Try to insert values

It isn't possible to do so.

With a connection to a mysql/mariadb it crashes.

If you need more informaiton, give me a hint to prepare them
Comment 1 oooforum (fr) 2017-10-25 07:59:28 UTC
I was not able to reproduce.
No problem to input data through a form and a table control.
Tested with Win7 x64 Pro and AOO 4.1.4
Using of embedded HSQL database engine

Please, provide an ODB and details about your operating system.
Comment 2 Mechtilde 2017-10-25 08:31:57 UTC
I changed Hardware and OS

I find this problem under Debian 32 bit and 64 bit ad Debian 8, 9 and 10

After trying to insert values it freezes.
Comment 3 Mechtilde 2017-10-25 15:47:52 UTC
Created attachment 86233 [details]
Insert values into form failed

A *.odb document showing the problem.

Open the document
Open the form
try to insert a value
Comment 4 oooforum (fr) 2017-10-25 15:56:46 UTC
Created attachment 86234 [details]
ODB back in town

Sorry, I can insert into your form.
I added two records with no problem.

So, that's work with Windows system.
Maybe, specific to Linux?
Comment 5 mroe 2017-10-25 16:02:12 UTC
Can NOT reproduce the issue under Ubuntu 14.04. No problems filling the form.
Comment 6 oooforum (fr) 2017-10-27 09:46:16 UTC
@mechtilde: could you test with my ODB?
Comment 7 Mechtilde 2017-10-27 17:59:25 UTC
So I did some more test also at different machines. It seems to be a 64 -bit Problem

@mroe do you use a 32-bit system?

@oooforum: I tested your *.odb too. It failed at my system

I already tried to use a new user dir with no success.
.
Comment 8 mroe 2017-10-28 00:04:48 UTC
> @mroe do you use a 32-bit system?


No. 64 bit. But there was other issues that comes only with Ubuntu/Debian versions from Ubuntu 16.10 upwards.
Comment 9 oooforum (fr) 2017-11-07 17:01:43 UTC
I was not able to reproduce with LUbuntu 17.10 x64 and AOO 4.1.4

To avoid an hardware problem, could you try another Distro?
Comment 10 oooforum (fr) 2017-11-22 16:32:47 UTC
No news from OP?
Dev team has published a 4.1.5-dev:
http://home.apache.org/~jim/AOO-builds/AOO-4.1.5-dev-20171120/
Maybe a new test with it.
Comment 11 Mechtilde 2018-01-06 07:30:57 UTC
I did the same tests under Debian 10 64-bit/XFCE4 with AOO 4.1.5 

I can't insert any valus into the form
I can't save the file. I can only close the file without any saving.

I also tried the second file with the same result.

When I test it with version 4.2.0-dev (05.01.2018) it crashes immediately. Ionly click into the form.