Issue 127580 - Fix for Issue 127568 created a new bug in Base
Summary: Fix for Issue 127568 created a new bug in Base
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: 4.1.4
Hardware: Mac macOS 10.13
: P5 (lowest) Major (vote)
Target Milestone: 4.1.5
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks: 127568
  Show dependency treegraph
 
Reported: 2017-11-03 11:40 UTC by Larry Gusaas
Modified: 2018-01-22 09:21 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jim: 4.1.5_release_blocker+


Attachments
Test base document (21.90 KB, application/vnd.oasis.opendocument.database)
2017-11-03 11:40 UTC, Larry Gusaas
no flags Details
Screenshot of document using AOO 4.1.3 (581.25 KB, image/png)
2017-11-03 11:41 UTC, Larry Gusaas
no flags Details
NeoOffice attempt (62.45 KB, image/png)
2017-11-03 16:38 UTC, Jim Jagielski
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Larry Gusaas 2017-11-03 11:40:05 UTC
Created attachment 86247 [details]
Test base document

Bug fix for Mac 4.1.4, [AOO414m5(Build:9788)  -  Rev. 1811857
2017-11-01 01:17:11 (Wed, 01 Nov 2017)], broke Base. I’ve attached a test document – Test list.odb

In left column (Database) select Tables.
In centre column (Tables) double click Addresses.
The OpenOffice Base: Table Data View does not open.

In AOO 4.1.3, [AOO413m1(Build:9783)  -  Rev. 1761381
2016-09-23 02:39:34 (Fri, 23 Sep 2016)],the Table Data View opens. I’ve attached a screenshot.

In the release version of AOO 4.1.4, [AOO414m5(Build:9788)  -  Rev. 1811857
2017-10-16 22:12:14 (Mon, 16 Oct 2017)], the Table Data View opens.

The build fix for the Calc bug (Issue 127568 - Diagrams become corrupt (not retrievable) when Calc document is saved) has created a new bug in Base.

I am using MacBook Pro, macOS ver, 10.13.1 High Sierra, Java 9 (jdk-9.0.1.jdk)
Comment 1 Larry Gusaas 2017-11-03 11:41:51 UTC
Created attachment 86248 [details]
Screenshot of document using AOO 4.1.3
Comment 2 Jim Jagielski 2017-11-03 12:03:02 UTC
Cannot re-create. When attempting to follow the instructions, I get an OpenOffice Base pop-up:

"""
The connection to the data source "Test list" could not be
established.

The connection to the external data source could not be established.
No SBDC driver was found for the given URL.
"""
Comment 3 Larry Gusaas 2017-11-03 12:23:32 UTC
Jim:
Are you using Java 9?
If not, do you have the legacy Apple Java 6 installed?
Comment 4 Jim Jagielski 2017-11-03 13:06:12 UTC
/Library/Java/JavaVirtualMachines/1.8.0.jdk/Contents/Home
Comment 5 Jim Jagielski 2017-11-03 13:06:28 UTC
Oh. And 10.12.6 (Sierra)
Comment 6 oooforum (fr) 2017-11-03 14:09:14 UTC
(In reply to Jim Jagielski from comment #2)
> Cannot re-create. When attempting to follow the instructions, I get an
> OpenOffice Base pop-up:
> 
> """
> The connection to the data source "Test list" could not be
> established.
> 
> The connection to the external data source could not be established.
> No SBDC driver was found for the given URL.
> """
This error can occur when you opened directly an ODB from a browser.
The best is to download this file.
Comment 7 Jim Jagielski 2017-11-03 16:38:07 UTC
Created attachment 86249 [details]
NeoOffice attempt
Comment 8 Jim Jagielski 2017-11-03 16:38:59 UTC
Wondering if this is related... Maybe we are missing some error pop-up and OpenOffice is just silently disabling.
Comment 9 Dave Fisher 2017-11-03 17:33:19 UTC
I can confirm that I get what Larry gets on Sierra 10.12.6.

When opening the Base file I get the following in /var/log/system.log:

596:Nov  3 10:29:19 Daves-MacBook-Pro soffice[70777]: assertion failed: 16G29: libxpc.dylib + 74307 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0x89
597:Nov  3 10:29:22 Daves-MacBook-Pro soffice[70777]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked

When I open the Base file with the original 4.1.4 from October 17 I only see:

598:Nov  3 10:31:40 Daves-MacBook-Pro soffice[70791]: assertion failed: 16G29: libxpc.dylib + 74307 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0x89
Comment 10 Larry Gusaas 2017-11-03 19:47:45 UTC
(In reply to Jim Jagielski from comment #4)
> /Library/Java/JavaVirtualMachines/1.8.0.jdk/Contents/Home

Do you also have 1.6.0.jdk?
Comment 11 Keith N. McKenna 2017-11-06 19:06:19 UTC
Given Dave's confirmation in https://bz.apache.org/ooo/show_bug.cgi?id=127580#c9 the ongoing discussion on dev@ I am setting this as confirmed and as blocking Issue 127568.
Comment 12 oooforum (fr) 2017-11-21 19:44:02 UTC
Seems to be solved with 4.1.5-dev
http://home.apache.org/~jim/AOO-builds/
Comment 13 Jim Jagielski 2017-12-09 20:20:46 UTC
Keeping open to ensure that these are tested and fixed in RCs
Comment 14 Keith N. McKenna 2017-12-26 22:30:15 UTC
Marking as fixed