Issue 127732 - Installing SVN trunk breaks external applications due to loss of system-wide CRT DLLs
Summary: Installing SVN trunk breaks external applications due to loss of system-wide ...
Status: CONFIRMED
Alias: None
Product: Installation
Classification: Application
Component: code (show other issues)
Version: 4.2.0-dev
Hardware: PC Windows 7
: P5 (lowest) Blocker (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-14 04:02 UTC by damjan
Modified: 2019-06-02 21:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description damjan 2018-03-14 04:02:49 UTC
I installed the latest SVN trunk (setup.exe produced during the AOO32 on Win64 build), for the first time on Windows 7. This was while investigating Bug 127731 that refers to odbcconfig.exe not working.

Our odbcconfig.exe ($OOO_BASE/program/odbcconfig.exe) itself gives the following error when double-clicked in Windows Explorer:
"The program can't start because MSVCRT90.dll is missing from your computer. Try reinstalling the program to fix this problem."

But, *****FAR WORSE*****, other unrelated applications have broken!!! To examine odbcconfig.exe's exports, I tried using Visual Studio's dumpbin.exe, which I ran many times before and am certain it worked:
"/cygdrive/c/Program Files (x86)/Microsoft Visual Studio 9.0/VC/bin/dumpbin.exe" /imports  odbcconfig.exe
C:/Program Files (x86)/Microsoft Visual Studio 9.0/VC/bin/dumpbin.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory

Double-click dumpbin.exe in Windows Explorer:
"The program can't start because mspdb80.dll is missing from your computer. Try reinstaling the program to fix this problem."

It seems installing AOO from SVN trunk results in loss of multiple system-wide CRT DLLs?
Comment 1 Peter 2018-12-13 10:30:10 UTC
Is this still an issue with latest trunk builds?